diff mbox series

[v2,1/1] openssl: Match target name for loongarch64

Message ID 20240226081335.501590-4-wuxiaotian@loongson.cn
State Accepted, archived
Commit 1e5b30d92da2e51e6a4ba75e2cc1e9ccebc8efe7
Headers show
Series openssl: Match target name for loongarch64 | expand

Commit Message

Xiaotian Wu Feb. 26, 2024, 8:13 a.m. UTC
From: Xiaotian Wu <yetist@gmail.com>

This is updated in openssl [1] since opensssl 3.2.0-alpha1 onwards

[1] https://github.com/openssl/openssl/commit/b625e21e67666213ffd3ba6b1f2cd8a847ba6b66

Signed-off-by: Xiaotian Wu <wuxiaotian@loongson.cn>
---
 meta/recipes-connectivity/openssl/openssl_3.2.1.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl_3.2.1.bb b/meta/recipes-connectivity/openssl/openssl_3.2.1.bb
index d3bf6248e3..1682b6f8cc 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.2.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.2.1.bb
@@ -96,6 +96,9 @@  do_configure () {
 	linux-gnu64-x86_64)
 		target=linux-x86_64
 		;;
+	linux-loongarch64)
+		target=linux64-loongarch64
+		;;
 	linux-mips | linux-mipsel)
 		# specifying TARGET_CC_ARCH prevents openssl from (incorrectly) adding target architecture flags
 		target="linux-mips32 ${TARGET_CC_ARCH}"