diff mbox series

Add user space utility:dropwatch

Message ID 20240209112421.45771-1-chen_heyun@163.com
State Rejected, archived
Headers show
Series Add user space utility:dropwatch | expand

Commit Message

chenheyun Feb. 9, 2024, 11:24 a.m. UTC
Signed-off-by: chenheyun <chen_heyun@163.com>
---
 .../dropwatch/dropwatch_git.bb                | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100755 meta/recipes-extended/dropwatch/dropwatch_git.bb

Comments

Ross Burton Feb. 9, 2024, 12:38 p.m. UTC | #1
On 9 Feb 2024, at 11:24, chenheyun via lists.openembedded.org <chen_heyun=163.com@lists.openembedded.org> wrote:
> +SUMMARY  = "User space utility to diagnose to NetWorking packets are getting dropped"
> +DESCRIPTION = "Dropwatch is an utility to interface to the kernel to monitor for dropped \
> +               network packets"

A useful tool, for sure, but I don’t see why this should be in oe-core.  I suggest adding it to meta-oe instead.

> +SRCREV = "853457b77dbc3d6665a379f3fe31ec53f11b6f61"
> +PV = "1.0.0"

These are contradictory.  853457b7 is the current HEAD, but the latest release is 1.5.4.

If you need to package a post-release snapshot, then set PV to "1.5.4+git”.

Ross
Jörg Sommer Feb. 9, 2024, 2:06 p.m. UTC | #2
Hi,

can you change the summary of the commit to something like `dropwatch: New userspace to diagnose network package drops`? It's common to name the module/component first and then what happened.

On 09.02.24 12:24, chenheyun via lists.openembedded.org wrote:
> Signed-off-by: chenheyun <chen_heyun@163.com>

Is your name "Chen Heyun"?

> ---
>  .../dropwatch/dropwatch_git.bb                | 22 +++++++++++++++++++
>  1 file changed, 22 insertions(+)
>  create mode 100755 meta/recipes-extended/dropwatch/dropwatch_git.bb
> 
> diff --git a/meta/recipes-extended/dropwatch/dropwatch_git.bb b/meta/recipes-extended/dropwatch/dropwatch_git.bb

Maybe the meta-openembedded/meta-networking would better fit and recipes-support directory.

> new file mode 100755
> index 0000000000..62a1eab777
> --- /dev/null
> +++ b/meta/recipes-extended/dropwatch/dropwatch_git.bb
> @@ -0,0 +1,22 @@
> +# Copyright (C) 2024 chenheyun <chen_heyun@163.com>
> +# Released under the MIT license (see COPYING.MIT for the terms)
> +
> +SUMMARY  = "User space utility to diagnose to NetWorking packets are getting dropped"
> +DESCRIPTION = "Dropwatch is an utility to interface to the kernel to monitor for dropped \
> +               network packets"
> +                   
> +HOMEPAGE = "https://github.com/nhorman/dropwatch/"
> +LICENSE = "GPLv2+"

Use the SPDX identifier `GPL-2.0-or-later`

> +LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
> +DEPENDS = "libnl readline libpcap binutils"
> +
> +PV = "1.0.0"

The common way is to put the version in the filename in place of `git`, i.e. `dropwatch_1.0.0.bb` and don't use the PV.

A useful tool to check the recipes is https://github.com/priv-kweihmann/oelint-adv/. You can use 

docker run -ti --rm -v "$(pwd):/code" -w /code -v oelint-adv-venv:/.venv \
  python:3.12-bookworm /bin/bash -c '
  python3 -m venv --upgrade-deps /.venv
  . /.venv/bin/activate
  python3 -m pip install oelint-adv
  oelint-adv layer/recipes/dropwatch/dropwatch_1.0.0.bb'

Kind regards

Jörg Sommer
Yoann Congal Feb. 9, 2024, 3:01 p.m. UTC | #3
Le 09/02/2024 à 12:24, chenheyun a écrit :
> Signed-off-by: chenheyun <chen_heyun@163.com>
> ---
>  .../dropwatch/dropwatch_git.bb                | 22 +++++++++++++++++++
>  1 file changed, 22 insertions(+)
>  create mode 100755 meta/recipes-extended/dropwatch/dropwatch_git.bb
> 
> diff --git a/meta/recipes-extended/dropwatch/dropwatch_git.bb b/meta/recipes-extended/dropwatch/dropwatch_git.bb
> new file mode 100755
> index 0000000000..62a1eab777
> --- /dev/null
> +++ b/meta/recipes-extended/dropwatch/dropwatch_git.bb
> @@ -0,0 +1,22 @@
> +# Copyright (C) 2024 chenheyun <chen_heyun@163.com>
> +# Released under the MIT license (see COPYING.MIT for the terms)
> +
> +SUMMARY  = "User space utility to diagnose to NetWorking packets are getting dropped"
> +DESCRIPTION = "Dropwatch is an utility to interface to the kernel to monitor for dropped \
> +               network packets"
> +                   
> +HOMEPAGE = "https://github.com/nhorman/dropwatch/"
> +LICENSE = "GPLv2+"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
> +DEPENDS = "libnl readline libpcap binutils"
> +
> +PV = "1.0.0"
> +
> +SRC_URI = "git://github.com/nhorman/dropwatch/;branch=master;protocol=https"
> +SRCREV = "853457b77dbc3d6665a379f3fe31ec53f11b6f61"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit autotools pkgconfig gettext
> +
> +BBCLASSEXTEND = "native nativesdk"


Happy to see this tool packaged, but, as Ross said, maybe not in OE-Core but in meta-openembedded instead.

That said, neither nativesdk-dropwatch nor dropwatch-native build:
  ERROR: Nothing PROVIDES 'nativesdk-libpcap' (but virtual:nativesdk:/home/yocon/Documents/projets/yocto/poky/meta/recipes-extended/dropwatch/dropwatch_git.bb DEPENDS on or otherwise requires it). Close matches:
    [...]
  ERROR: Required build target 'nativesdk-dropwatch' has no buildable providers.
  Missing or unbuildable dependency chain was: ['nativesdk-dropwatch', 'nativesdk-libpcap']

for dropwatch-native, logs are here: https://pastebin.com/Z6qEATiE

=> You need to drop the "native nativesdk" in BBCLASSEXTEND (or fix the build problem but I don't see the point of having this tool on the build/native host) 

Regards,
chenheyun Feb. 10, 2024, 5:33 a.m. UTC | #4
On Fri, Feb 9, 2024 at 11:01 PM, Yoann Congal wrote:

> 
> meta-openembedde

Hi,
i am doubt with OE-Core and meta-openembedded。
i am sure that OE-Core means: https://git.openembedded.org/openembedded-core/
meta-openembedded means what? like https://git.openembedded.org/openembedded/? ( https://git.openembedded.org/openembedded/ ) but https://git.openembedded.org/openembedded/ say "it has been replaced by a new model based upon OpenEmbedded-Core (OE-Core)"

what should i do?
please help me. thanks.
Richard Purdie Feb. 10, 2024, 7:40 a.m. UTC | #5
On Fri, 2024-02-09 at 21:33 -0800, chenheyun wrote:
> On Fri, Feb 9, 2024 at 11:01 PM, Yoann Congal wrote:
> > meta-openembedde
> Hi,
>    i am doubt with OE-Core and meta-openembedded。
> i am sure that OE-Core means:https://git.openembedded.org/openembedded-core/
> meta-openembedded means what? like https://git.openembedded.org/openembedded/? 
> but https://git.openembedded.org/openembedded/ say "it has been replaced by 
> a new model based upon OpenEmbedded-Core (OE-Core)"
> 
> what should i do? 
> please help me. thanks.

This is meta-openembedded:

https://git.openembedded.org/meta-openembedded/

Cheers,

Richard
chenheyun Feb. 10, 2024, 10:02 a.m. UTC | #6
Hi,
thank you very much.
we usually build our project,poky ,meta-openembedded, meta-selinux and so on.
https://git.openembedded.org/openembedded-core/  for what? ( https://git.openembedded.org/openembedded-core/ )
Alexander Kanavin Feb. 10, 2024, 10:30 a.m. UTC | #7
poky is a reference collection of several other repositories used for
testing, it includes bitbake, openembedded-core (both on
git.openembedded.org) and meta-yocto (on git.yoctoproject.org).

Alex

On Sat, 10 Feb 2024 at 11:02, chenheyun <chen_heyun@163.com> wrote:
>
> Hi,
>   thank you very much.
>   we usually build our project,poky ,meta-openembedded, meta-selinux and so on.
>   https://git.openembedded.org/openembedded-core/  for what?
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#195257): https://lists.openembedded.org/g/openembedded-core/message/195257
> Mute This Topic: https://lists.openembedded.org/mt/104256897/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/dropwatch/dropwatch_git.bb b/meta/recipes-extended/dropwatch/dropwatch_git.bb
new file mode 100755
index 0000000000..62a1eab777
--- /dev/null
+++ b/meta/recipes-extended/dropwatch/dropwatch_git.bb
@@ -0,0 +1,22 @@ 
+# Copyright (C) 2024 chenheyun <chen_heyun@163.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY  = "User space utility to diagnose to NetWorking packets are getting dropped"
+DESCRIPTION = "Dropwatch is an utility to interface to the kernel to monitor for dropped \
+               network packets"
+                   
+HOMEPAGE = "https://github.com/nhorman/dropwatch/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+DEPENDS = "libnl readline libpcap binutils"
+
+PV = "1.0.0"
+
+SRC_URI = "git://github.com/nhorman/dropwatch/;branch=master;protocol=https"
+SRCREV = "853457b77dbc3d6665a379f3fe31ec53f11b6f61"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig gettext
+
+BBCLASSEXTEND = "native nativesdk"