diff mbox series

python3-numpy: Use Large File Support version of fallocate

Message ID 20240125143606.4128407-1-olani@axis.com
State Accepted, archived
Commit 3d556e59f658ac29615fb7a14b6ea48533122ff6
Headers show
Series python3-numpy: Use Large File Support version of fallocate | expand

Commit Message

Ola x Nilsson Jan. 25, 2024, 2:36 p.m. UTC
This was supposed to always be the case from upstream but was exposed
by the 64-bit-time QA checker when file function scanning was enabled.

Signed-off-by: Ola x Nilsson <olani@axis.com>
---
 ...le-fallocate-on-32-bit-linux-platfor.patch | 49 +++++++++++++++++++
 .../python/python3-numpy_1.26.2.bb            |  1 +
 2 files changed, 50 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch b/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
new file mode 100644
index 0000000000..6972431192
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy/0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch
@@ -0,0 +1,49 @@ 
+From a67561c3c015589e26d156f82de8624533e3e6d7 Mon Sep 17 00:00:00 2001
+From: Ola x Nilsson <olani@axis.com>
+Date: Fri, 19 Jan 2024 10:26:41 +0100
+Subject: [PATCH] BUG: Use large file fallocate on 32 bit linux platforms
+
+Using a local prototype for fallocate instead of the fcntl.h header
+meant that the redirect triggered by -D_FILE_OFFSET_BITS=64 was not
+triggered.
+
+The prototypes in feature_detection_stdio.h should only be used by
+functions in setup_common.py. If they are used by the feature
+discovery code they might trigger false positives.
+
+Upstream-Status: Backport [https://github.com/numpy/numpy/commit/f49c6f9ea735cd7f718e74f8d637ffbbd3a7a03b]
+---
+ numpy/core/feature_detection_stdio.h | 3 +++
+ numpy/core/src/multiarray/convert.c  | 5 +++--
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/numpy/core/feature_detection_stdio.h b/numpy/core/feature_detection_stdio.h
+index bc14d16..d8bbfbd 100644
+--- a/numpy/core/feature_detection_stdio.h
++++ b/numpy/core/feature_detection_stdio.h
+@@ -1,6 +1,9 @@
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <fcntl.h>
+ 
++#if 0 /* Only for setup_common.py, not the C compiler */
+ off_t ftello(FILE *stream);
+ int fseeko(FILE *stream, off_t offset, int whence);
+ int fallocate(int, int, off_t, off_t);
++#endif
+diff --git a/numpy/core/src/multiarray/convert.c b/numpy/core/src/multiarray/convert.c
+index 60c1a1b..8ec0aee 100644
+--- a/numpy/core/src/multiarray/convert.c
++++ b/numpy/core/src/multiarray/convert.c
+@@ -23,8 +23,9 @@
+ #include "array_coercion.h"
+ #include "refcount.h"
+ 
+-int
+-fallocate(int fd, int mode, off_t offset, off_t len);
++#if defined(HAVE_FALLOCATE) && defined(__linux__)
++#include <fcntl.h>
++#endif
+ 
+ /*
+  * allocate nbytes of diskspace for file fp
diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.2.bb b/meta/recipes-devtools/python/python3-numpy_1.26.2.bb
index 253b334367..b28a6c0305 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.26.2.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.2.bb
@@ -12,6 +12,7 @@  SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
            file://0001-numpy-core-Define-RISCV-32-support.patch \
            file://fix_reproducibility.patch \
            file://run-ptest \
+           file://0001-BUG-Use-large-file-fallocate-on-32-bit-linux-platfor.patch \
            "
 SRC_URI[sha256sum] = "f65738447676ab5777f11e6bbbdb8ce11b785e105f690bc45966574816b6d3ea"