diff mbox series

[4/4] libunwind: clean up configuration

Message ID 20240117150720.3585669-4-ross.burton@arm.com
State Accepted, archived
Commit 2752f6a4f8a45afff3366e5aa75672ba6f994a23
Headers show
Series [1/4] musl: doesn't support riscv32 | expand

Commit Message

Ross Burton Jan. 17, 2024, 3:07 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Add a PACKAGECONFIG for the support for zlib-compressed debuginfo.

There's no need to explicitly enable reading of .debug_frame segments as
this is enabled automatically for arm/aarch64.

Enable static globally, there's not much to gain by making this
musl-specific.

Don't disable the tests on musl as they verify that libunwind can link,
which is important with external libucontext libraries.

No need to disable documentation on musl, as it's already disabled out
of the box.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-support/libunwind/libunwind_1.6.2.bb | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-support/libunwind/libunwind_1.6.2.bb b/meta/recipes-support/libunwind/libunwind_1.6.2.bb
index d40a2af26d3..3208785124a 100644
--- a/meta/recipes-support/libunwind/libunwind_1.6.2.bb
+++ b/meta/recipes-support/libunwind/libunwind_1.6.2.bb
@@ -21,13 +21,10 @@  COMPATIBLE_HOST:riscv32 = "null"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[lzma] = "--enable-minidebuginfo,--disable-minidebuginfo,xz"
+PACKAGECONFIG[zlib] = "--enable-zlibdebuginfo,--disable-zlibdebuginfo,zlib"
 PACKAGECONFIG[latexdocs] = "--enable-documentation, --disable-documentation, latex2man-native"
 
-EXTRA_OECONF:arm = "--enable-debug-frame"
-EXTRA_OECONF:armeb = "--enable-debug-frame"
-EXTRA_OECONF:aarch64 = "--enable-debug-frame"
-
-EXTRA_OECONF:append:libc-musl = " --disable-documentation --disable-tests --enable-static"
+EXTRA_OECONF = "--enable-static"
 
 # http://errors.yoctoproject.org/Errors/Details/20487/
 ARM_INSTRUCTION_SET:armv4 = "arm"