diff mbox series

[v2] glib-networking: Fix ptest failures with openssl backend

Message ID 20240109182350.1070414-1-raj.khem@gmail.com
State New
Headers show
Series [v2] glib-networking: Fix ptest failures with openssl backend | expand

Commit Message

Khem Raj Jan. 9, 2024, 6:23 p.m. UTC
Apply only when openssl is in packageconfigs, seems to work ok with
gnutls backend.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Make the patch apply only when openssl backend is used

 ...Disable-test_unclean_close_by_server.patch | 42 +++++++++++++++++++
 .../glib-networking/glib-networking_2.78.0.bb |  5 ++-
 2 files changed, 45 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch

Comments

Alexander Kanavin Jan. 9, 2024, 6:52 p.m. UTC | #1
Conditional patches complicate version updates and can silently cease to
apply if no one builds with them, please place the condition into the .c
code directly.

Alex

On Tue 9. Jan 2024 at 19.23, Khem Raj <raj.khem@gmail.com> wrote:

> Apply only when openssl is in packageconfigs, seems to work ok with
> gnutls backend.
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> v2: Make the patch apply only when openssl backend is used
>
>  ...Disable-test_unclean_close_by_server.patch | 42 +++++++++++++++++++
>  .../glib-networking/glib-networking_2.78.0.bb |  5 ++-
>  2 files changed, 45 insertions(+), 2 deletions(-)
>  create mode 100644
> meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
>
> diff --git
> a/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
> b/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
> new file mode 100644
> index 00000000000..44e92f52001
> --- /dev/null
> +++
> b/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
> @@ -0,0 +1,42 @@
> +From 378bb3b0bf001e66a89d100ba12ac183e8375c36 Mon Sep 17 00:00:00 2001
> +From: Khem Raj <raj.khem@gmail.com>
> +Date: Fri, 22 Dec 2023 09:46:36 -0800
> +Subject: [PATCH] tests: Disable test_unclean_close_by_server
> +
> +This test does not work reliably when openSSL support is enabled. This
> +is not default in OE therefore the ptest failure is not seen on AB
> +testing
> +
> +Fixes
> +
> +not ok /tls/openssl/connection/unclean-close-by-server -
> GLib-Net:ERROR:../tls/tests/connection.c:2374:test_unclean_close_by_server:
> assertion failed (test->read_error == (g-tls-error-quark, 6)): Error
> reading data from TLS socket: error:00000005:lib(0)::reason(5)
> (g-tls-error-quark, 1)
> +Bail out!
> +stderr:
> +**
> +GLib-Net:ERROR:../tls/tests/connection.c:2374:test_unclean_close_by_server:
> assertion failed (test->read_error == (g-tls-error-quark, 6)): Error
> reading data from TLS socket: error:00000005:lib(0)::reason(5)
> (g-tls-error-quark, 1)
> +
> +Issue is already reported upstream [1]
> +
> +[1] https://gitlab.gnome.org/GNOME/glib-networking/-/issues/219
> +Upstream-Status: Inappropriate [ Disabled test as a workaround until
> fixed ]
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +---
> + tls/tests/connection.c | 2 --
> + 1 file changed, 2 deletions(-)
> +
> +diff --git a/tls/tests/connection.c b/tls/tests/connection.c
> +index 62a7fbb..cc99645 100644
> +--- a/tls/tests/connection.c
> ++++ b/tls/tests/connection.c
> +@@ -3462,8 +3462,6 @@ main (int   argc,
> +               setup_connection, test_simultaneous_sync_rehandshake,
> teardown_connection);
> +   g_test_add ("/tls/" BACKEND "/connection/close-immediately",
> TestConnection, NULL,
> +               setup_connection, test_close_immediately,
> teardown_connection);
> +-  g_test_add ("/tls/" BACKEND "/connection/unclean-close-by-server",
> TestConnection, NULL,
> +-              setup_connection, test_unclean_close_by_server,
> teardown_connection);
> +   g_test_add ("/tls/" BACKEND "/connection/async-implicit-handshake",
> TestConnection, NULL,
> +               setup_connection, test_async_implicit_handshake,
> teardown_connection);
> +   g_test_add ("/tls/" BACKEND "/connection/output-stream-close",
> TestConnection, NULL,
> +--
> +2.43.0
> +
> diff --git a/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
> b/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
> index 68f9a2ed783..4576b3556c0 100644
> --- a/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
> +++ b/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
> @@ -30,8 +30,9 @@ PACKAGECONFIG[gnomeproxy] =
> "-Dgnome_proxy=enabled,-Dgnome_proxy=disabled,gsetti
>  inherit gnomebase gettext upstream-version-is-even gio-module-cache
> ptest-gnome
>
>  SRC_URI += "file://run-ptest"
> -SRC_URI += "file://eagain.patch"
> -
> +SRC_URI += "file://eagain.patch \
> +            ${@bb.utils.contains('PACKAGECONFIG', 'openssl',
> 'file://0001-tests-Disable-test_unclean_close_by_server.patch', '', d)} \
> +            "
>  FILES:${PN} += "\
>                  ${libdir}/gio/modules/libgio*.so \
>                  ${datadir}/dbus-1/services/ \
> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193474):
> https://lists.openembedded.org/g/openembedded-core/message/193474
> Mute This Topic: https://lists.openembedded.org/mt/103625368/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch b/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
new file mode 100644
index 00000000000..44e92f52001
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking/0001-tests-Disable-test_unclean_close_by_server.patch
@@ -0,0 +1,42 @@ 
+From 378bb3b0bf001e66a89d100ba12ac183e8375c36 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 22 Dec 2023 09:46:36 -0800
+Subject: [PATCH] tests: Disable test_unclean_close_by_server
+
+This test does not work reliably when openSSL support is enabled. This
+is not default in OE therefore the ptest failure is not seen on AB
+testing
+
+Fixes
+
+not ok /tls/openssl/connection/unclean-close-by-server - GLib-Net:ERROR:../tls/tests/connection.c:2374:test_unclean_close_by_server: assertion failed (test->read_error == (g-tls-error-quark, 6)): Error reading data from TLS socket: error:00000005:lib(0)::reason(5) (g-tls-error-quark, 1)
+Bail out!
+stderr:
+**
+GLib-Net:ERROR:../tls/tests/connection.c:2374:test_unclean_close_by_server: assertion failed (test->read_error == (g-tls-error-quark, 6)): Error reading data from TLS socket: error:00000005:lib(0)::reason(5) (g-tls-error-quark, 1)
+
+Issue is already reported upstream [1]
+
+[1] https://gitlab.gnome.org/GNOME/glib-networking/-/issues/219
+Upstream-Status: Inappropriate [ Disabled test as a workaround until fixed ]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tls/tests/connection.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tls/tests/connection.c b/tls/tests/connection.c
+index 62a7fbb..cc99645 100644
+--- a/tls/tests/connection.c
++++ b/tls/tests/connection.c
+@@ -3462,8 +3462,6 @@ main (int   argc,
+               setup_connection, test_simultaneous_sync_rehandshake, teardown_connection);
+   g_test_add ("/tls/" BACKEND "/connection/close-immediately", TestConnection, NULL,
+               setup_connection, test_close_immediately, teardown_connection);
+-  g_test_add ("/tls/" BACKEND "/connection/unclean-close-by-server", TestConnection, NULL,
+-              setup_connection, test_unclean_close_by_server, teardown_connection);
+   g_test_add ("/tls/" BACKEND "/connection/async-implicit-handshake", TestConnection, NULL,
+               setup_connection, test_async_implicit_handshake, teardown_connection);
+   g_test_add ("/tls/" BACKEND "/connection/output-stream-close", TestConnection, NULL,
+-- 
+2.43.0
+
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb b/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
index 68f9a2ed783..4576b3556c0 100644
--- a/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
+++ b/meta/recipes-core/glib-networking/glib-networking_2.78.0.bb
@@ -30,8 +30,9 @@  PACKAGECONFIG[gnomeproxy] = "-Dgnome_proxy=enabled,-Dgnome_proxy=disabled,gsetti
 inherit gnomebase gettext upstream-version-is-even gio-module-cache ptest-gnome
 
 SRC_URI += "file://run-ptest"
-SRC_URI += "file://eagain.patch"
-
+SRC_URI += "file://eagain.patch \
+            ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'file://0001-tests-Disable-test_unclean_close_by_server.patch', '', d)} \
+            "
 FILES:${PN} += "\
                 ${libdir}/gio/modules/libgio*.so \
                 ${datadir}/dbus-1/services/ \