diff mbox series

[v2,2/2] systemd-boot: Add efi stubs to systemd-boot-stubs PACKAGE

Message ID 20231213115748.487216-2-quic_vkraleti@quicinc.com
State New
Headers show
Series [v2,1/2] systemd-boot: Add recipe to compile native | expand

Commit Message

Viswanath Kraleti Dec. 13, 2023, 11:57 a.m. UTC
Place efi stubs generated by systemd-boot in systemd-boot-stubs package.
Currently these are only installed in DEPLOY_DIR, making it difficult to
consume from other recipes.

Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
---
 meta/recipes-core/systemd/systemd-boot_254.4.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_254.4.bb b/meta/recipes-core/systemd/systemd-boot_254.4.bb
index 2b43ccf243..45c08dcb31 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.4.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.4.bb
@@ -59,6 +59,8 @@  COMPATIBLE_HOST:x86-x32 = "null"
 do_install() {
 	install -d ${D}${EFI_FILES_PATH}
 	install ${B}/src/boot/efi/systemd-boot*.efi ${D}${EFI_FILES_PATH}/${SYSTEMD_BOOT_IMAGE}
+	install ${B}/src/boot/efi/linux*.efi.stub ${D}
+	install ${B}/src/boot/efi/addon*.efi.stub ${D}
 }
 
 do_deploy () {
@@ -69,3 +71,5 @@  do_deploy () {
 
 addtask deploy before do_build after do_compile
 
+PACKAGES += "${PN}-stubs"
+FILES:${PN}-stubs = "*.efi.stub"