diff mbox series

strace: Disable bluetooth support by default

Message ID 20231212233723.2543380-1-yoann.congal@smile.fr
State Accepted, archived
Commit 5dbfeea1c90c4dab9291d27da5a7ed1706e2ac2e
Headers show
Series strace: Disable bluetooth support by default | expand

Commit Message

Yoann Congal Dec. 12, 2023, 11:37 p.m. UTC
The bluetooth support adds a bluez5 dependency (and,recursively, a lot
of other stuff). Disable it by default to avoid having to build all of
this when it is not needed.

This decrease the number of tasks run for a core-image-minimal build by
~1000 (-21%).

To re-enable bluetooth support in strace, add "bluez" to strace
PACKAGECONFIG. For example, in local.conf:
  PACKAGECONFIG:append:pn-strace = "bluetooth"

Fixes [YOCTO #15323]

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
---
 meta/recipes-devtools/strace/strace_6.6.bb | 3 ---
 1 file changed, 3 deletions(-)

Comments

Tim Orling Dec. 13, 2023, 3:45 a.m. UTC | #1
On Tue, Dec 12, 2023 at 3:37 PM Yoann Congal <yoann.congal@smile.fr> wrote:

> The bluetooth support adds a bluez5 dependency (and,recursively, a lot
> of other stuff). Disable it by default to avoid having to build all of
> this when it is not needed.
>
> This decrease the number of tasks run for a core-image-minimal build by
> ~1000 (-21%).
>
> To re-enable bluetooth support in strace, add "bluez" to strace
> PACKAGECONFIG. For example, in local.conf:
>   PACKAGECONFIG:append:pn-strace = "bluetooth"

typo: = “bluez” unless you meant to reference the DISTRO_FEATURE?

>
>
> Fixes [YOCTO #15323]
>
> Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
> ---
>  meta/recipes-devtools/strace/strace_6.6.bb | 3 ---
>  1 file changed, 3 deletions(-)
>
> diff --git a/meta/recipes-devtools/strace/strace_6.6.bb
> b/meta/recipes-devtools/strace/strace_6.6.bb
> index a3de7941cf..c355b45b20 100644
> --- a/meta/recipes-devtools/strace/strace_6.6.bb
> +++ b/meta/recipes-devtools/strace/strace_6.6.bb
> @@ -22,9 +22,6 @@ inherit autotools ptest
>  # Not yet ported to rv32
>  COMPATIBLE_HOST:riscv32 = "null"
>
> -PACKAGECONFIG:class-target ??= "\
> -    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}
> \
> -"
>
>  PACKAGECONFIG[bluez] =
> "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
>  PACKAGECONFIG[libunwind] =
> "--with-libunwind,--without-libunwind,libunwind"
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192253):
> https://lists.openembedded.org/g/openembedded-core/message/192253
> Mute This Topic: https://lists.openembedded.org/mt/103140540/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Yoann Congal Dec. 13, 2023, 7:34 a.m. UTC | #2
Le 13/12/2023 à 04:45, Tim Orling a écrit :
> 
> 
> On Tue, Dec 12, 2023 at 3:37 PM Yoann Congal <yoann.congal@smile.fr <mailto:yoann.congal@smile.fr>> wrote:
> 
>     The bluetooth support adds a bluez5 dependency (and,recursively, a lot
>     of other stuff). Disable it by default to avoid having to build all of
>     this when it is not needed.
> 
>     This decrease the number of tasks run for a core-image-minimal build by
>     ~1000 (-21%).
> 
>     To re-enable bluetooth support in strace, add "bluez" to strace
>     PACKAGECONFIG. For example, in local.conf:
>       PACKAGECONFIG:append:pn-strace = "bluetooth"
> 
> typo: = “bluez” unless you meant to reference the DISTRO_FEATURE?

You are right, I meant
  PACKAGECONFIG:append:pn-strace = "bluez"
I've tested it, fixed it... and forgot to fix the commit -_-

Thanks! I will send a v2 shortly

> 
> 
> 
>     Fixes [YOCTO #15323]
> 
>     Signed-off-by: Yoann Congal <yoann.congal@smile.fr <mailto:yoann.congal@smile.fr>>
>     ---
>      meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb> | 3 ---
>      1 file changed, 3 deletions(-)
> 
>     diff --git a/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb> b/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     index a3de7941cf..c355b45b20 100644
>     --- a/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     +++ b/meta/recipes-devtools/strace/strace_6.6.bb <http://strace_6.6.bb>
>     @@ -22,9 +22,6 @@ inherit autotools ptest
>      # Not yet ported to rv32
>      COMPATIBLE_HOST:riscv32 = "null"
> 
>     -PACKAGECONFIG:class-target ??= "\
>     -    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
>     -"
> 
>      PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
>      PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
>     -- 
>     2.30.2
> 
> 
>     -=-=-=-=-=-=-=-=-=-=-=-
>     Links: You receive all messages sent to this group.
>     View/Reply Online (#192253): https://lists.openembedded.org/g/openembedded-core/message/192253 <https://lists.openembedded.org/g/openembedded-core/message/192253>
>     Mute This Topic: https://lists.openembedded.org/mt/103140540/924729 <https://lists.openembedded.org/mt/103140540/924729>
>     Group Owner: openembedded-core+owner@lists.openembedded.org <mailto:openembedded-core%2Bowner@lists.openembedded.org>
>     Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub <https://lists.openembedded.org/g/openembedded-core/unsub> [ticotimo@gmail.com <mailto:ticotimo@gmail.com>]
>     -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/strace/strace_6.6.bb b/meta/recipes-devtools/strace/strace_6.6.bb
index a3de7941cf..c355b45b20 100644
--- a/meta/recipes-devtools/strace/strace_6.6.bb
+++ b/meta/recipes-devtools/strace/strace_6.6.bb
@@ -22,9 +22,6 @@  inherit autotools ptest
 # Not yet ported to rv32
 COMPATIBLE_HOST:riscv32 = "null"
 
-PACKAGECONFIG:class-target ??= "\
-    ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
-"
 
 PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5"
 PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"