diff mbox series

[05/19] usbutils: upgrade 015 -> 017

Message ID 20231127101751.3187950-5-alex@linutronix.de
State New
Headers show
Series [01/19] sstate.bbclass: setscene_depvalid(): do not exclude shadow-native from task dependency resolution | expand

Commit Message

Alexander Kanavin Nov. 27, 2023, 10:17 a.m. UTC
Drop CFLAGS (containing host paths) from installed pkg-config file.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../usbutils/{usbutils_015.bb => usbutils_017.bb}           | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta/recipes-bsp/usbutils/{usbutils_015.bb => usbutils_017.bb} (86%)

Comments

Richard Purdie Dec. 1, 2023, 11:49 a.m. UTC | #1
On Mon, 2023-11-27 at 11:17 +0100, Alexander Kanavin wrote:
> Drop CFLAGS (containing host paths) from installed pkg-config file.
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  .../usbutils/{usbutils_015.bb => usbutils_017.bb}           | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>  rename meta/recipes-bsp/usbutils/{usbutils_015.bb => usbutils_017.bb} (86%)
> 
> diff --git a/meta/recipes-bsp/usbutils/usbutils_015.bb b/meta/recipes-bsp/usbutils/usbutils_017.bb
> similarity index 86%
> rename from meta/recipes-bsp/usbutils/usbutils_015.bb
> rename to meta/recipes-bsp/usbutils/usbutils_017.bb
> index a30037b6938..c62c6256fc8 100644
> --- a/meta/recipes-bsp/usbutils/usbutils_015.bb
> +++ b/meta/recipes-bsp/usbutils/usbutils_017.bb
> @@ -13,7 +13,7 @@ DEPENDS = "libusb1 virtual/libiconv udev"
>  
>  SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \
>            "
> -SRC_URI[sha256sum] = "2b8140664578f39c3f6f0166a1b950f8655304e63e3d7f89899acb99bc5cb8e7"
> +SRC_URI[sha256sum] = "f704c4cb78a060db88b43aac6ebfd3d93c2c5cf1d6dd0e42936faaf00814ab00"
>  
>  inherit autotools pkgconfig update-alternatives
>  
> @@ -30,3 +30,7 @@ RRECOMMENDS:${PN} = "udev-hwdb"
>  PACKAGE_BEFORE_PN =+ "${PN}-python"
>  FILES:${PN}-python += "${bindir}/lsusb.py"
>  RDEPENDS:${PN}-python = "python3-core"
> +
> +do_install:append() {
> +    sed -i -e "s,${WORKDIR},,g" ${D}/${libdir}/pkgconfig/*.pc
> +}

This looks like it removes WORKDIR, not CFLAGS so it doesn't quite
match the commit message?

I think it might be wise to put a comment in the code here saying
exactly what its doing so we can know in future too.

Cheers,

Richard
Alexander Kanavin Dec. 1, 2023, 12:17 p.m. UTC | #2
On Fri, 1 Dec 2023 at 12:49, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:

> This looks like it removes WORKDIR, not CFLAGS so it doesn't quite
> match the commit message?
>
> I think it might be wise to put a comment in the code here saying
> exactly what its doing so we can know in future too.

Yes, it drops WORKDIR from cflags value in the .pc file. The commit
message wasn't accurate.

Alex
diff mbox series

Patch

diff --git a/meta/recipes-bsp/usbutils/usbutils_015.bb b/meta/recipes-bsp/usbutils/usbutils_017.bb
similarity index 86%
rename from meta/recipes-bsp/usbutils/usbutils_015.bb
rename to meta/recipes-bsp/usbutils/usbutils_017.bb
index a30037b6938..c62c6256fc8 100644
--- a/meta/recipes-bsp/usbutils/usbutils_015.bb
+++ b/meta/recipes-bsp/usbutils/usbutils_017.bb
@@ -13,7 +13,7 @@  DEPENDS = "libusb1 virtual/libiconv udev"
 
 SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \
           "
-SRC_URI[sha256sum] = "2b8140664578f39c3f6f0166a1b950f8655304e63e3d7f89899acb99bc5cb8e7"
+SRC_URI[sha256sum] = "f704c4cb78a060db88b43aac6ebfd3d93c2c5cf1d6dd0e42936faaf00814ab00"
 
 inherit autotools pkgconfig update-alternatives
 
@@ -30,3 +30,7 @@  RRECOMMENDS:${PN} = "udev-hwdb"
 PACKAGE_BEFORE_PN =+ "${PN}-python"
 FILES:${PN}-python += "${bindir}/lsusb.py"
 RDEPENDS:${PN}-python = "python3-core"
+
+do_install:append() {
+    sed -i -e "s,${WORKDIR},,g" ${D}/${libdir}/pkgconfig/*.pc
+}