diff mbox series

[v2,2/2] ca-certificates-native: add certs path to SYSROOT_DIRS_NATIVE

Message ID 20231115215256.867653-2-p.lobacz@welotec.com
State New
Headers show
Series [v2,1/2] curl-native: add missing ca-certificates-native dependency | expand

Commit Message

Piotr Łobacz Nov. 15, 2023, 9:52 p.m. UTC
As curl-native needs CA bundle for establishing secure connection,
its installation is required in native environment.

Signed-off-by: Piotr Łobacz <p.lobacz@welotec.com>
---
 .../recipes-support/ca-certificates/ca-certificates_20211016.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Richard Purdie Nov. 15, 2023, 10:19 p.m. UTC | #1
On Wed, 2023-11-15 at 22:52 +0100, Piotr Łobacz wrote:
> As curl-native needs CA bundle for establishing secure connection,
> its installation is required in native environment.
> 
> Signed-off-by: Piotr Łobacz <p.lobacz@welotec.com>
> ---
>  .../recipes-support/ca-certificates/ca-certificates_20211016.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> index 99abe60613..0d55bae845 100644
> --- a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> +++ b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> @@ -86,4 +86,6 @@ RDEPENDS:${PN}:append:class-target = " openssl-bin openssl"
>  RDEPENDS:${PN}:append:class-native = " openssl-native"
>  RDEPENDS:${PN}:append:class-nativesdk = " nativesdk-openssl-bin nativesdk-openssl"
>  
> +SYSROOT_DIRS_NATIVE += "${sysconfdir}/ssl/certs"
> +
>  BBCLASSEXTEND = "native nativesdk"

If I look at SYSROOT_DIRS_NATIVE in staging.bbclass, it has   
${sysconfdir} already listed in it. That makes me wonder if this is
really needed?

Cheers,

Richard
Piotr Łobacz Nov. 15, 2023, 10:45 p.m. UTC | #2
Dnia środa, 15 listopada 2023 23:19:40 CET Richard Purdie pisze:
> On Wed, 2023-11-15 at 22:52 +0100, Piotr Łobacz wrote:
> > As curl-native needs CA bundle for establishing secure connection,
> > its installation is required in native environment.
> > 
> > Signed-off-by: Piotr Łobacz <p.lobacz@welotec.com>
> > ---
> > 
> >  .../recipes-support/ca-certificates/ca-certificates_20211016.bb | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git
> > a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> > b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb index
> > 99abe60613..0d55bae845 100644
> > --- a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> > +++ b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
> > @@ -86,4 +86,6 @@ RDEPENDS:${PN}:append:class-target = " openssl-bin
> > openssl"> 
> >  RDEPENDS:${PN}:append:class-native = " openssl-native"
> >  RDEPENDS:${PN}:append:class-nativesdk = " nativesdk-openssl-bin
> >  nativesdk-openssl"> 
> > +SYSROOT_DIRS_NATIVE += "${sysconfdir}/ssl/certs"
> > +
> > 
> >  BBCLASSEXTEND = "native nativesdk"
> 
> If I look at SYSROOT_DIRS_NATIVE in staging.bbclass, it has
> ${sysconfdir} already listed in it. That makes me wonder if this is
> really needed?

Yeah, I see it but somehow it was not working without it, need to test it 
more...

> 
> Cheers,
> 
> Richard

BR
Piotr
diff mbox series

Patch

diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
index 99abe60613..0d55bae845 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20211016.bb
@@ -86,4 +86,6 @@  RDEPENDS:${PN}:append:class-target = " openssl-bin openssl"
 RDEPENDS:${PN}:append:class-native = " openssl-native"
 RDEPENDS:${PN}:append:class-nativesdk = " nativesdk-openssl-bin nativesdk-openssl"
 
+SYSROOT_DIRS_NATIVE += "${sysconfdir}/ssl/certs"
+
 BBCLASSEXTEND = "native nativesdk"