diff mbox series

[V2] strace: skip so_peerpidfd test

Message ID 20231006211404.4161211-1-Randy.MacLeod@windriver.com
State Accepted, archived
Commit d7c9afbef0b440f5dbd16b3e8a3cb1ac5c513836
Headers show
Series [V2] strace: skip so_peerpidfd test | expand

Commit Message

Randy MacLeod Oct. 6, 2023, 9:14 p.m. UTC
From: Randy MacLeod <Randy.MacLeod@windriver.com>

The so_peerpidfd test is failing due to a difference of square brackets
in part of the log file. Skip the failing test until the difference is
understood and fixed.

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
---
 .../skip-test-so_peerpidfd.gen.test.patch     | 25 +++++++++++++++++++
 meta/recipes-devtools/strace/strace_6.5.bb    |  1 +
 2 files changed, 26 insertions(+)
 create mode 100644 meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch

Comments

Alexander Kanavin Oct. 11, 2023, 8:06 a.m. UTC | #1
Is this a recent regression tied to some other commit or is this
intermittent? What does the output look like? Is there an upstream
ticket?

How the failure occurs to be better documented, and upstreams do need
to be notified, please don't just add pending patches to quickly
resolve AB fails.

Alex

On Fri, 6 Oct 2023 at 23:14, Randy MacLeod via lists.openembedded.org
<randy.macleod=windriver.com@lists.openembedded.org> wrote:
>
> From: Randy MacLeod <Randy.MacLeod@windriver.com>
>
> The so_peerpidfd test is failing due to a difference of square brackets
> in part of the log file. Skip the failing test until the difference is
> understood and fixed.
>
> Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
> ---
>  .../skip-test-so_peerpidfd.gen.test.patch     | 25 +++++++++++++++++++
>  meta/recipes-devtools/strace/strace_6.5.bb    |  1 +
>  2 files changed, 26 insertions(+)
>  create mode 100644 meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch
>
> diff --git a/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch b/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch
> new file mode 100644
> index 0000000000..76f93ab613
> --- /dev/null
> +++ b/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch
> @@ -0,0 +1,25 @@
> +From 002d9f2512245536dfc8d62db429d97e2216ec3a Mon Sep 17 00:00:00 2001
> +From: Randy MacLeod <Randy.MacLeod@windriver.com>
> +Date: Fri, 6 Oct 2023 12:08:23 -0700
> +Subject: [PATCH] skip tests/so_peerpidfd.gen.test
> +
> +Upstream-Status: Pending
> +
> +Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
> +---
> + tests/so_peerpidfd.gen.test | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/tests/so_peerpidfd.gen.test b/tests/so_peerpidfd.gen.test
> +index 64ad3a2..f89da9f 100755
> +--- a/tests/so_peerpidfd.gen.test
> ++++ b/tests/so_peerpidfd.gen.test
> +@@ -1,4 +1,5 @@
> + #!/bin/sh -efu
> + # Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (so_peerpidfd --trace=getsockopt -y); do not edit.
> + . "${srcdir=.}/init.sh"
> ++skip_ "Test fails due to apparently trivial log format differences"
> + run_strace_match_diff --trace=getsockopt -y
> +--
> +2.39.0
> +
> diff --git a/meta/recipes-devtools/strace/strace_6.5.bb b/meta/recipes-devtools/strace/strace_6.5.bb
> index 8f90c35925..d6475e8db9 100644
> --- a/meta/recipes-devtools/strace/strace_6.5.bb
> +++ b/meta/recipes-devtools/strace/strace_6.5.bb
> @@ -14,6 +14,7 @@ SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
>             file://skip-load.patch \
>             file://0001-configure-Use-autoconf-macro-to-detect-largefile-sup.patch \
>             file://0002-tests-Replace-off64_t-with-off_t.patch \
> +           file://skip-test-so_peerpidfd.gen.test.patch \
>             "
>  SRC_URI[sha256sum] = "dfb051702389e1979a151892b5901afc9e93bbc1c70d84c906ade3224ca91980"
>
> --
> 2.39.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188786): https://lists.openembedded.org/g/openembedded-core/message/188786
> Mute This Topic: https://lists.openembedded.org/mt/101806877/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Oct. 11, 2023, 8:51 a.m. UTC | #2
On Wed, 2023-10-11 at 10:06 +0200, Alexander Kanavin wrote:
> Is this a recent regression tied to some other commit or is this
> intermittent? What does the output look like? Is there an upstream
> ticket?
> 
> How the failure occurs to be better documented, and upstreams do need
> to be notified, please don't just add pending patches to quickly
> resolve AB fails.

In the v3 a note was added that this is a 6.5 kernel issue. I suspect
upstream can and will resolve it when they get to that kernel version,
we're just not there yet. In the meantime we have a ton of other issues
with 6.5 so having this noise removed is extremely helpful.

I appreciate it isn't ideal but we do need to pull all the loose ends
together and get our 4.3 release happening at this point.

The commit that merged does mention the kernel version element.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch b/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch
new file mode 100644
index 0000000000..76f93ab613
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/skip-test-so_peerpidfd.gen.test.patch
@@ -0,0 +1,25 @@ 
+From 002d9f2512245536dfc8d62db429d97e2216ec3a Mon Sep 17 00:00:00 2001
+From: Randy MacLeod <Randy.MacLeod@windriver.com>
+Date: Fri, 6 Oct 2023 12:08:23 -0700
+Subject: [PATCH] skip tests/so_peerpidfd.gen.test
+
+Upstream-Status: Pending
+
+Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
+---
+ tests/so_peerpidfd.gen.test | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/so_peerpidfd.gen.test b/tests/so_peerpidfd.gen.test
+index 64ad3a2..f89da9f 100755
+--- a/tests/so_peerpidfd.gen.test
++++ b/tests/so_peerpidfd.gen.test
+@@ -1,4 +1,5 @@
+ #!/bin/sh -efu
+ # Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (so_peerpidfd --trace=getsockopt -y); do not edit.
+ . "${srcdir=.}/init.sh"
++skip_ "Test fails due to apparently trivial log format differences"
+ run_strace_match_diff --trace=getsockopt -y
+-- 
+2.39.0
+
diff --git a/meta/recipes-devtools/strace/strace_6.5.bb b/meta/recipes-devtools/strace/strace_6.5.bb
index 8f90c35925..d6475e8db9 100644
--- a/meta/recipes-devtools/strace/strace_6.5.bb
+++ b/meta/recipes-devtools/strace/strace_6.5.bb
@@ -14,6 +14,7 @@  SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
            file://skip-load.patch \
            file://0001-configure-Use-autoconf-macro-to-detect-largefile-sup.patch \
            file://0002-tests-Replace-off64_t-with-off_t.patch \
+           file://skip-test-so_peerpidfd.gen.test.patch \
            "
 SRC_URI[sha256sum] = "dfb051702389e1979a151892b5901afc9e93bbc1c70d84c906ade3224ca91980"