diff mbox series

[06/17] python3-click: Copy recipe from meta-python

Message ID 20230922144628.2495839-7-samantha.jalabert@syslinbit.com
State Accepted, archived
Commit 05eb1b2feff36ab7d1525febf644316bd57a1299
Headers show
Series python3-spdx-tools implementation | expand

Commit Message

Samantha Jalabert Sept. 22, 2023, 2:46 p.m. UTC
From: Samantha Jalabert <samantha.jalabert@syslinbit.com>

commit: 1a14a28f132a10e9db7b3e5bb2b5361c4679946e

Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
---
 .../python/python3-click/run-ptest            |  3 ++
 .../python/python3-click_8.1.7.bb             | 39 +++++++++++++++++++
 2 files changed, 42 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-click/run-ptest
 create mode 100644 meta/recipes-devtools/python/python3-click_8.1.7.bb

Comments

Khem Raj Sept. 22, 2023, 3:24 p.m. UTC | #1
On 9/22/23 7:46 AM, Samantha Jalabert wrote:
> From: Samantha Jalabert <samantha.jalabert@syslinbit.com>
> 
> commit: 1a14a28f132a10e9db7b3e5bb2b5361c4679946e
> 
> Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>

Please send a removal patch for meta-python as well. So we can keep 
passing the yp compat checks for meta-openembedded on AB and coordinate 
the change between meta-python and oe-core

> ---
>   .../python/python3-click/run-ptest            |  3 ++
>   .../python/python3-click_8.1.7.bb             | 39 +++++++++++++++++++
>   2 files changed, 42 insertions(+)
>   create mode 100644 meta/recipes-devtools/python/python3-click/run-ptest
>   create mode 100644 meta/recipes-devtools/python/python3-click_8.1.7.bb
> 
> diff --git a/meta/recipes-devtools/python/python3-click/run-ptest b/meta/recipes-devtools/python/python3-click/run-ptest
> new file mode 100644
> index 0000000000..b63c4de0d9
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-click/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> diff --git a/meta/recipes-devtools/python/python3-click_8.1.7.bb b/meta/recipes-devtools/python/python3-click_8.1.7.bb
> new file mode 100644
> index 0000000000..a4ec6cd1ef
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-click_8.1.7.bb
> @@ -0,0 +1,39 @@
> +SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
> +DESCRIPTION = "\
> +Click is a Python package for creating beautiful command line interfaces \
> +in a composable way with as little code as necessary. It's the "Command \
> +Line Interface Creation Kit". It's highly configurable but comes with \
> +sensible defaults out of the box."
> +HOMEPAGE = "http://click.pocoo.org/"
> +LICENSE = "BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
> +
> +SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
> +
> +inherit pypi setuptools3 ptest
> +
> +SRC_URI += "file://run-ptest"
> +
> +RDEPENDS:${PN}-ptest += " \
> +	${PYTHON_PN}-pytest \
> +	${PYTHON_PN}-terminal \
> +	${PYTHON_PN}-unixadmin \
> +"
> +
> +do_install_ptest() {
> +    install -d ${D}${PTEST_PATH}/tests
> +    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> +    cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
> +    cp -rf ${S}/docs ${D}${PTEST_PATH}/
> +}
> +
> +UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
> +
> +CLEANBROKEN = "1"
> +
> +RDEPENDS:${PN} += "\
> +    ${PYTHON_PN}-io \
> +    ${PYTHON_PN}-threading \
> +    "
> +
> +BBCLASSEXTEND = "native nativesdk"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188109): https://lists.openembedded.org/g/openembedded-core/message/188109
> Mute This Topic: https://lists.openembedded.org/mt/101522496/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Marta Rybczynska Sept. 22, 2023, 6:10 p.m. UTC | #2
Sure Khem,
We wanted to make sure there are no major objections to this patchset and
immediately follow with removals in meta-openembedded.

Cheers,
Marta

On Fri, 22 Sept 2023, 17:24 Khem Raj, <raj.khem@gmail.com> wrote:

> On 9/22/23 7:46 AM, Samantha Jalabert wrote:
> > From: Samantha Jalabert <samantha.jalabert@syslinbit.com>
> >
> > commit: 1a14a28f132a10e9db7b3e5bb2b5361c4679946e
> >
> > Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
>
> Please send a removal patch for meta-python as well. So we can keep
> passing the yp compat checks for meta-openembedded on AB and coordinate
> the change between meta-python and oe-core
>
> > ---
> >   .../python/python3-click/run-ptest            |  3 ++
> >   .../python/python3-click_8.1.7.bb             | 39 +++++++++++++++++++
> >   2 files changed, 42 insertions(+)
> >   create mode 100644 meta/recipes-devtools/python/python3-click/run-ptest
> >   create mode 100644 meta/recipes-devtools/python/python3-click_8.1.7.bb
> >
> > diff --git a/meta/recipes-devtools/python/python3-click/run-ptest
> b/meta/recipes-devtools/python/python3-click/run-ptest
> > new file mode 100644
> > index 0000000000..b63c4de0d9
> > --- /dev/null
> > +++ b/meta/recipes-devtools/python/python3-click/run-ptest
> > @@ -0,0 +1,3 @@
> > +#!/bin/sh
> > +
> > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'|
> sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e
> 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" ||
> $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk
> '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" ||
> $NF=="XPASS") {$NF="";print $0}else{print}}'
> > diff --git a/meta/recipes-devtools/python/python3-click_8.1.7.bb
> b/meta/recipes-devtools/python/python3-click_8.1.7.bb
> > new file mode 100644
> > index 0000000000..a4ec6cd1ef
> > --- /dev/null
> > +++ b/meta/recipes-devtools/python/python3-click_8.1.7.bb
> > @@ -0,0 +1,39 @@
> > +SUMMARY = "A simple wrapper around optparse for powerful command line
> utilities."
> > +DESCRIPTION = "\
> > +Click is a Python package for creating beautiful command line
> interfaces \
> > +in a composable way with as little code as necessary. It's the "Command
> \
> > +Line Interface Creation Kit". It's highly configurable but comes with \
> > +sensible defaults out of the box."
> > +HOMEPAGE = "http://click.pocoo.org/"
> > +LICENSE = "BSD-3-Clause"
> > +LIC_FILES_CHKSUM =
> "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
> > +
> > +SRC_URI[sha256sum] =
> "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
> > +
> > +inherit pypi setuptools3 ptest
> > +
> > +SRC_URI += "file://run-ptest"
> > +
> > +RDEPENDS:${PN}-ptest += " \
> > +     ${PYTHON_PN}-pytest \
> > +     ${PYTHON_PN}-terminal \
> > +     ${PYTHON_PN}-unixadmin \
> > +"
> > +
> > +do_install_ptest() {
> > +    install -d ${D}${PTEST_PATH}/tests
> > +    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> > +    cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
> > +    cp -rf ${S}/docs ${D}${PTEST_PATH}/
> > +}
> > +
> > +UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
> > +
> > +CLEANBROKEN = "1"
> > +
> > +RDEPENDS:${PN} += "\
> > +    ${PYTHON_PN}-io \
> > +    ${PYTHON_PN}-threading \
> > +    "
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> >
> >
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188123):
> https://lists.openembedded.org/g/openembedded-core/message/188123
> Mute This Topic: https://lists.openembedded.org/mt/101522496/5827677
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> rybczynska@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-click/run-ptest b/meta/recipes-devtools/python/python3-click/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-click/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta/recipes-devtools/python/python3-click_8.1.7.bb b/meta/recipes-devtools/python/python3-click_8.1.7.bb
new file mode 100644
index 0000000000..a4ec6cd1ef
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-click_8.1.7.bb
@@ -0,0 +1,39 @@ 
+SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
+DESCRIPTION = "\
+Click is a Python package for creating beautiful command line interfaces \
+in a composable way with as little code as necessary. It's the "Command \
+Line Interface Creation Kit". It's highly configurable but comes with \
+sensible defaults out of the box."
+HOMEPAGE = "http://click.pocoo.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
+
+SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += "file://run-ptest"
+
+RDEPENDS:${PN}-ptest += " \
+	${PYTHON_PN}-pytest \
+	${PYTHON_PN}-terminal \
+	${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+    install -d ${D}${PTEST_PATH}/tests
+    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+    cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
+    cp -rf ${S}/docs ${D}${PTEST_PATH}/
+}
+
+UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
+
+CLEANBROKEN = "1"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-io \
+    ${PYTHON_PN}-threading \
+    "
+
+BBCLASSEXTEND = "native nativesdk"