diff mbox series

[25/40] meson: upgrade 1.1.1 -> 1.2.1

Message ID 20230922072431.1481743-25-alex@linutronix.de
State Accepted, archived
Commit de38f7a5f3b374ab0006d50168c84da7f08a7a9e
Headers show
Series [01/40] systemd: upgrade 254 -> 254.4 | expand

Commit Message

Alexander Kanavin Sept. 22, 2023, 7:24 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../0001-Make-CPU-family-warnings-fatal.patch | 32 +++++++++----------
 .../meson/{meson_1.1.1.bb => meson_1.2.1.bb}  |  2 +-
 2 files changed, 17 insertions(+), 17 deletions(-)
 rename meta/recipes-devtools/meson/{meson_1.1.1.bb => meson_1.2.1.bb} (98%)

Comments

Khem Raj Sept. 25, 2023, 4:46 p.m. UTC | #1
gnupg failure seems related to this -
https://errors.yoctoproject.org/Errors/Details/738191/

On Fri, Sep 22, 2023 at 12:25 AM Alexander Kanavin
<alex.kanavin@gmail.com> wrote:
>
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  .../0001-Make-CPU-family-warnings-fatal.patch | 32 +++++++++----------
>  .../meson/{meson_1.1.1.bb => meson_1.2.1.bb}  |  2 +-
>  2 files changed, 17 insertions(+), 17 deletions(-)
>  rename meta/recipes-devtools/meson/{meson_1.1.1.bb => meson_1.2.1.bb} (98%)
>
> diff --git a/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch b/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
> index 848dccfbe72..8fbcb5a0a23 100644
> --- a/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
> +++ b/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
> @@ -1,4 +1,4 @@
> -From 6c4eef1d92e9e42fdbc888365cab3c95fb33c605 Mon Sep 17 00:00:00 2001
> +From fcd3260c03f313676720e6219c5953d412fb0a2c Mon Sep 17 00:00:00 2001
>  From: Ross Burton <ross.burton@intel.com>
>  Date: Tue, 3 Jul 2018 13:59:09 +0100
>  Subject: [PATCH] Make CPU family warnings fatal
> @@ -7,15 +7,15 @@ Upstream-Status: Inappropriate [OE specific]
>  Signed-off-by: Ross Burton <ross.burton@intel.com>
>
>  ---
> - mesonbuild/envconfig.py   | 2 +-
> - mesonbuild/environment.py | 4 +---
> - 2 files changed, 2 insertions(+), 4 deletions(-)
> + mesonbuild/envconfig.py   | 4 ++--
> + mesonbuild/environment.py | 6 ++----
> + 2 files changed, 4 insertions(+), 6 deletions(-)
>
> -Index: meson-0.60.2/mesonbuild/envconfig.py
> -===================================================================
> ---- meson-0.60.2.orig/mesonbuild/envconfig.py
> -+++ meson-0.60.2/mesonbuild/envconfig.py
> -@@ -266,8 +266,8 @@ class MachineInfo(HoldableObject):
> +diff --git a/mesonbuild/envconfig.py b/mesonbuild/envconfig.py
> +index 7e0c567..a180065 100644
> +--- a/mesonbuild/envconfig.py
> ++++ b/mesonbuild/envconfig.py
> +@@ -284,8 +284,8 @@ class MachineInfo(HoldableObject):
>                   'but is missing {}.'.format(minimum_literal - set(literal)))
>
>           cpu_family = literal['cpu_family']
> @@ -26,13 +26,13 @@ Index: meson-0.60.2/mesonbuild/envconfig.py
>
>           endian = literal['endian']
>           if endian not in ('little', 'big'):
> -Index: meson-0.60.2/mesonbuild/environment.py
> -===================================================================
> ---- meson-0.60.2.orig/mesonbuild/environment.py
> -+++ meson-0.60.2/mesonbuild/environment.py
> -@@ -354,10 +354,8 @@ def detect_cpu_family(compilers: Compile
> -         if any_compiler_has_define(compilers, '__64BIT__'):
> -             trial = 'ppc64'
> +diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
> +index e212c7a..9d2bff3 100644
> +--- a/mesonbuild/environment.py
> ++++ b/mesonbuild/environment.py
> +@@ -345,10 +345,8 @@ def detect_cpu_family(compilers: CompilersDict) -> str:
> +         if compilers and not any_compiler_has_define(compilers, '__mips64'):
> +             trial = 'mips'
>
>  -    if trial not in known_cpu_families:
>  -        mlog.warning(f'Unknown CPU family {trial!r}, please report this at '
> diff --git a/meta/recipes-devtools/meson/meson_1.1.1.bb b/meta/recipes-devtools/meson/meson_1.2.1.bb
> similarity index 98%
> rename from meta/recipes-devtools/meson/meson_1.1.1.bb
> rename to meta/recipes-devtools/meson/meson_1.2.1.bb
> index dd97f93aef6..fe452662029 100644
> --- a/meta/recipes-devtools/meson/meson_1.1.1.bb
> +++ b/meta/recipes-devtools/meson/meson_1.2.1.bb
> @@ -15,7 +15,7 @@ SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \
>             file://0001-Make-CPU-family-warnings-fatal.patch \
>             file://0002-Support-building-allarch-recipes-again.patch \
>             "
> -SRC_URI[sha256sum] = "d04b541f97ca439fb82fab7d0d480988be4bd4e62563a5ca35fadb5400727b1c"
> +SRC_URI[sha256sum] = "b1db3a153087549497ee52b1c938d2134e0338214fe14f7efd16fecd57b639f5"
>
>  inherit python_setuptools_build_meta github-releases
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188068): https://lists.openembedded.org/g/openembedded-core/message/188068
> Mute This Topic: https://lists.openembedded.org/mt/101516872/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Martin Jansa Sept. 26, 2023, 5:55 p.m. UTC | #2
On Mon, Sep 25, 2023 at 6:47 PM Khem Raj <raj.khem@gmail.com> wrote:

> gnupg failure seems related to this -
> https://errors.yoctoproject.org/Errors/Details/738191/


I've just sent a fix for this one (gupnp not gnupg :)):
https://lists.openembedded.org/g/openembedded-devel/message/105145
Khem Raj Sept. 26, 2023, 7:45 p.m. UTC | #3
On Tue, Sep 26, 2023 at 10:55 AM Martin Jansa <martin.jansa@gmail.com> wrote:
>
> On Mon, Sep 25, 2023 at 6:47 PM Khem Raj <raj.khem@gmail.com> wrote:
>>
>> gnupg failure seems related to this -
>> https://errors.yoctoproject.org/Errors/Details/738191/
>
>
> I've just sent a fix for this one (gupnp not gnupg :)):

Yeah poor eyes and spellchecker have me at times. Thanks for chiming
in with a patch

> https://lists.openembedded.org/g/openembedded-devel/message/105145
diff mbox series

Patch

diff --git a/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch b/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
index 848dccfbe72..8fbcb5a0a23 100644
--- a/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
+++ b/meta/recipes-devtools/meson/meson/0001-Make-CPU-family-warnings-fatal.patch
@@ -1,4 +1,4 @@ 
-From 6c4eef1d92e9e42fdbc888365cab3c95fb33c605 Mon Sep 17 00:00:00 2001
+From fcd3260c03f313676720e6219c5953d412fb0a2c Mon Sep 17 00:00:00 2001
 From: Ross Burton <ross.burton@intel.com>
 Date: Tue, 3 Jul 2018 13:59:09 +0100
 Subject: [PATCH] Make CPU family warnings fatal
@@ -7,15 +7,15 @@  Upstream-Status: Inappropriate [OE specific]
 Signed-off-by: Ross Burton <ross.burton@intel.com>
 
 ---
- mesonbuild/envconfig.py   | 2 +-
- mesonbuild/environment.py | 4 +---
- 2 files changed, 2 insertions(+), 4 deletions(-)
+ mesonbuild/envconfig.py   | 4 ++--
+ mesonbuild/environment.py | 6 ++----
+ 2 files changed, 4 insertions(+), 6 deletions(-)
 
-Index: meson-0.60.2/mesonbuild/envconfig.py
-===================================================================
---- meson-0.60.2.orig/mesonbuild/envconfig.py
-+++ meson-0.60.2/mesonbuild/envconfig.py
-@@ -266,8 +266,8 @@ class MachineInfo(HoldableObject):
+diff --git a/mesonbuild/envconfig.py b/mesonbuild/envconfig.py
+index 7e0c567..a180065 100644
+--- a/mesonbuild/envconfig.py
++++ b/mesonbuild/envconfig.py
+@@ -284,8 +284,8 @@ class MachineInfo(HoldableObject):
                  'but is missing {}.'.format(minimum_literal - set(literal)))
  
          cpu_family = literal['cpu_family']
@@ -26,13 +26,13 @@  Index: meson-0.60.2/mesonbuild/envconfig.py
  
          endian = literal['endian']
          if endian not in ('little', 'big'):
-Index: meson-0.60.2/mesonbuild/environment.py
-===================================================================
---- meson-0.60.2.orig/mesonbuild/environment.py
-+++ meson-0.60.2/mesonbuild/environment.py
-@@ -354,10 +354,8 @@ def detect_cpu_family(compilers: Compile
-         if any_compiler_has_define(compilers, '__64BIT__'):
-             trial = 'ppc64'
+diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
+index e212c7a..9d2bff3 100644
+--- a/mesonbuild/environment.py
++++ b/mesonbuild/environment.py
+@@ -345,10 +345,8 @@ def detect_cpu_family(compilers: CompilersDict) -> str:
+         if compilers and not any_compiler_has_define(compilers, '__mips64'):
+             trial = 'mips'
  
 -    if trial not in known_cpu_families:
 -        mlog.warning(f'Unknown CPU family {trial!r}, please report this at '
diff --git a/meta/recipes-devtools/meson/meson_1.1.1.bb b/meta/recipes-devtools/meson/meson_1.2.1.bb
similarity index 98%
rename from meta/recipes-devtools/meson/meson_1.1.1.bb
rename to meta/recipes-devtools/meson/meson_1.2.1.bb
index dd97f93aef6..fe452662029 100644
--- a/meta/recipes-devtools/meson/meson_1.1.1.bb
+++ b/meta/recipes-devtools/meson/meson_1.2.1.bb
@@ -15,7 +15,7 @@  SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \
            file://0001-Make-CPU-family-warnings-fatal.patch \
            file://0002-Support-building-allarch-recipes-again.patch \
            "
-SRC_URI[sha256sum] = "d04b541f97ca439fb82fab7d0d480988be4bd4e62563a5ca35fadb5400727b1c"
+SRC_URI[sha256sum] = "b1db3a153087549497ee52b1c938d2134e0338214fe14f7efd16fecd57b639f5"
 
 inherit python_setuptools_build_meta github-releases