diff mbox series

[v2] mdadm: disable strace on rv32 arch

Message ID 20230818165738.23592-1-dmitry.baryshkov@linaro.org
State Accepted, archived
Commit 9eca859f3bad9a881162f514d6147be5fd1351d9
Headers show
Series [v2] mdadm: disable strace on rv32 arch | expand

Commit Message

Dmitry Baryshkov Aug. 18, 2023, 4:57 p.m. UTC
strace program is not yet ported to RiscV 32 arch. Disable corresponding
dependency and test to remove dependency on the non-existing package,
which otherwise breaks building of core images:

ERROR: Nothing RPROVIDES 'strace' (but /oe/poky/meta/recipes-extended/mdadm/mdadm_4.2.bb RDEPENDS on or otherwise requires it)
strace was skipped: incompatible with host riscv32-poky-linux (not in COMPATIBLE_HOST)
NOTE: Runtime target 'strace' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['strace']
NOTE: Runtime target 'mdadm' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['mdadm', 'strace']
NOTE: Runtime target 'matchbox-terminal' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']
ERROR: Required build target 'core-image-weston' has no buildable providers.
Missing or unbuildable dependency chain was: ['core-image-weston', 'matchbox-terminal', 'gtk+3', 'glib-2.0', 'util-linux', 'mdadm', 'strace']

Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
---
 meta/recipes-extended/mdadm/mdadm_4.2.bb | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
index fa50325f1f71..82b8175b9d6e 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
@@ -126,3 +126,10 @@  RRECOMMENDS:${PN}-ptest += " \
 "
 
 FILES:${PN} += "${systemd_unitdir}/*"
+
+# strace is not yet ported to rv32
+RDEPENDS:${PN}-ptest:remove:riscv32 = "strace"
+do_install_ptest:append:riscv32 () {
+    echo "disabled, no strace" > ${D}${PTEST_PATH}/tests/07revert-grow.broken
+    echo "disabled, no strace" > ${D}${PTEST_PATH}/tests/07revert-inplace.broken
+}