diff mbox series

[v2] systemd-boot: Fix build on musl

Message ID 20230811063101.365985-1-raj.khem@gmail.com
State Accepted, archived
Commit 7b84fe344a2067b63d0c222fbc68d5916fa7903f
Headers show
Series [v2] systemd-boot: Fix build on musl | expand

Commit Message

Khem Raj Aug. 11, 2023, 6:31 a.m. UTC
systemd efi.h defines wchar_t from compiler provided __WCHAR_TYPE__
therefore we do not want it to come from alltypes.h in musl case which
otherwise will end up with conflicting definitions of wchar_t, defining
__DEFINED_wchar_t ensures that alltypes.h does not provide it

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/systemd/systemd-boot_254.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
index 4fee99beada..642a5fafe74 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.bb
@@ -50,6 +50,8 @@  RDEPENDS:${PN} += "virtual-systemd-bootconf"
 # Imported from the old gummiboot recipe
 TUNE_CCARGS:remove = "-mfpmath=sse"
 
+CFLAGS:append:libc-musl = " -D__DEFINED_wchar_t"
+
 COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
 COMPATIBLE_HOST:x86-x32 = "null"