diff mbox series

pm-utils: Do not require GNU grep at runtime

Message ID 20230809001834.1682013-1-raj.khem@gmail.com
State Accepted, archived
Commit ba52209acc699d71de865e7eddf64c8acb67b491
Headers show
Series pm-utils: Do not require GNU grep at runtime | expand

Commit Message

Khem Raj Aug. 9, 2023, 12:18 a.m. UTC
This was added to fix bug reported here [1]

back then busybox grep applet did not implement -x option
and it would fail as reported in the bug, in due course
busybox now has implemented -x option [2] and the expression

using grep -x in /usr/lib/pm-utils/functions:219 works fine

[1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=1887
[2] https://git.busybox.net/busybox/commit/?id=cd09e81520b7917adebcffd7c361671f913325eb

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-bsp/pm-utils/pm-utils_1.4.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-bsp/pm-utils/pm-utils_1.4.1.bb b/meta/recipes-bsp/pm-utils/pm-utils_1.4.1.bb
index dcc09f279ef..2c3ade99347 100644
--- a/meta/recipes-bsp/pm-utils/pm-utils_1.4.1.bb
+++ b/meta/recipes-bsp/pm-utils/pm-utils_1.4.1.bb
@@ -17,7 +17,7 @@  inherit pkgconfig autotools manpages
 
 PACKAGECONFIG[manpages] = "--enable-doc, --disable-doc, libxslt-native xmlto-native"
 
-RDEPENDS:${PN} = "grep bash"
+RDEPENDS:${PN} = "bash"
 
 EXTRA_OECONF = "--libdir=${nonarch_libdir}"