diff mbox series

[v2] musl: Upgrade to tip of trunk

Message ID 20230802051828.16307-1-raj.khem@gmail.com
State Accepted, archived
Commit b6abcd4f01aec24393bce68a9806d94702c0d387
Headers show
Series [v2] musl: Upgrade to tip of trunk | expand

Commit Message

Khem Raj Aug. 2, 2023, 5:18 a.m. UTC
Brings following changes

* 83b858f8 fix rejection of dns responses with pointers past 512 byte offset
* a4ecaf89 dns stub resolver: increase buffer size to handle chained CNAMEs
* 40834f6c printf core: fix gratuitous integer formatting buffer size
* 3a23cd06 all printf variants: fix argument type handling for %c and %lc
* fa4a8abd fix public clone function to be safe and usable by applications
* 0c277ff1 fix broken thread list unlocking after fork
* 4653b987 mbrtowc: Fix wrong return value when n > UINT_MAX
* b90841e2 configure: replace -Os with equivalent based on -O2

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Add MIRROR for redundancy

 meta/recipes-core/musl/musl_git.bb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index b4c2b1f8980..297c5581a37 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "718f363bc2067b6487900eddc9180c84e7739f80"
+SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
 
 BASEVER = "1.2.4"
 
@@ -12,11 +12,13 @@  PV = "${BASEVER}+git${SRCPV}"
 
 # mirror is at git://github.com/kraj/musl.git
 
-SRC_URI = "git://git.musl-libc.org/git/musl;branch=master;protocol=https \
+SRC_URI = "git://git.musl-libc.org/git/musl.git;branch=master;protocol=https \
            file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
            file://0002-ldso-Use-syslibdir-and-libdir-as-default-pathes-to-l.patch \
           "
 
+MIRRORS += "git://git.musl-libc.org/git/musl.git git://github.com/kraj/musl.git"
+
 S = "${WORKDIR}/git"
 
 PROVIDES += "virtual/libc virtual/libiconv virtual/libintl virtual/crypt"