diff mbox series

[v2] ltp: Use bfd linker when lld is distro linker default

Message ID 20230727075604.2954034-1-raj.khem@gmail.com
State Accepted, archived
Commit 3f6ab1fea2d07a4e553bb67e3055133ff38dd68c
Headers show
Series [v2] ltp: Use bfd linker when lld is distro linker default | expand

Commit Message

Khem Raj July 27, 2023, 7:56 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Also fix KVM_LD and remove -fuse-ld=lld

 meta/recipes-extended/ltp/ltp_20230516.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Richard Purdie July 27, 2023, 8:38 a.m. UTC | #1
On Thu, 2023-07-27 at 00:56 -0700, Khem Raj wrote:
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> v2: Also fix KVM_LD and remove -fuse-ld=lld
> 
>  meta/recipes-extended/ltp/ltp_20230516.bb | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/ltp/ltp_20230516.bb b/meta/recipes-extended/ltp/ltp_20230516.bb
> index e9407d3148e..1efb7637dcf 100644
> --- a/meta/recipes-extended/ltp/ltp_20230516.bb
> +++ b/meta/recipes-extended/ltp/ltp_20230516.bb
> @@ -41,13 +41,15 @@ inherit autotools-brokensep pkgconfig
>  # https://sourceware.org/bugzilla/show_bug.cgi?id=18097
>  # https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
>  LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
> +LDFLAGS:remove = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', '-fuse-ld=lld', '', d)}"
> +LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"

Why do we need the remove? Nobody would set both ld-is-gold and ls-is-
ldd would they?

I don't really like remove on principle in OE-Core...

Cheers,

Richard
Khem Raj July 27, 2023, 2:55 p.m. UTC | #2
On Thu, Jul 27, 2023 at 1:38 AM Richard Purdie <
richard.purdie@linuxfoundation.org> wrote:

> On Thu, 2023-07-27 at 00:56 -0700, Khem Raj wrote:
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> > v2: Also fix KVM_LD and remove -fuse-ld=lld
> >
> >  meta/recipes-extended/ltp/ltp_20230516.bb | 4 +++-
> >  1 file changed, 3 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-extended/ltp/ltp_20230516.bb
> b/meta/recipes-extended/ltp/ltp_20230516.bb
> > index e9407d3148e..1efb7637dcf 100644
> > --- a/meta/recipes-extended/ltp/ltp_20230516.bb
> > +++ b/meta/recipes-extended/ltp/ltp_20230516.bb
> > @@ -41,13 +41,15 @@ inherit autotools-brokensep pkgconfig
> >  # https://sourceware.org/bugzilla/show_bug.cgi?id=18097
> >  #
> https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
> >  LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold',
> ' -fuse-ld=bfd', '', d)}"
> > +LDFLAGS:remove = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld',
> '-fuse-ld=lld', '', d)}"
> > +LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld',
> ' -fuse-ld=bfd', '', d)}"
>
> Why do we need the remove? Nobody would set both ld-is-gold and ls-is-
> ldd would they?
>
> I don't really like remove on principle in OE-Core...


I think it is not needed for will test a v2

>
>
> Cheers,
>
> Richard
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/ltp/ltp_20230516.bb b/meta/recipes-extended/ltp/ltp_20230516.bb
index e9407d3148e..1efb7637dcf 100644
--- a/meta/recipes-extended/ltp/ltp_20230516.bb
+++ b/meta/recipes-extended/ltp/ltp_20230516.bb
@@ -41,13 +41,15 @@  inherit autotools-brokensep pkgconfig
 # https://sourceware.org/bugzilla/show_bug.cgi?id=18097
 # https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
 LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
+LDFLAGS:remove = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', '-fuse-ld=lld', '', d)}"
+LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
 
 # After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
 # https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
 # it fails with gold also a bit later when trying to use *-payload.bin
 # http://errors.yoctoproject.org/Errors/Details/663094/
 # work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
-KVM_LD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
+KVM_LD = "${@bb.utils.contains_any('DISTRO_FEATURES', 'ld-is-gold ld-is-lld', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
 
 TARGET_CC_ARCH += "${LDFLAGS}"