diff mbox series

iproute2: upgrade 6.3.0 -> 6.4.0

Message ID 20230720192620.1853222-1-tgamblin@baylibre.com
State Accepted, archived
Commit ae2a9b8d3a8b119cc021b9c99cac72d18d5954ba
Headers show
Series iproute2: upgrade 6.3.0 -> 6.4.0 | expand

Commit Message

Trevor Gamblin July 20, 2023, 7:26 p.m. UTC
Changelog: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/log/

Added a patch for including limits.h with musl builds, or else
we get failures such as:

| mdb.c: In function 'mdb_parse_vni':
| mdb.c:666:47: error: 'ULONG_MAX' undeclared (first use in this function)
|   666 |         if ((endptr && *endptr) || vni_num == ULONG_MAX)
|       |                                               ^~~~~~~~~
| mdb.c:666:47: note: 'ULONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../0001-bridge-mdb.c-include-limits.h.patch  | 31 +++++++++++++++++++
 .../{iproute2_6.3.0.bb => iproute2_6.4.0.bb}  |  3 +-
 2 files changed, 33 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
 rename meta/recipes-connectivity/iproute2/{iproute2_6.3.0.bb => iproute2_6.4.0.bb} (95%)

Comments

Alexander Kanavin July 20, 2023, 7:46 p.m. UTC | #1
Please do not add Pending patches, if they're not actually pending
anything. You should submit upstream ahead of submitting to oe-core.

Alex

On Thu, 20 Jul 2023 at 21:26, Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> Changelog: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/log/
>
> Added a patch for including limits.h with musl builds, or else
> we get failures such as:
>
> | mdb.c: In function 'mdb_parse_vni':
> | mdb.c:666:47: error: 'ULONG_MAX' undeclared (first use in this function)
> |   666 |         if ((endptr && *endptr) || vni_num == ULONG_MAX)
> |       |                                               ^~~~~~~~~
> | mdb.c:666:47: note: 'ULONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?
>
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  .../0001-bridge-mdb.c-include-limits.h.patch  | 31 +++++++++++++++++++
>  .../{iproute2_6.3.0.bb => iproute2_6.4.0.bb}  |  3 +-
>  2 files changed, 33 insertions(+), 1 deletion(-)
>  create mode 100644 meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
>  rename meta/recipes-connectivity/iproute2/{iproute2_6.3.0.bb => iproute2_6.4.0.bb} (95%)
>
> diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
> new file mode 100644
> index 0000000000..0330163ae5
> --- /dev/null
> +++ b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
> @@ -0,0 +1,31 @@
> +From 3d6fee6b55992d185f3af4f254b86ea1ac11acfe Mon Sep 17 00:00:00 2001
> +From: Trevor Gamblin <tgamblin@baylibre.com>
> +Date: Thu, 20 Jul 2023 14:32:23 -0400
> +Subject: [PATCH] bridge/mdb.c: include limits.h
> +
> +Upstream-Status: Pending
> +
> +Based on
> +https://git.alpinelinux.org/aports/commit/main/iproute2/include.patch?id=bd46efb8a8da54948639cebcfa5b37bd608f1069,
> +but the author has no plans to submit it upstream.
> +
> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> +---
> + bridge/mdb.c | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/bridge/mdb.c b/bridge/mdb.c
> +index fbb4f704..18793458 100644
> +--- a/bridge/mdb.c
> ++++ b/bridge/mdb.c
> +@@ -15,6 +15,7 @@
> + #include <string.h>
> + #include <arpa/inet.h>
> + #include <netdb.h>
> ++#include <limits.h>
> +
> + #include "libnetlink.h"
> + #include "utils.h"
> +--
> +2.41.0
> +
> diff --git a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
> similarity index 95%
> rename from meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
> rename to meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
> index 892fa854da..32e2f8176b 100644
> --- a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
> +++ b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
> @@ -13,9 +13,10 @@ DEPENDS = "flex-native bison-native iptables libcap"
>
>  SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
>             file://0001-libc-compat.h-add-musl-workaround.patch \
> +           file://0001-bridge-mdb.c-include-limits.h.patch \
>             "
>
> -SRC_URI[sha256sum] = "dfb2a98db96e7a653cffc6693335a1a466e29a34b6ac528be48f35e1d2766732"
> +SRC_URI[sha256sum] = "4c51b8decbc7e4da159ffb066f590cfb93dbf9af7ff86b1647ce42b7c179a272"
>
>  inherit update-alternatives bash-completion pkgconfig
>
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184656): https://lists.openembedded.org/g/openembedded-core/message/184656
> Mute This Topic: https://lists.openembedded.org/mt/100263035/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Trevor Gamblin July 20, 2023, 8 p.m. UTC | #2
On 2023-07-20 15:46, Alexander Kanavin wrote:
> Please do not add Pending patches, if they're not actually pending
> anything. You should submit upstream ahead of submitting to oe-core.
I'm going to attempt submitting it upstream, but I should've clarified 
that I am going to do so. I talked to the author and they said to go ahead.
>
> Alex
>
> On Thu, 20 Jul 2023 at 21:26, Trevor Gamblin <tgamblin@baylibre.com> wrote:
>> Changelog: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/log/
>>
>> Added a patch for including limits.h with musl builds, or else
>> we get failures such as:
>>
>> | mdb.c: In function 'mdb_parse_vni':
>> | mdb.c:666:47: error: 'ULONG_MAX' undeclared (first use in this function)
>> |   666 |         if ((endptr && *endptr) || vni_num == ULONG_MAX)
>> |       |                                               ^~~~~~~~~
>> | mdb.c:666:47: note: 'ULONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?
>>
>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> ---
>>   .../0001-bridge-mdb.c-include-limits.h.patch  | 31 +++++++++++++++++++
>>   .../{iproute2_6.3.0.bb => iproute2_6.4.0.bb}  |  3 +-
>>   2 files changed, 33 insertions(+), 1 deletion(-)
>>   create mode 100644 meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
>>   rename meta/recipes-connectivity/iproute2/{iproute2_6.3.0.bb => iproute2_6.4.0.bb} (95%)
>>
>> diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
>> new file mode 100644
>> index 0000000000..0330163ae5
>> --- /dev/null
>> +++ b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
>> @@ -0,0 +1,31 @@
>> +From 3d6fee6b55992d185f3af4f254b86ea1ac11acfe Mon Sep 17 00:00:00 2001
>> +From: Trevor Gamblin <tgamblin@baylibre.com>
>> +Date: Thu, 20 Jul 2023 14:32:23 -0400
>> +Subject: [PATCH] bridge/mdb.c: include limits.h
>> +
>> +Upstream-Status: Pending
>> +
>> +Based on
>> +https://git.alpinelinux.org/aports/commit/main/iproute2/include.patch?id=bd46efb8a8da54948639cebcfa5b37bd608f1069,
>> +but the author has no plans to submit it upstream.
>> +
>> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> +---
>> + bridge/mdb.c | 1 +
>> + 1 file changed, 1 insertion(+)
>> +
>> +diff --git a/bridge/mdb.c b/bridge/mdb.c
>> +index fbb4f704..18793458 100644
>> +--- a/bridge/mdb.c
>> ++++ b/bridge/mdb.c
>> +@@ -15,6 +15,7 @@
>> + #include <string.h>
>> + #include <arpa/inet.h>
>> + #include <netdb.h>
>> ++#include <limits.h>
>> +
>> + #include "libnetlink.h"
>> + #include "utils.h"
>> +--
>> +2.41.0
>> +
>> diff --git a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
>> similarity index 95%
>> rename from meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
>> rename to meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
>> index 892fa854da..32e2f8176b 100644
>> --- a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
>> +++ b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
>> @@ -13,9 +13,10 @@ DEPENDS = "flex-native bison-native iptables libcap"
>>
>>   SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
>>              file://0001-libc-compat.h-add-musl-workaround.patch \
>> +           file://0001-bridge-mdb.c-include-limits.h.patch \
>>              "
>>
>> -SRC_URI[sha256sum] = "dfb2a98db96e7a653cffc6693335a1a466e29a34b6ac528be48f35e1d2766732"
>> +SRC_URI[sha256sum] = "4c51b8decbc7e4da159ffb066f590cfb93dbf9af7ff86b1647ce42b7c179a272"
>>
>>   inherit update-alternatives bash-completion pkgconfig
>>
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#184656): https://lists.openembedded.org/g/openembedded-core/message/184656
>> Mute This Topic: https://lists.openembedded.org/mt/100263035/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
new file mode 100644
index 0000000000..0330163ae5
--- /dev/null
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
@@ -0,0 +1,31 @@ 
+From 3d6fee6b55992d185f3af4f254b86ea1ac11acfe Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Thu, 20 Jul 2023 14:32:23 -0400
+Subject: [PATCH] bridge/mdb.c: include limits.h
+
+Upstream-Status: Pending
+
+Based on
+https://git.alpinelinux.org/aports/commit/main/iproute2/include.patch?id=bd46efb8a8da54948639cebcfa5b37bd608f1069,
+but the author has no plans to submit it upstream.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ bridge/mdb.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bridge/mdb.c b/bridge/mdb.c
+index fbb4f704..18793458 100644
+--- a/bridge/mdb.c
++++ b/bridge/mdb.c
+@@ -15,6 +15,7 @@
+ #include <string.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
++#include <limits.h>
+ 
+ #include "libnetlink.h"
+ #include "utils.h"
+-- 
+2.41.0
+
diff --git a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
similarity index 95%
rename from meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
rename to meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
index 892fa854da..32e2f8176b 100644
--- a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
+++ b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
@@ -13,9 +13,10 @@  DEPENDS = "flex-native bison-native iptables libcap"
 
 SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
            file://0001-libc-compat.h-add-musl-workaround.patch \
+           file://0001-bridge-mdb.c-include-limits.h.patch \
            "
 
-SRC_URI[sha256sum] = "dfb2a98db96e7a653cffc6693335a1a466e29a34b6ac528be48f35e1d2766732"
+SRC_URI[sha256sum] = "4c51b8decbc7e4da159ffb066f590cfb93dbf9af7ff86b1647ce42b7c179a272"
 
 inherit update-alternatives bash-completion pkgconfig