diff mbox series

p11-kit: upgrade 0.24.1 -> 0.25.0

Message ID 20230706171626.3356772-1-tgamblin@baylibre.com
State New
Headers show
Series p11-kit: upgrade 0.24.1 -> 0.25.0 | expand

Commit Message

Trevor Gamblin July 6, 2023, 5:16 p.m. UTC
Changelog:

- add PKCS#11 3.0 support
- add support for profile objects
- add ability to adjust module and config paths at run-time via system environmental exports
- make terminal output nicer
- p11-kit: add command to print merged configuration
- p11-kit: add commands to list, add and delete profiles of a token
- trust: add command to check format of .p11-kit files
- virtual: fix libffi type signatures for PKCS#11 3.0 functions
- server: fix umask setting when --group is specified
- server: check SHELL only when neither --sh nor --csh is specified
- rpc: use space string in C_InitToken
- rpc: fix two off-by-one errors identified by asan
- modules: make logging message more translatable
- pkcs11.h: support CRYPTOKI_GNU for IBM vendor mechanisms
- pkcs11.h: add IBM specific mechanism and attributes
- pkcs11.h: add ChaCha20/Salsa20 and Poly1305 mechanisms
- pkcs11.h: add AES-GCM mechanism parameters for message-based encryption
- po: update translations from Transifex
- bug and build fixes
- test fixes

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../p11-kit/{p11-kit_0.24.1.bb => p11-kit_0.25.0.bb}            | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-support/p11-kit/{p11-kit_0.24.1.bb => p11-kit_0.25.0.bb} (96%)
diff mbox series

Patch

diff --git a/meta/recipes-support/p11-kit/p11-kit_0.24.1.bb b/meta/recipes-support/p11-kit/p11-kit_0.25.0.bb
similarity index 96%
rename from meta/recipes-support/p11-kit/p11-kit_0.24.1.bb
rename to meta/recipes-support/p11-kit/p11-kit_0.25.0.bb
index 72b446204a..ad207d0c9f 100644
--- a/meta/recipes-support/p11-kit/p11-kit_0.24.1.bb
+++ b/meta/recipes-support/p11-kit/p11-kit_0.25.0.bb
@@ -11,7 +11,7 @@  DEPENDS = "libtasn1 libtasn1-native libffi"
 DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
 
 SRC_URI = "git://github.com/p11-glue/p11-kit;branch=master;protocol=https"
-SRCREV = "dd0590d4e583f107e3e9fafe9ed754149da335d0"
+SRCREV = "a8cce8bd8065bbf80bd47219f85f0cd9cf27dd0c"
 S = "${WORKDIR}/git"
 
 PACKAGECONFIG ??= ""