diff mbox series

python3-urllib3: upgrade 1.26.15 -> 2.0.2

Message ID 20230505024345.2726882-1-tim.orling@konsulko.com
State Accepted, archived
Commit df716c1039826510a5d03fcad972e7b3913368d0
Headers show
Series python3-urllib3: upgrade 1.26.15 -> 2.0.2 | expand

Commit Message

Tim Orling May 5, 2023, 2:43 a.m. UTC
* Change inherit from setuptools3 to python_hatchling
* Add RDEPENDS for python3-json

Migration Guide:
https://urllib3.readthedocs.io/en/latest/v2-migration-guide.html

Changes:
https://github.com/urllib3/urllib3/blob/main/CHANGES.rst#202-2023-05-03
https://github.com/urllib3/urllib3/blob/main/CHANGES.rst#201-2023-04-30
https://github.com/urllib3/urllib3/blob/main/CHANGES.rst#200-2023-04-26

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../{python3-urllib3_1.26.15.bb => python3-urllib3_2.0.2.bb} | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-urllib3_1.26.15.bb => python3-urllib3_2.0.2.bb} (79%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-urllib3_1.26.15.bb b/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
similarity index 79%
rename from meta/recipes-devtools/python/python3-urllib3_1.26.15.bb
rename to meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
index d2de7c4c022..bc1cdb009f4 100644
--- a/meta/recipes-devtools/python/python3-urllib3_1.26.15.bb
+++ b/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
@@ -3,15 +3,16 @@  HOMEPAGE = "https://github.com/shazow/urllib3"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
 
-SRC_URI[sha256sum] = "8a388717b9476f934a21484e8c8e61875ab60644d29b9b39e11e4b9dc1c6b305"
+SRC_URI[sha256sum] = "61717a1095d7e155cdb737ac7bb2f4324a858a1e2e6466f6d03ff630ca68d3cc"
 
-inherit pypi setuptools3
+inherit pypi python_hatchling
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-certifi \
     ${PYTHON_PN}-cryptography \
     ${PYTHON_PN}-email \
     ${PYTHON_PN}-idna \
+    ${PYTHON_PN}-json \
     ${PYTHON_PN}-netclient \
     ${PYTHON_PN}-pyopenssl \
     ${PYTHON_PN}-threading \