diff mbox series

[1/3] musl: Update to latest master

Message ID 20230502144406.2849858-1-raj.khem@gmail.com
State Accepted, archived
Commit 1aceb2dcf5bd671d90ec0517ed8f6fa817ea64c0
Headers show
Series [1/3] musl: Update to latest master | expand

Commit Message

Khem Raj May 2, 2023, 2:44 p.m. UTC
Brings the following changes

* b928c723 fix return value of wmemcmp for extreme wchar_t values
* 4724793f fix wide printf numbered argument buffer overflow
* c1b42c4a wait4: fix missing rusage on x32 due to wrong success condition
* 9b12982d semtimedop: fix timespec kernel ABI mismatch for 32-bit timeouts on x32
* 6d322159 getopt: fix null pointer arithmetic ub
* 35e98311 nftw: fix use of uninitialized struct stat
* 7c410472 fix inadvertently static local var in dynlink get_lfs64
* 77327ed0 dns: check length field in tcp response message

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 531f337e82..036ac948b2 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "1d5750b95c06913a1f18a995481276d698d20fae"
+SRCREV = "b928c7234f62c35a9b4927586ff4c3cbf6e513b5"
 
 BASEVER = "1.2.3"