diff mbox series

qtwebkitgtk: Backport a build fix for GCC 13

Message ID 20230430052031.3102466-1-raj.khem@gmail.com
State Accepted, archived
Commit b2a8379713af625f1667bc63ee85031ac65ca3a4
Headers show
Series qtwebkitgtk: Backport a build fix for GCC 13 | expand

Commit Message

Khem Raj April 30, 2023, 5:20 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...0b55f52ff8b883296f4845269e2ed746acb3.patch | 37 +++++++++++++++++++
 meta/recipes-sato/webkit/webkitgtk_2.38.5.bb  |  1 +
 2 files changed, 38 insertions(+)
 create mode 100644 meta/recipes-sato/webkit/webkitgtk/93920b55f52ff8b883296f4845269e2ed746acb3.patch
diff mbox series

Patch

diff --git a/meta/recipes-sato/webkit/webkitgtk/93920b55f52ff8b883296f4845269e2ed746acb3.patch b/meta/recipes-sato/webkit/webkitgtk/93920b55f52ff8b883296f4845269e2ed746acb3.patch
new file mode 100644
index 0000000000..762de40995
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/93920b55f52ff8b883296f4845269e2ed746acb3.patch
@@ -0,0 +1,37 @@ 
+From 93920b55f52ff8b883296f4845269e2ed746acb3 Mon Sep 17 00:00:00 2001
+From: Michael Catanzaro <mcatanzaro@redhat.com>
+Date: Fri, 31 Mar 2023 12:24:09 -0700
+Subject: [PATCH] Fix build of SourceBrush.cpp
+ https://bugs.webkit.org/show_bug.cgi?id=254821
+
+Unreviewed build fix.
+
+* Source/WebCore/platform/graphics/SourceBrush.cpp:
+(WebCore::SourceBrush::setGradient):
+(WebCore::SourceBrush::setPattern):
+
+Canonical link: https://commits.webkit.org/262434@main
+
+Upstream-Status: Backport [https://github.com/WebKit/WebKit/commit/93920b55f52ff8b883296f4845269e2ed746acb3]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Source/WebCore/platform/graphics/SourceBrush.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/Source/WebCore/platform/graphics/SourceBrush.cpp
++++ b/Source/WebCore/platform/graphics/SourceBrush.cpp
+@@ -65,12 +65,12 @@ Pattern* SourceBrush::pattern() const
+ 
+ void SourceBrush::setGradient(Ref<Gradient>&& gradient, const AffineTransform& spaceTransform)
+ {
+-    m_brush = { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
++    m_brush = Brush { Brush::LogicalGradient { { WTFMove(gradient) }, spaceTransform } };
+ }
+ 
+ void SourceBrush::setPattern(Ref<Pattern>&& pattern)
+ {
+-    m_brush = { WTFMove(pattern) };
++    m_brush = Brush { WTFMove(pattern) };
+ }
+ 
+ WTF::TextStream& operator<<(TextStream& ts, const SourceBrush& brush)
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.38.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.38.5.bb
index 36c6233b33..f7fa6dfb98 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.38.5.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.38.5.bb
@@ -14,6 +14,7 @@  SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
            file://reproducibility.patch \
            file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
            file://d318bb461f040b90453bc4e100dcf967243ecd98.patch \
+           file://93920b55f52ff8b883296f4845269e2ed746acb3.patch \
            "
 SRC_URI[sha256sum] = "40c20c43022274df5893f22b1054fa894c3eea057389bb08aee08c5b0bb0c1a7"