diff mbox series

[v2,1/2] gawk: Disable known ptest fails on musl

Message ID 20230414155511.91980-1-raj.khem@gmail.com
State New
Headers show
Series [v2,1/2] gawk: Disable known ptest fails on musl | expand

Commit Message

Khem Raj April 14, 2023, 3:55 p.m. UTC
Add needed locale rdeps on musl as well.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Delete failing tests on musl

 meta/recipes-extended/gawk/gawk_5.2.1.bb | 17 +++++++++++++++--
 1 file changed, 15 insertions(+), 2 deletions(-)

Comments

Khem Raj April 14, 2023, 4:49 p.m. UTC | #1
ignore this set, it does not work.

On Fri, Apr 14, 2023 at 8:55 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> Add needed locale rdeps on musl as well.
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> v2: Delete failing tests on musl
>
>  meta/recipes-extended/gawk/gawk_5.2.1.bb | 17 +++++++++++++++--
>  1 file changed, 15 insertions(+), 2 deletions(-)
>
> diff --git a/meta/recipes-extended/gawk/gawk_5.2.1.bb b/meta/recipes-extended/gawk/gawk_5.2.1.bb
> index e381bad148..bbb26231a1 100644
> --- a/meta/recipes-extended/gawk/gawk_5.2.1.bb
> +++ b/meta/recipes-extended/gawk/gawk_5.2.1.bb
> @@ -62,8 +62,21 @@ do_install_ptest() {
>         rm -f ${D}${PTEST_PATH}/test/timeout.*
>  }
>
> -RDEPENDS:${PN}-ptest += "make"
> +do_install_ptest:append:libc-musl() {
> +       # Reported  https://lists.gnu.org/archive/html/bug-gawk/2021-02/msg00005.html
> +       rm -f ${D}${PTEST_PATH}/test/clos1way6.*
> +       # Needs en_US.UTF-8 but then does not work with musl
> +       rm -f ${D}${PTEST_PATH}/test/backsmalls1.*
> +       # Needs en_US.UTF-8 but then does not work with musl
> +       rm -f ${D}${PTEST_PATH}/test/commas.*
> +       # The below two need LANG=C inside the make rule for musl
> +       rm -f ${D}${PTEST_PATH}/test/rebt8b1.*
> +       rm -f ${D}${PTEST_PATH}/test/regx8bit.*
> +}
> +
> +RDEPENDS:${PN}-ptest += "make locale-base-en-us"
>
> -RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us locale-base-en-us.iso-8859-1"
> +RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us.iso-8859-1"
> +RDEPENDS:${PN}-ptest:append:libc-musl = " musl-locales"
>
>  BBCLASSEXTEND = "native nativesdk"
> --
> 2.40.0
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/gawk/gawk_5.2.1.bb b/meta/recipes-extended/gawk/gawk_5.2.1.bb
index e381bad148..bbb26231a1 100644
--- a/meta/recipes-extended/gawk/gawk_5.2.1.bb
+++ b/meta/recipes-extended/gawk/gawk_5.2.1.bb
@@ -62,8 +62,21 @@  do_install_ptest() {
 	rm -f ${D}${PTEST_PATH}/test/timeout.*
 }
 
-RDEPENDS:${PN}-ptest += "make"
+do_install_ptest:append:libc-musl() {
+	# Reported  https://lists.gnu.org/archive/html/bug-gawk/2021-02/msg00005.html
+	rm -f ${D}${PTEST_PATH}/test/clos1way6.*
+	# Needs en_US.UTF-8 but then does not work with musl
+	rm -f ${D}${PTEST_PATH}/test/backsmalls1.*
+	# Needs en_US.UTF-8 but then does not work with musl
+	rm -f ${D}${PTEST_PATH}/test/commas.*
+	# The below two need LANG=C inside the make rule for musl
+	rm -f ${D}${PTEST_PATH}/test/rebt8b1.*
+	rm -f ${D}${PTEST_PATH}/test/regx8bit.*
+}
+
+RDEPENDS:${PN}-ptest += "make locale-base-en-us"
 
-RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us locale-base-en-us.iso-8859-1"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us.iso-8859-1"
+RDEPENDS:${PN}-ptest:append:libc-musl = " musl-locales"
 
 BBCLASSEXTEND = "native nativesdk"