diff mbox series

[2/5] python3-packaging: add missing run-time dependencies

Message ID 20230413091557.10659-3-brgl@bgdev.pl
State Accepted, archived
Commit 5281d5f8a9111413ed8d09360185aca7fe1f23a5
Headers show
Series python3: fix run-time availability of python3-build | expand

Commit Message

Bartosz Golaszewski April 13, 2023, 9:15 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

python3-profile is required by python3-packaging at run-time.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-packaging_23.0.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-packaging_23.0.bb b/meta/recipes-devtools/python/python3-packaging_23.0.bb
index 7b69c880c1..c3d748911c 100644
--- a/meta/recipes-devtools/python/python3-packaging_23.0.bb
+++ b/meta/recipes-devtools/python/python3-packaging_23.0.bb
@@ -11,6 +11,7 @@  BBCLASSEXTEND = "native nativesdk"
 
 # Bootstrap the native build
 DEPENDS:remove:class-native = "python3-build-native"
+RDEPENDS:${PN} += "python3-profile"
 
 do_compile:class-native () {
     python_flit_core_do_manual_build