diff mbox series

[09/11] build-appliance-image: QB_MEM: allow user config

Message ID 20230221204445.23931-10-twoerner@gmail.com
State Accepted, archived
Commit 2f8c20ab6750bd900b28e6468493cbd010144050
Headers show
Series build-appliance-image revival | expand

Commit Message

Trevor Woerner Feb. 21, 2023, 8:44 p.m. UTC
Allow the user to specify a QB_MEM value of their choosing, otherwise set it
to a default value.

Signed-off-by: Trevor Woerner <twoerner@gmail.com>
---
 meta/recipes-core/images/build-appliance-image_15.0.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Feb. 22, 2023, 2:12 a.m. UTC | #1
On Tue, Feb 21, 2023 at 12:45 PM Trevor Woerner <twoerner@gmail.com> wrote:
>
> Allow the user to specify a QB_MEM value of their choosing, otherwise set it
> to a default value.
>
> Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> ---
>  meta/recipes-core/images/build-appliance-image_15.0.0.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
> index 1f7b96a9fcf4..aa1e87763d57 100644
> --- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
> +++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
> @@ -11,7 +11,7 @@ IMAGE_INSTALL = "packagegroup-core-boot packagegroup-core-ssh-openssh packagegro
>
>  IMAGE_FEATURES += "x11-base package-management splash"
>
> -QB_MEM = '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
> +QB_MEM ?= '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
>

it would be good to see if we can say something like minimum memory
needed so it should be a fallback
if user sets higher value then it should use that. So for that matter
it looks its fine unless someone sets
QB_MEM < minmem then it will get some trouble.

>  # Ensure there's enough space to do a core-image-sato build, with rm_work enabled
>  IMAGE_ROOTFS_EXTRA_SPACE = "41943040"
> --
> 2.36.0.rc2.17.g4027e30c53
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177547): https://lists.openembedded.org/g/openembedded-core/message/177547
> Mute This Topic: https://lists.openembedded.org/mt/97118452/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index 1f7b96a9fcf4..aa1e87763d57 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -11,7 +11,7 @@  IMAGE_INSTALL = "packagegroup-core-boot packagegroup-core-ssh-openssh packagegro
 
 IMAGE_FEATURES += "x11-base package-management splash"
 
-QB_MEM = '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
+QB_MEM ?= '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
 
 # Ensure there's enough space to do a core-image-sato build, with rm_work enabled
 IMAGE_ROOTFS_EXTRA_SPACE = "41943040"