diff mbox series

[3/3] python3-pytest: add BBCLASSEXTEND

Message ID 20230216151005.3469200-3-ross.burton@arm.com
State New
Headers show
Series [1/3] python3-atomicwrites: add BBCLASSEXTEND | expand

Commit Message

Ross Burton Feb. 16, 2023, 3:10 p.m. UTC
Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-pytest_7.2.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jose Quaresma Feb. 16, 2023, 5:09 p.m. UTC | #1
Hi Ross,

Ross Burton <ross.burton@arm.com> escreveu no dia quinta, 16/02/2023 à(s)
15:10:

> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-devtools/python/python3-pytest_7.2.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> index 105b76a4a64..c7610d440c1 100644
> --- a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> +++ b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> @@ -11,7 +11,7 @@ DEPENDS += "python3-setuptools-scm-native"
>
>  inherit update-alternatives pypi python_setuptools_build_meta
>
> -RDEPENDS:${PN}:class-target += " \
> +RDEPENDS:${PN} += " \
>

The commit title is not describing what has been done on the patch.

Jose

     ${PYTHON_PN}-atomicwrites \
>      ${PYTHON_PN}-attrs \
>      ${PYTHON_PN}-debugger \
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177293):
> https://lists.openembedded.org/g/openembedded-core/message/177293
> Mute This Topic: https://lists.openembedded.org/mt/97007314/5052612
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Ross Burton Feb. 20, 2023, 4:35 p.m. UTC | #2
On 16 Feb 2023, at 17:09, Jose Quaresma <quaresma.jose@gmail.com> wrote:
> 
> Hi Ross,
> 
> Ross Burton <ross.burton@arm.com> escreveu no dia quinta, 16/02/2023 à(s) 15:10:
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-devtools/python/python3-pytest_7.2.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> index 105b76a4a64..c7610d440c1 100644
> --- a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> +++ b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
> @@ -11,7 +11,7 @@ DEPENDS += "python3-setuptools-scm-native"
> 
>  inherit update-alternatives pypi python_setuptools_build_meta
> 
> -RDEPENDS:${PN}:class-target += " \
> +RDEPENDS:${PN} += " \
> 
> The commit title is not describing what has been done on the patch.

No, it’s not.  Sorry about that, I tried getting clever and scripting commits but forgot one was different.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
index 105b76a4a64..c7610d440c1 100644
--- a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
+++ b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
@@ -11,7 +11,7 @@  DEPENDS += "python3-setuptools-scm-native"
 
 inherit update-alternatives pypi python_setuptools_build_meta
 
-RDEPENDS:${PN}:class-target += " \
+RDEPENDS:${PN} += " \
     ${PYTHON_PN}-atomicwrites \
     ${PYTHON_PN}-attrs \
     ${PYTHON_PN}-debugger \