diff mbox series

[PATCHv5] graphene: add a PACKAGECONFIG for arm_neon

Message ID 20230213180351.2695806-1-f_l_k@t-online.de
State Accepted, archived
Commit 72778f6a647f47926c6ba1b77f0984999a22e44a
Headers show
Series [PATCHv5] graphene: add a PACKAGECONFIG for arm_neon | expand

Commit Message

Markus Volk Feb. 13, 2023, 6:03 p.m. UTC
Not all arm platforms support neon and runtime detection for this feature is
currently not reliable.
Disable neon support by default on ARM-32 platforms because of the
following upstream bug: https://github.com/ebassi/graphene/issues/215

Enable neon for aarch64 by default

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-graphics/graphene/graphene_1.10.8.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Carlos Alberto Lopez Perez Feb. 13, 2023, 9:35 p.m. UTC | #1
On 13/02/2023 19:03, Markus Volk wrote:
> Not all arm platforms support neon and runtime detection for this feature is
> currently not reliable.
> Disable neon support by default on ARM-32 platforms because of the
> following upstream bug: https://github.com/ebassi/graphene/issues/215
> 
> Enable neon for aarch64 by default
> 
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta/recipes-graphics/graphene/graphene_1.10.8.bb | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> index 813ff74adf..199c460feb 100644
> --- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> +++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> @@ -10,8 +10,10 @@ inherit gnomebase gobject-introspection gtk-doc
>  SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
>  
>  # gtk4 & mutter 41.0 requires graphene build with introspection
> -PACKAGECONFIG ?= "introspection"
> +PACKAGECONFIG ?= "introspection ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
> +
>  PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
> +PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
>  
>  GTKDOC_MESON_OPTION = "gtk_doc"
>  
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177106): https://lists.openembedded.org/g/openembedded-core/message/177106
> Mute This Topic: https://lists.openembedded.org/mt/96941870/2167112
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [clopez@igalia.com]
> -=-=-=-=-=-=-=-=-=-=-=-
> 

I think the comment with the link to the upstream bug and the reason for
disabling Neon support should be on the .bb file itself (and not only
the git log).
diff mbox series

Patch

diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
index 813ff74adf..199c460feb 100644
--- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
+++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
@@ -10,8 +10,10 @@  inherit gnomebase gobject-introspection gtk-doc
 SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
 
 # gtk4 & mutter 41.0 requires graphene build with introspection
-PACKAGECONFIG ?= "introspection"
+PACKAGECONFIG ?= "introspection ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
+
 PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
+PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
 
 GTKDOC_MESON_OPTION = "gtk_doc"