diff mbox series

[PATCHv2] graphene: add a PACKAGECONFIG for arm_neon

Message ID 20230213103939.1066831-1-f_l_k@t-online.de
State Accepted, archived
Commit 72778f6a647f47926c6ba1b77f0984999a22e44a
Headers show
Series [PATCHv2] graphene: add a PACKAGECONFIG for arm_neon | expand

Commit Message

Markus Volk Feb. 13, 2023, 10:39 a.m. UTC
Not all arm platforms support neon and runtime detection for this feature is
currently not reliable. Add a PACKAGECONFIG that disables neon support for arm
but can be manually enabled.

Enable neon for aarch64 by default

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-graphics/graphene/graphene_1.10.8.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Markus Volk Feb. 13, 2023, 10:40 a.m. UTC | #1
v2 enables neon for aarch64 by default

Am Mo, 13. Feb 2023 um 11:39:39 +0100 schrieb Markus Volk 
<f_l_k@t-online.de>:
> Not all arm platforms support neon and runtime detection for this 
> feature is
> currently not reliable. Add a PACKAGECONFIG that disables neon 
> support for arm
> but can be manually enabled.
> 
> Enable neon for aarch64 by default
> 
> Signed-off-by: Markus Volk <f_l_k@t-online.de 
> <mailto:f_l_k@t-online.de>>
> ---
>  meta/recipes-graphics/graphene/graphene_1.10.8.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb 
> b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> index 813ff74adf..f32112118f 100644
> --- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> +++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> @@ -11,7 +11,9 @@ SRC_URI[archive.sha256sum] = 
> "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da3
> 
>  # gtk4 & mutter 41.0 requires graphene build with introspection
>  PACKAGECONFIG ?= "introspection"
> +#PACKAGECONFIG:aarch64 += "neon"
>  PACKAGECONFIG[introspection] = 
> "-Dintrospection=enabled,-Dintrospection=disabled,"
> +PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
> 
>  GTKDOC_MESON_OPTION = "gtk_doc"
> 
> --
> 2.34.1
>
Alexander Kanavin Feb. 13, 2023, 10:43 a.m. UTC | #2
I think it's commented out?

Alex

On Mon, 13 Feb 2023 at 11:40, Markus Volk <f_l_k@t-online.de> wrote:
>
> v2 enables neon for aarch64 by default
>
> Am Mo, 13. Feb 2023 um 11:39:39 +0100 schrieb Markus Volk <f_l_k@t-online.de>:
>
> Not all arm platforms support neon and runtime detection for this feature is currently not reliable. Add a PACKAGECONFIG that disables neon support for arm but can be manually enabled. Enable neon for aarch64 by default Signed-off-by: Markus Volk <f_l_k@t-online.de> --- meta/recipes-graphics/graphene/graphene_1.10.8.bb | 2 ++ 1 file changed, 2 insertions(+) diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb index 813ff74adf..f32112118f 100644 --- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb +++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb @@ -11,7 +11,9 @@ SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da3 # gtk4 & mutter 41.0 requires graphene build with introspection PACKAGECONFIG ?= "introspection" +#PACKAGECONFIG:aarch64 += "neon" PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled," +PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false," GTKDOC_MESON_OPTION = "gtk_doc"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177092): https://lists.openembedded.org/g/openembedded-core/message/177092
> Mute This Topic: https://lists.openembedded.org/mt/96933123/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Feb. 13, 2023, 10:45 a.m. UTC | #3
Am Mo, 13. Feb 2023 um 11:43:55 +0100 schrieb Alexander Kanavin 
<alex.kanavin@gmail.com>:
> I think it's commented out?

yes, did this for testing purpose. Sorry. Sent a v3
diff mbox series

Patch

diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
index 813ff74adf..f32112118f 100644
--- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
+++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
@@ -11,7 +11,9 @@  SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da3
 
 # gtk4 & mutter 41.0 requires graphene build with introspection
 PACKAGECONFIG ?= "introspection"
+#PACKAGECONFIG:aarch64 += "neon"
 PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
+PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
 
 GTKDOC_MESON_OPTION = "gtk_doc"