diff mbox series

[1/4] mdadm: Define alignof using _Alignof when using C11 or newer

Message ID 20230117231853.1511529-1-raj.khem@gmail.com
State Accepted, archived
Commit 18f1f2775ef0690802b44a6094383db48c712c19
Headers show
Series [1/4] mdadm: Define alignof using _Alignof when using C11 or newer | expand

Commit Message

Khem Raj Jan. 17, 2023, 11:18 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...sing-_Alignof-when-using-C11-or-newe.patch | 52 +++++++++++++++++++
 meta/recipes-extended/mdadm/mdadm_4.2.bb      |  1 +
 2 files changed, 53 insertions(+)
 create mode 100644 meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch

Comments

Alexander Kanavin Jan. 18, 2023, 7:35 a.m. UTC | #1
Please submit the patch upstream first.

Alex

On Wed, 18 Jan 2023 at 00:18, Khem Raj <raj.khem@gmail.com> wrote:
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  ...sing-_Alignof-when-using-C11-or-newe.patch | 52 +++++++++++++++++++
>  meta/recipes-extended/mdadm/mdadm_4.2.bb      |  1 +
>  2 files changed, 53 insertions(+)
>  create mode 100644 meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch
>
> diff --git a/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch b/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch
> new file mode 100644
> index 0000000000..1c472886b3
> --- /dev/null
> +++ b/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch
> @@ -0,0 +1,52 @@
> +From 82c893bb9e01f914a6bdef1bef943af746cfc3e1 Mon Sep 17 00:00:00 2001
> +From: Khem Raj <raj.khem@gmail.com>
> +Date: Sun, 15 Jan 2023 12:42:18 -0800
> +Subject: [PATCH] Define alignof using _Alignof when using C11 or newer
> +
> +WG14 N2350 made very clear that it is an UB having type definitions
> +within "offsetof" [1]. This patch enhances the implementation of macro
> +alignof_slot to use builtin "_Alignof" to avoid undefined behavior on
> +when using std=c11 or newer
> +
> +clang 16+ has started to flag this [2]
> +
> +Fixes build when using -std >= gnu11 and using clang16+
> +
> +Older compilers gcc < 4.9 or clang < 8 has buggy _Alignof even though it
> +may support C11, exclude those compilers too
> +
> +[1] https://www.open-std.org/jtc1/sc22/wg14/www/docs/n2350.htm
> +[2] https://reviews.llvm.org/D133574
> +
> +Upstream-Status: Pending
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +---
> + sha1.c | 12 +++++++++++-
> + 1 file changed, 11 insertions(+), 1 deletion(-)
> +
> +diff --git a/sha1.c b/sha1.c
> +index 89b32f4..1e4ad5d 100644
> +--- a/sha1.c
> ++++ b/sha1.c
> +@@ -229,7 +229,17 @@ sha1_process_bytes (const void *buffer, size_t len, struct sha1_ctx *ctx)
> +   if (len >= 64)
> +     {
> + #if !_STRING_ARCH_unaligned
> +-# define alignof(type) offsetof (struct { char c; type x; }, x)
> ++/* GCC releases before GCC 4.9 had a bug in _Alignof.  See GCC bug 52023
> ++   <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=52023>.
> ++   clang versions < 8.0.0 have the same bug.  */
> ++# if (!defined __STDC_VERSION__ || __STDC_VERSION__ < 201112 \
> ++      || (defined __GNUC__ && __GNUC__ < 4 + (__GNUC_MINOR__ < 9) \
> ++   && !defined __clang__) \
> ++      || (defined __clang__ && __clang_major__ < 8))
> ++#  define alignof(type) offsetof (struct { char c; type x; }, x)
> ++# else
> ++#  define alignof(type) _Alignof(type)
> ++# endif
> + # define UNALIGNED_P(p) (((size_t) p) % alignof (sha1_uint32) != 0)
> +       if (UNALIGNED_P (buffer))
> +       while (len > 64)
> +--
> +2.39.0
> +
> diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> index 7298860241..1c4397509b 100644
> --- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
> +++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
> @@ -25,6 +25,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
>             file://0001-Fix-parsing-of-r-in-monitor-manager-mode.patch \
>             file://0001-Makefile-install-mdcheck.patch \
>             file://0001-restripe.c-Use-_FILE_OFFSET_BITS-to-enable-largefile.patch \
> +           file://0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch \
>             "
>
>  SRC_URI[sha256sum] = "461c215670864bb74a4d1a3620684aa2b2f8296dffa06743f26dda5557acf01d"
> --
> 2.39.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#176066): https://lists.openembedded.org/g/openembedded-core/message/176066
> Mute This Topic: https://lists.openembedded.org/mt/96343396/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch b/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch
new file mode 100644
index 0000000000..1c472886b3
--- /dev/null
+++ b/meta/recipes-extended/mdadm/files/0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch
@@ -0,0 +1,52 @@ 
+From 82c893bb9e01f914a6bdef1bef943af746cfc3e1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 15 Jan 2023 12:42:18 -0800
+Subject: [PATCH] Define alignof using _Alignof when using C11 or newer
+
+WG14 N2350 made very clear that it is an UB having type definitions
+within "offsetof" [1]. This patch enhances the implementation of macro
+alignof_slot to use builtin "_Alignof" to avoid undefined behavior on
+when using std=c11 or newer
+
+clang 16+ has started to flag this [2]
+
+Fixes build when using -std >= gnu11 and using clang16+
+
+Older compilers gcc < 4.9 or clang < 8 has buggy _Alignof even though it
+may support C11, exclude those compilers too
+
+[1] https://www.open-std.org/jtc1/sc22/wg14/www/docs/n2350.htm
+[2] https://reviews.llvm.org/D133574
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ sha1.c | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/sha1.c b/sha1.c
+index 89b32f4..1e4ad5d 100644
+--- a/sha1.c
++++ b/sha1.c
+@@ -229,7 +229,17 @@ sha1_process_bytes (const void *buffer, size_t len, struct sha1_ctx *ctx)
+   if (len >= 64)
+     {
+ #if !_STRING_ARCH_unaligned
+-# define alignof(type) offsetof (struct { char c; type x; }, x)
++/* GCC releases before GCC 4.9 had a bug in _Alignof.  See GCC bug 52023
++   <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=52023>.
++   clang versions < 8.0.0 have the same bug.  */
++# if (!defined __STDC_VERSION__ || __STDC_VERSION__ < 201112 \
++      || (defined __GNUC__ && __GNUC__ < 4 + (__GNUC_MINOR__ < 9) \
++   && !defined __clang__) \
++      || (defined __clang__ && __clang_major__ < 8))
++#  define alignof(type) offsetof (struct { char c; type x; }, x)
++# else
++#  define alignof(type) _Alignof(type)
++# endif
+ # define UNALIGNED_P(p) (((size_t) p) % alignof (sha1_uint32) != 0)
+       if (UNALIGNED_P (buffer))
+ 	while (len > 64)
+-- 
+2.39.0
+
diff --git a/meta/recipes-extended/mdadm/mdadm_4.2.bb b/meta/recipes-extended/mdadm/mdadm_4.2.bb
index 7298860241..1c4397509b 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.2.bb
@@ -25,6 +25,7 @@  SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
            file://0001-Fix-parsing-of-r-in-monitor-manager-mode.patch \
            file://0001-Makefile-install-mdcheck.patch \
            file://0001-restripe.c-Use-_FILE_OFFSET_BITS-to-enable-largefile.patch \
+           file://0001-Define-alignof-using-_Alignof-when-using-C11-or-newe.patch \
            "
 
 SRC_URI[sha256sum] = "461c215670864bb74a4d1a3620684aa2b2f8296dffa06743f26dda5557acf01d"