diff mbox series

wpa-supplicant: Enable native builds

Message ID 20230104092139.9015-1-mares@2n.com
State New
Headers show
Series wpa-supplicant: Enable native builds | expand

Commit Message

Miroslav Mareš - 2N Jan. 4, 2023, 9:21 a.m. UTC
Native builds for wpa-supplicant can be enabled
without any further modifications.

Signed-off-by: Miroslav Mareš <mares@2n.com>
---
 meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Alexander Kanavin Jan. 4, 2023, 9:23 a.m. UTC | #1
They can, but you should describe possible use cases too.

Alex

On Wed, 4 Jan 2023 at 10:22, Miroslav Mareš <mares@2n.com> wrote:
>
> Native builds for wpa-supplicant can be enabled
> without any further modifications.
>
> Signed-off-by: Miroslav Mareš <mares@2n.com>
> ---
>  meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> index 4e27b92bc6..ec20b8b32f 100644
> --- a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> +++ b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> @@ -135,3 +135,5 @@ python split_wpa_supplicant_libs () {
>          d.appendVar('RRECOMMENDS:' + pn + '-dbg', ' ' + ' '.join(split_dbg_packages))
>  }
>  PACKAGESPLITFUNCS:prepend = "split_wpa_supplicant_libs "
> +
> +BBCLASSEXTEND = "native"
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175378): https://lists.openembedded.org/g/openembedded-core/message/175378
> Mute This Topic: https://lists.openembedded.org/mt/96047102/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Mikko Rapeli Jan. 4, 2023, 9:24 a.m. UTC | #2
Hi,

On Wed, Jan 04, 2023 at 10:21:39AM +0100, Miroslav Mareš wrote:
> Native builds for wpa-supplicant can be enabled
> without any further modifications.

Why would this be needed? The reason should be in the commit message.

It is likely better to remove wpa-supplicant from the dependency which
needs it on -native.

Cheers,

-Mikko

> Signed-off-by: Miroslav Mareš <mares@2n.com>
> ---
>  meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> index 4e27b92bc6..ec20b8b32f 100644
> --- a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> +++ b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
> @@ -135,3 +135,5 @@ python split_wpa_supplicant_libs () {
>          d.appendVar('RRECOMMENDS:' + pn + '-dbg', ' ' + ' '.join(split_dbg_packages))
>  }
>  PACKAGESPLITFUNCS:prepend = "split_wpa_supplicant_libs "
> +
> +BBCLASSEXTEND = "native"
> -- 
> 2.30.2
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175378): https://lists.openembedded.org/g/openembedded-core/message/175378
> Mute This Topic: https://lists.openembedded.org/mt/96047102/7159507
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [mikko.rapeli@linaro.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Miroslav Mareš - 2N Jan. 4, 2023, 9:53 a.m. UTC | #3
We are using native builds to run some tests on the software we develop in Yocto
and some of this software uses wpa-supplicant library.

Is this an acceptable use case?
Alexander Kanavin Jan. 4, 2023, 10:15 a.m. UTC | #4
You can easily enable native supplicant via a .bbappend in your own layer.

Native builds are not meant for running tests on the software that
goes into a product, they're meant only for building tools that are
needed for target builds.

Can we see the tests?

Alex

On Wed, 4 Jan 2023 at 10:53, Miroslav Mareš <mares@2n.com> wrote:
>
> We are using native builds to run some tests on the software we develop in Yocto
> and some of this software uses wpa-supplicant library.
>
> Is this an acceptable use case?
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175381): https://lists.openembedded.org/g/openembedded-core/message/175381
> Mute This Topic: https://lists.openembedded.org/mt/96047102/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Miroslav Mareš - 2N Jan. 4, 2023, 10:45 a.m. UTC | #5
Thank you for the information, in this case we should resort to using the bbappend,

because we don't have any use case of wpa-supplicant as a tool needed for target builds.
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
index 4e27b92bc6..ec20b8b32f 100644
--- a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
+++ b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.10.bb
@@ -135,3 +135,5 @@  python split_wpa_supplicant_libs () {
         d.appendVar('RRECOMMENDS:' + pn + '-dbg', ' ' + ' '.join(split_dbg_packages))
 }
 PACKAGESPLITFUNCS:prepend = "split_wpa_supplicant_libs "
+
+BBCLASSEXTEND = "native"