diff mbox series

[dunfell] curl: Correct LICENSE from MIT to curl

Message ID 20221221070914.20166-1-ranjitsinhrathod1991@gmail.com
State New, archived
Headers show
Series [dunfell] curl: Correct LICENSE from MIT to curl | expand

Commit Message

Ranjitsinh Rathod Dec. 21, 2022, 7:09 a.m. UTC
From: Ranjitsinh Rathod <ranjitsinh.rathod@kpit.com>

LICENSE for curl is set to MIT which is wrong and proper license is
'curl'

I check below link and the line "Curl and libcurl are licensed under
the license below, which is inspired by MIT/X, but not identical." says
that the license is identical to MIT but actual license is identical
from the file "meta/files/common-licenses/curl"
Link: https://curl.se/docs/copyright.html

Also, I do not find the MIT license text in the entire source-code

(From OE-Core rev: 34b228bd3a80a74bf4d84ef7ee362f4ab1e3a466)

Conflicts:
meta/recipes-support/curl/curl_7.86.0.bb
This is due to version change of curl and also due to MIT and
MIT-open-group license variant

Signed-off-by: Ranjitsinh Rathod <ranjitsinh.rathod@kpit.com>
Signed-off-by: Ranjitsinh Rathod <ranjitsinhrathod1991@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 4a246e06cb62efff8bfd20cdf3dde31e24f9b711)
Signed-off-by: Ranjitsinh Rathod <ranjitsinhrathod1991@gmail.com>
---
 meta/recipes-support/curl/curl_7.69.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Steve Sakoman Dec. 21, 2022, 5:16 p.m. UTC | #1
This patch results in build errors:

stdio: WARNING: curl-7.69.1-r0 do_populate_lic: curl: No generic
license file exists for: curl in any provider
stdio: WARNING: core-image-sato-1.0-r0 do_rootfs: The license listed
curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-dev-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-dev-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-dev-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-1.0-r0 do_rootfs: The license
listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-ptest-1.0-r0 do_rootfs: The
license listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-ptest-1.0-r0 do_rootfs: The
license listed curl was not in the licenses collected for recipe curl
stdio: WARNING: core-image-sato-sdk-ptest-1.0-r0 do_rootfs: The
license listed curl was not in the licenses collected for recipe curl

On Tue, Dec 20, 2022 at 9:09 PM Ranjitsinh Rathod
<ranjitsinhrathod1991@gmail.com> wrote:
>
> From: Ranjitsinh Rathod <ranjitsinh.rathod@kpit.com>
>
> LICENSE for curl is set to MIT which is wrong and proper license is
> 'curl'
>
> I check below link and the line "Curl and libcurl are licensed under
> the license below, which is inspired by MIT/X, but not identical." says
> that the license is identical to MIT but actual license is identical
> from the file "meta/files/common-licenses/curl"
> Link: https://curl.se/docs/copyright.html
>
> Also, I do not find the MIT license text in the entire source-code
>
> (From OE-Core rev: 34b228bd3a80a74bf4d84ef7ee362f4ab1e3a466)
>
> Conflicts:
> meta/recipes-support/curl/curl_7.86.0.bb
> This is due to version change of curl and also due to MIT and
> MIT-open-group license variant
>
> Signed-off-by: Ranjitsinh Rathod <ranjitsinh.rathod@kpit.com>
> Signed-off-by: Ranjitsinh Rathod <ranjitsinhrathod1991@gmail.com>
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> (cherry picked from commit 4a246e06cb62efff8bfd20cdf3dde31e24f9b711)
> Signed-off-by: Ranjitsinh Rathod <ranjitsinhrathod1991@gmail.com>
> ---
>  meta/recipes-support/curl/curl_7.69.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/curl/curl_7.69.1.bb b/meta/recipes-support/curl/curl_7.69.1.bb
> index 31aa9d7185..49287b2e3d 100644
> --- a/meta/recipes-support/curl/curl_7.69.1.bb
> +++ b/meta/recipes-support/curl/curl_7.69.1.bb
> @@ -6,7 +6,7 @@ HTTP post, SSL connections, proxy support, FTP uploads, and more!"
>  HOMEPAGE = "http://curl.haxx.se/"
>  BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
>  SECTION = "console/network"
> -LICENSE = "MIT"
> +LICENSE = "curl"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=2e9fb35867314fe31c6a4977ef7dd531"
>
>  SRC_URI = "https://curl.haxx.se/download/curl-${PV}.tar.bz2 \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#174901): https://lists.openembedded.org/g/openembedded-core/message/174901
> Mute This Topic: https://lists.openembedded.org/mt/95802470/3620601
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl_7.69.1.bb b/meta/recipes-support/curl/curl_7.69.1.bb
index 31aa9d7185..49287b2e3d 100644
--- a/meta/recipes-support/curl/curl_7.69.1.bb
+++ b/meta/recipes-support/curl/curl_7.69.1.bb
@@ -6,7 +6,7 @@  HTTP post, SSL connections, proxy support, FTP uploads, and more!"
 HOMEPAGE = "http://curl.haxx.se/"
 BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
 SECTION = "console/network"
-LICENSE = "MIT"
+LICENSE = "curl"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2e9fb35867314fe31c6a4977ef7dd531"
 
 SRC_URI = "https://curl.haxx.se/download/curl-${PV}.tar.bz2 \