diff mbox series

[05/24] python3-numpy: fix upstream version check

Message ID 20221213111118.149697-5-alex@linutronix.de
State Accepted, archived
Commit e2f81a955457fc50107ec9f0e2aea3641ed8a048
Headers show
Series [01/24] ptest-packagelists.inc: correctly assign fast and slow tests | expand

Commit Message

Alexander Kanavin Dec. 13, 2022, 11:10 a.m. UTC
Default regex is also considering numpy release candidates.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/python/python3-numpy_1.23.4.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy_1.23.4.bb b/meta/recipes-devtools/python/python3-numpy_1.23.4.bb
index d9172692b5..679a6f4081 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.23.4.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.23.4.bb
@@ -16,6 +16,7 @@  SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
 SRC_URI[sha256sum] = "ed2cc92af0efad20198638c69bb0fc2870a58dabfba6eb722c933b48556c686c"
 
 GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases"
+UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"
 
 DEPENDS += "python3-cython-native"