diff mbox series

libinput: upgrade 1.19.4 -> 1.21.0

Message ID 20221107231526.397428-1-f_l_k@t-online.de
State New
Headers show
Series libinput: upgrade 1.19.4 -> 1.21.0 | expand

Commit Message

Markus Volk Nov. 7, 2022, 11:15 p.m. UTC
libinput 1.21.0 is now available for download.
This version includes a new configuration option that, similarly to its touchpad counterpart, allows disabling the trackpoint while typing.
Compositors can take advantage of it thanks to four new APIs:
  libinput_device_config_dwtp_is_available, libinput_device_config_dwtp_set_enabled, libinput_device_config_dwtp_get_enabled and libinput_device_config_dwtp_get_default_enabled.
Those who use the flat acceleration profile on their touchpad are in luck, it has been improved in this version.
In addition to the changes already mentioned, new quirks have been added for multiple StarLabs laptops.
Last but not least, several bugs have been fixed, so make sure to update!
Thanks to everyone involved for making this new version possible ❤

Alexander Courtis (1):
      AttrLidSwitchReliability quirk default unreliable->reliable

José Expósito (7):
      evdev: check well-known keyboard keys on joystick/gamepad detection
      evdev: modernize variable declaration in evdev_device_is_joystick_or_gamepad
      coding style: allow C99 variable declaration
      test: disable hold gestures when are not required
      Remove "device-" file
      wheel: fix Lenovo Scrollpoint quirk
      libinput 1.21.0

Peter Hutterer (26):
      gitlab CI: fail the sanity check stage if the fork is not public
      util: auto-declare the element variable in ARRAY_FOR_EACH
      meson: fix a meson warning
      meson: replace a meson.source_root() with the explicit directory
      doc/user: add a page to troubleshoot right-click Clickpads
      tools/record: fix the indentation of the system: section
      evdev: strip the device name of format directives
      tools: allow limiting the axes in libinput analyse recording
      tools: don't print a carriage return if we're not on a tty
      tools/record: fix indentation for libinput events
      tools/analyze-recording: add --print-state to always print values
      tools/analyze-recording: improve the repeated-events line printing
      tools: add a libinput test tool as entry point for our test suites
      test: install libinput-test-utils as part of install-tests
      quirks: move the canvas quirk enum to the right order
      quirks: remove an unused quirk
      tablet: remove an always-true part of an if condition
      test: rename a test function to make it easier to select
      tablet: use a helper variable to make the code more readable
      tablet: require a minimum pressure before we process pressure events
      test: fix the lowres-only wheel event tests
      test: ensure we always have an axis event where we expect one
      test: use a ranged test instead of a duplicated one
      test: fix a typo
      meson.build: check gtk targets before building
      gitlab CI: bump to F35 and F36, as well as Ubuntu 21.10 and 22.04

Sean Rhodes (2):
      quirks: Add quirk for StarLite Mk IV
      Quirk all StarLabs trackpads

Tom Stellard (1):
      Update valgrind.h to a newer version

pudiva chip líquida (1):
      touchpad: new option dwtp (disable-while-trackpointing)

satrmb (1):
      filter-touchpad: normalize for dpi on the touchpad-specific flat profile

libinput 1.20.1 is now available for download.
This release fixes CVE-2022-1215, see #752.

When a device is detected by libinput, libinput logs several messages through log handlers set up by the callers.
These log handlers usually eventually result in a printf call. Logging happens with the privileges of the caller,
in the case of Xorg this may be root.

The device name ends up as part of the format string and a kernel device with printf-style format string placeholders
in the device name can enable an attacker to run malicious code. An exploit is possible through any device where the
attacker controls the device name, e.g. /dev/uinput or Bluetooth devices.

Peter Hutterer (2):
      evdev: strip the device name of format directives
      libinput 1.20.1

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../wayland/{libinput_1.19.4.bb => libinput_1.21.0.bb}       | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
 rename meta/recipes-graphics/wayland/{libinput_1.19.4.bb => libinput_1.21.0.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/wayland/libinput_1.19.4.bb b/meta/recipes-graphics/wayland/libinput_1.21.0.bb
similarity index 91%
rename from meta/recipes-graphics/wayland/libinput_1.19.4.bb
rename to meta/recipes-graphics/wayland/libinput_1.21.0.bb
index a7d0c4be69..cf59bd81c5 100644
--- a/meta/recipes-graphics/wayland/libinput_1.19.4.bb
+++ b/meta/recipes-graphics/wayland/libinput_1.21.0.bb
@@ -12,11 +12,12 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
 
 DEPENDS = "libevdev udev mtdev libcheck"
 
-SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
+SRC_URI = "git://gitlab.freedesktop.org/libinput/libinput.git;protocol=https;branch=main \
            file://run-ptest \
            file://determinism.patch \
            "
-SRC_URI[sha256sum] = "ff33a570b5a936c81e6c08389a8581c2665311d026ce3d225c88d09c49f9b440"
+SRCREV = "bc363328a704b3c5e0ee2f0fcf088de67c708979"
+S = "${WORKDIR}/git"
 
 UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"