diff mbox series

cargo-update-recipe-crates: small improvements

Message ID 20221102081207.233211-1-Martin.Jansa@gmail.com
State Accepted, archived
Commit 7636a2b8080521ed2ad54b0edce47a8742a12d58
Headers show
Series cargo-update-recipe-crates: small improvements | expand

Commit Message

Martin Jansa Nov. 2, 2022, 8:12 a.m. UTC
* use 4 spaces
* avoid trailing space
* add CARGO_LOCK_SRC_DIR to allow searching outside ${S}
* use BPN in output filename
* First I've used CARGO_LOCK_SRC_DIR as relative to ${S}, because that's what CARGO_SRC_DIR
  in cargo.bbclass is using:
  meta/classes-recipe/cargo.bbclass:CARGO_SRC_DIR ??= ""
  meta/classes-recipe/cargo.bbclass:MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"

  but change to absolute path (defaulting to ${S}) as requested by Alex:
  11:44 < kanavin> JaMa, would prefer CARGO_LOCK_SRC_DIR ??= "${S}"
  11:46 < kanavin> otherwise looks good

* I've resolved my usecase for CARGO_LOCK_SRC_DIR by changing
  S back to ${WORKDIR}/git and using CARGO_SRC_DIR to select
  the right subdirectory to be built, because the Cargo.toml
  in this subdirectory was also referencing other subdirectories
  with relative path:
  https://github.com/solana-labs/solana-program-library/blob/88b147506d5b9515f3a4762421a0b8c309188dc9/token/cli/Cargo.toml#L30
  so including all Cargo.lock files in whole ${WORKDIR}/git
  seems like reasonable approach

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 .../cargo-update-recipe-crates.bbclass             | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

Comments

Tim Orling Nov. 2, 2022, 2:45 p.m. UTC | #1
On Wed, Nov 2, 2022 at 1:12 AM Martin Jansa <Martin.Jansa@gmail.com> wrote:

> * use 4 spaces
> * avoid trailing space


Thank you. I just noticed this yesterday in python3-bcrypt upgrade

>
> * add CARGO_LOCK_SRC_DIR to allow searching outside ${S}
> * use BPN in output filename
> * First I've used CARGO_LOCK_SRC_DIR as relative to ${S}, because that's
> what CARGO_SRC_DIR
>   in cargo.bbclass is using:
>   meta/classes-recipe/cargo.bbclass:CARGO_SRC_DIR ??= ""
>   meta/classes-recipe/cargo.bbclass:MANIFEST_PATH ??=
> "${S}/${CARGO_SRC_DIR}/Cargo.toml"
>
>   but change to absolute path (defaulting to ${S}) as requested by Alex:
>   11:44 < kanavin> JaMa, would prefer CARGO_LOCK_SRC_DIR ??= "${S}"
>   11:46 < kanavin> otherwise looks good
>
> * I've resolved my usecase for CARGO_LOCK_SRC_DIR by changing
>   S back to ${WORKDIR}/git and using CARGO_SRC_DIR to select
>   the right subdirectory to be built, because the Cargo.toml
>   in this subdirectory was also referencing other subdirectories
>   with relative path:
>
> https://github.com/solana-labs/solana-program-library/blob/88b147506d5b9515f3a4762421a0b8c309188dc9/token/cli/Cargo.toml#L30
>   so including all Cargo.lock files in whole ${WORKDIR}/git
>   seems like reasonable approach
>
> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> ---
>  .../cargo-update-recipe-crates.bbclass             | 14 +++++++++-----
>  1 file changed, 9 insertions(+), 5 deletions(-)
>
> diff --git a/meta/classes-recipe/cargo-update-recipe-crates.bbclass
> b/meta/classes-recipe/cargo-update-recipe-crates.bbclass
> index f90938c734..3a12ba247d 100644
> --- a/meta/classes-recipe/cargo-update-recipe-crates.bbclass
> +++ b/meta/classes-recipe/cargo-update-recipe-crates.bbclass
> @@ -16,26 +16,30 @@
>  addtask do_update_crates after do_patch
>  do_update_crates[depends] = "python3-native:do_populate_sysroot"
>
> +# The directory where to search for Cargo.lock files
> +CARGO_LOCK_SRC_DIR ??= "${S}"
> +
>  do_update_crates() {
>      nativepython3 - <<EOF
>
>  def get_crates(f):
>      import tomllib
> -    c_list = 'SRC_URI += " \\ \n'
> +    c_list = '# from %s' % os.path.relpath(f, '${CARGO_LOCK_SRC_DIR}')
> +    c_list += '\nSRC_URI += " \\\'
>      crates = tomllib.load(open(f, 'rb'))
>      for c in crates['package']:
>          if 'source' in c and 'crates.io' in c['source']:
> -            c_list += "        crate://crates.io/{}/{}
> <http://crates.io/%7B%7D/%7B%7D> \\ \n".format(c['name'], c['version'])
> -    c_list += '"\n'
> +            c_list += '\n    crate://crates.io/%s/%s \\\' % (c['name'],
> c['version'])
> +    c_list += '\n"\n'
>      return c_list
>
>  import os
>  crates = "# Autogenerated with 'bitbake -c update_crates ${PN}'\n\n"
> -for root, dirs, files in os.walk('${S}'):
> +for root, dirs, files in os.walk('${CARGO_LOCK_SRC_DIR}'):
>      for file in files:
>          if file == 'Cargo.lock':
>              crates += get_crates(os.path.join(root, file))
> -open(os.path.join('${THISDIR}', '${PN}'+"-crates.inc"), 'w').write(crates)
> +open(os.path.join('${THISDIR}', '${BPN}'+"-crates.inc"),
> 'w').write(crates)
>
>  EOF
>  }
> --
> 2.38.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#172576):
> https://lists.openembedded.org/g/openembedded-core/message/172576
> Mute This Topic: https://lists.openembedded.org/mt/94729650/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/classes-recipe/cargo-update-recipe-crates.bbclass b/meta/classes-recipe/cargo-update-recipe-crates.bbclass
index f90938c734..3a12ba247d 100644
--- a/meta/classes-recipe/cargo-update-recipe-crates.bbclass
+++ b/meta/classes-recipe/cargo-update-recipe-crates.bbclass
@@ -16,26 +16,30 @@ 
 addtask do_update_crates after do_patch
 do_update_crates[depends] = "python3-native:do_populate_sysroot"
 
+# The directory where to search for Cargo.lock files
+CARGO_LOCK_SRC_DIR ??= "${S}"
+
 do_update_crates() {
     nativepython3 - <<EOF
 
 def get_crates(f):
     import tomllib
-    c_list = 'SRC_URI += " \\ \n'
+    c_list = '# from %s' % os.path.relpath(f, '${CARGO_LOCK_SRC_DIR}')
+    c_list += '\nSRC_URI += " \\\'
     crates = tomllib.load(open(f, 'rb'))
     for c in crates['package']:
         if 'source' in c and 'crates.io' in c['source']:
-            c_list += "        crate://crates.io/{}/{} \\ \n".format(c['name'], c['version'])
-    c_list += '"\n'
+            c_list += '\n    crate://crates.io/%s/%s \\\' % (c['name'], c['version'])
+    c_list += '\n"\n'
     return c_list
 
 import os
 crates = "# Autogenerated with 'bitbake -c update_crates ${PN}'\n\n"
-for root, dirs, files in os.walk('${S}'):
+for root, dirs, files in os.walk('${CARGO_LOCK_SRC_DIR}'):
     for file in files:
         if file == 'Cargo.lock':
             crates += get_crates(os.path.join(root, file))
-open(os.path.join('${THISDIR}', '${PN}'+"-crates.inc"), 'w').write(crates)
+open(os.path.join('${THISDIR}', '${BPN}'+"-crates.inc"), 'w').write(crates)
 
 EOF
 }