diff mbox series

[openembedded-core] graphics: Hotfix for eGalax Touchscreen

Message ID 20220929095813.3207562-1-philippe.coval@astrolabe.coop
State New
Headers show
Series [openembedded-core] graphics: Hotfix for eGalax Touchscreen | expand

Commit Message

philippe.coval@astrolabe.coop Sept. 29, 2022, 9:58 a.m. UTC
From: Philippe Coval <philippe.coval@astrolabe.coop>

For unsupported screens (which X axis is inverted)

For the record issue was observed with this CVL1010 device:

http://www.cartft.com/en/catalog/il/1589#

For more details check related links:

Forwarded: https://lists.openembedded.org/g/openembedded-core/search?q=philippe.coval
Relate-to: https://gitlab.freedesktop.org/libinput/libinput/-/issues/665
Relate-to: https://at.projects.genivi.org/jira/si/jira.issueviews:issue-html/GDP-19/GDP-19.html
Relate-to: https://git.ostc-eu.org/OSTC/planning/blueprints/-/issues/22
Origin: https://git.ostc-eu.org/OSTC/OHOS/meta-ohos/-/merge_requests/288
Signed-off-by: Philippe Coval <philippe.coval@huawei.com>
Signed-off-by: Philippe Coval <philippe.coval@astrolabe.coop>
---
 .../wayland/libinput/90-usb-0eef-0001.rules         |  1 +
 meta/recipes-graphics/wayland/libinput_%.bbappend   | 13 +++++++++++++
 2 files changed, 14 insertions(+)
 create mode 100644 meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
 create mode 100644 meta/recipes-graphics/wayland/libinput_%.bbappend

Comments

Martin Jansa Sept. 29, 2022, 10:50 a.m. UTC | #1
Was this sent by accident? The overrides are all wrong and recipe from
oe-core surely shouldn't have a .bbappend in oe-core.

On Thu, Sep 29, 2022 at 11:58 AM <philippe.coval@astrolabe.coop> wrote:

> From: Philippe Coval <philippe.coval@astrolabe.coop>
>
> For unsupported screens (which X axis is inverted)
>
> For the record issue was observed with this CVL1010 device:
>
> http://www.cartft.com/en/catalog/il/1589#
>
> For more details check related links:
>
> Forwarded:
> https://lists.openembedded.org/g/openembedded-core/search?q=philippe.coval
> Relate-to
> <https://lists.openembedded.org/g/openembedded-core/search?q=philippe.covalRelate-to>:
> https://gitlab.freedesktop.org/libinput/libinput/-/issues/665
> Relate-to
> <https://gitlab.freedesktop.org/libinput/libinput/-/issues/665Relate-to>:
> https://at.projects.genivi.org/jira/si/jira.issueviews:issue-html/GDP-19/GDP-19.html
> Relate-to: https://git.ostc-eu.org/OSTC/planning/blueprints/-/issues/22
> Origin: https://git.ostc-eu.org/OSTC/OHOS/meta-ohos/-/merge_requests/288
> Signed-off-by
> <https://git.ostc-eu.org/OSTC/OHOS/meta-ohos/-/merge_requests/288Signed-off-by>:
> Philippe Coval <philippe.coval@huawei.com>
> Signed-off-by: Philippe Coval <philippe.coval@astrolabe.coop>
> ---
>  .../wayland/libinput/90-usb-0eef-0001.rules         |  1 +
>  meta/recipes-graphics/wayland/libinput_%.bbappend   | 13 +++++++++++++
>  2 files changed, 14 insertions(+)
>  create mode 100644
> meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
>  create mode 100644 meta/recipes-graphics/wayland/libinput_%.bbappend
>
> diff --git a/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
> b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
> new file mode 100644
> index 0000000000..354629dbbb
> --- /dev/null
> +++ b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
> @@ -0,0 +1 @@
> +ACTION=="add|change", KERNEL=="event[0-9]*", ENV{ID_VENDOR_ID}=="0eef",
> ENV{ID_MODEL_ID}=="0001", ENV{ID_INPUT_TOUCHSCREEN}="1",
> ENV{ID_INPUT_TABLET}="0", ENV{ID_INPUT_MOUSE}="0",
> ENV{LIBINPUT_CALIBRATION_MATRIX}="-1 0 1 0 1 0"
> diff --git a/meta/recipes-graphics/wayland/libinput_%.bbappend
> b/meta/recipes-graphics/wayland/libinput_%.bbappend
> new file mode 100644
> index 0000000000..281b499624
> --- /dev/null
> +++ b/meta/recipes-graphics/wayland/libinput_%.bbappend
> @@ -0,0 +1,13 @@
> +# SPDX-FileCopyrightText: Huawei Inc.
> +# SPDX-License-Identifier: Apache-2.0
> +
> +FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
> +
> +SRC_URI += "file://90-usb-0eef-0001.rules"
> +
> +do_install_append() {
> +    install -d  "${D}/${sysconfdir}/udev/rules.d"
> +    install -m444 "${WORKDIR}/90-usb-0eef-0001.rules"
> "${D}/${sysconfdir}/udev/rules.d/"
> +}
> +
> +FILES_${PN} += "${sysconfdir}/udev/rules.d/90-usb-0eef-0001.rules"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171179):
> https://lists.openembedded.org/g/openembedded-core/message/171179
> Mute This Topic: https://lists.openembedded.org/mt/93991089/3617156
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> Martin.Jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
philippe.coval@astrolabe.coop Sept. 29, 2022, 11:49 a.m. UTC | #2
Hi,
Yes sorry I sent it in a rush
it's not ready and should be reworked to be reviewed :)

But I am wondering if this is the right project to share it?

For the record I proposed it upstream (in libinput) and downstream (oniro),
but it was not merged because it's specific to some hardware that both projects do not support.

If not anyone can take and maintain this patch elsewhere...

Sorry for noise


On Thursday, September 29, 2022 12:50 CEST, Martin Jansa <martin.jansa@gmail.com> wrote:
 Was this sent by accident? The overrides are all wrong and recipe from oe-core surely shouldn't have a .bbappend in oe-core. On Thu, Sep 29, 2022 at 11:58 AM <philippe.coval@astrolabe.coop> wrote:From: Philippe Coval <philippe.coval@astrolabe.coop>

For unsupported screens (which X axis is inverted)

For the record issue was observed with this CVL1010 device:

http://www.cartft.com/en/catalog/il/1589#

For more details check related links:

Forwarded: https://lists.openembedded.org/g/openembedded-core/search?q=philippe.coval
Relate-to: https://gitlab.freedesktop.org/libinput/libinput/-/issues/665
Relate-to: https://at.projects.genivi.org/jira/si/jira.issueviews:issue-html/GDP-19/GDP-19.html
Relate-to: https://git.ostc-eu.org/OSTC/planning/blueprints/-/issues/22
Origin: https://git.ostc-eu.org/OSTC/OHOS/meta-ohos/-/merge_requests/288
Signed-off-by: Philippe Coval <philippe.coval@huawei.com>
Signed-off-by: Philippe Coval <philippe.coval@astrolabe.coop>
---
 .../wayland/libinput/90-usb-0eef-0001.rules         |  1 +
 meta/recipes-graphics/wayland/libinput_%.bbappend   | 13 +++++++++++++
 2 files changed, 14 insertions(+)
 create mode 100644 meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
 create mode 100644 meta/recipes-graphics/wayland/libinput_%.bbappend

diff --git a/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
new file mode 100644
index 0000000000..354629dbbb
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
@@ -0,0 +1 @@
+ACTION=="add|change", KERNEL=="event[0-9]*", ENV{ID_VENDOR_ID}=="0eef", ENV{ID_MODEL_ID}=="0001", ENV{ID_INPUT_TOUCHSCREEN}="1", ENV{ID_INPUT_TABLET}="0", ENV{ID_INPUT_MOUSE}="0", ENV{LIBINPUT_CALIBRATION_MATRIX}="-1 0 1 0 1 0"
diff --git a/meta/recipes-graphics/wayland/libinput_%.bbappend b/meta/recipes-graphics/wayland/libinput_%.bbappend
new file mode 100644
index 0000000000..281b499624
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_%.bbappend
@@ -0,0 +1,13 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+# SPDX-License-Identifier: Apache-2.0
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://90-usb-0eef-0001.rules"
+
+do_install_append() {
+    install -d  "${D}/${sysconfdir}/udev/rules.d"
+    install -m444 "${WORKDIR}/90-usb-0eef-0001.rules" "${D}/${sysconfdir}/udev/rules.d/"
+}
+
+FILES_${PN} += "${sysconfdir}/udev/rules.d/90-usb-0eef-0001.rules"
--
2.34.1


-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#171179): https://lists.openembedded.org/g/openembedded-core/message/171179
Mute This Topic: https://lists.openembedded.org/mt/93991089/3617156
Group Owner: openembedded-core+owner@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [Martin.Jansa@gmail.com]
-=-=-=-=-=-=-=-=-=-=-=-
diff mbox series

Patch

diff --git a/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
new file mode 100644
index 0000000000..354629dbbb
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput/90-usb-0eef-0001.rules
@@ -0,0 +1 @@ 
+ACTION=="add|change", KERNEL=="event[0-9]*", ENV{ID_VENDOR_ID}=="0eef", ENV{ID_MODEL_ID}=="0001", ENV{ID_INPUT_TOUCHSCREEN}="1", ENV{ID_INPUT_TABLET}="0", ENV{ID_INPUT_MOUSE}="0", ENV{LIBINPUT_CALIBRATION_MATRIX}="-1 0 1 0 1 0"
diff --git a/meta/recipes-graphics/wayland/libinput_%.bbappend b/meta/recipes-graphics/wayland/libinput_%.bbappend
new file mode 100644
index 0000000000..281b499624
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_%.bbappend
@@ -0,0 +1,13 @@ 
+# SPDX-FileCopyrightText: Huawei Inc.
+# SPDX-License-Identifier: Apache-2.0
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://90-usb-0eef-0001.rules"
+
+do_install_append() {
+    install -d  "${D}/${sysconfdir}/udev/rules.d"
+    install -m444 "${WORKDIR}/90-usb-0eef-0001.rules" "${D}/${sysconfdir}/udev/rules.d/"
+}
+
+FILES_${PN} += "${sysconfdir}/udev/rules.d/90-usb-0eef-0001.rules"