diff mbox series

gcompat: Add __getauxval wrapper needed on aarch64

Message ID 20220917211339.2536726-1-raj.khem@gmail.com
State Accepted, archived
Commit bac2c95f6331deafd3e07c927ba00a202db9a12b
Headers show
Series gcompat: Add __getauxval wrapper needed on aarch64 | expand

Commit Message

Khem Raj Sept. 17, 2022, 9:13 p.m. UTC
Update SRCREV to bring in few bug fixes
Install a .so symlink which could be used during linking

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../musl/gcompat/0001-auxv-new-module.patch   | 59 +++++++++++++++++++
 meta/recipes-core/musl/gcompat_git.bb         |  6 +-
 2 files changed, 63 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch

Comments

Richard Purdie Sept. 20, 2022, 9:39 a.m. UTC | #1
On Sat, 2022-09-17 at 14:13 -0700, Khem Raj wrote:
> Update SRCREV to bring in few bug fixes
> Install a .so symlink which could be used during linking
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../musl/gcompat/0001-auxv-new-module.patch   | 59 +++++++++++++++++++
>  meta/recipes-core/musl/gcompat_git.bb         |  6 +-
>  2 files changed, 63 insertions(+), 2 deletions(-)
>  create mode 100644 meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5873
https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5890

Cheers,

Richard
Khem Raj Sept. 21, 2022, 2:25 a.m. UTC | #2
On 9/20/22 5:39 AM, Richard Purdie wrote:
> On Sat, 2022-09-17 at 14:13 -0700, Khem Raj wrote:
>> Update SRCREV to bring in few bug fixes
>> Install a .so symlink which could be used during linking
>>
>> Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ---
>>   .../musl/gcompat/0001-auxv-new-module.patch   | 59 +++++++++++++++++++
>>   meta/recipes-core/musl/gcompat_git.bb         |  6 +-
>>   2 files changed, 63 insertions(+), 2 deletions(-)
>>   create mode 100644 meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5873
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5890
> 

Yeah my bad, Yoe distro uses usrmerge feature, and I forgot the main 
library is installed in base_libdir and not libdir, sent a v2 with this 
changed

> Cheers,
> 
> Richard
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch b/meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch
new file mode 100644
index 0000000000..ee292f3841
--- /dev/null
+++ b/meta/recipes-core/musl/gcompat/0001-auxv-new-module.patch
@@ -0,0 +1,59 @@ 
+From aecd42801904462501a890d173648e4e826eda19 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sat, 23 Oct 2021 23:29:40 -0500
+Subject: [PATCH] auxv: new module
+
+Adds `__getauxval` wrapper, needed for Parallels Tools GUI installer.
+
+Upstream-Status: Submitted [https://git.adelielinux.org/adelie/gcompat/-/commit/e860a38a88c7ea148ee15976136a1f83ea13f8e0]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ CHANGELOG.rst     | 5 +++++
+ Makefile          | 1 +
+ libgcompat/auxv.c | 6 ++++++
+ 3 files changed, 12 insertions(+)
+ create mode 100644 libgcompat/auxv.c
+
+diff --git a/CHANGELOG.rst b/CHANGELOG.rst
+index ce6859b..c3a9cee 100644
+--- a/CHANGELOG.rst
++++ b/CHANGELOG.rst
+@@ -11,6 +11,11 @@
+ 1.1 (202?-??-??)
+ ================
+ 
++auxv
++----
++
++* Add __getauxval wrapper for getauxval.
++
+ locale
+ ------
+ 
+diff --git a/Makefile b/Makefile
+index cbb7634..1893cc1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,6 +2,7 @@ LIBGCOMPAT_INCLUDE = \
+ 	libgcompat/alias.h \
+ 	libgcompat/internal.h
+ LIBGCOMPAT_SRC = \
++	libgcompat/auxv.c		\
+ 	libgcompat/ctype.c		\
+ 	libgcompat/cxx_thread.c		\
+ 	libgcompat/dlfcn.c		\
+diff --git a/libgcompat/auxv.c b/libgcompat/auxv.c
+new file mode 100644
+index 0000000..01de376
+--- /dev/null
++++ b/libgcompat/auxv.c
+@@ -0,0 +1,6 @@
++#include <sys/auxv.h> /* getauxval */
++
++unsigned long __getauxval(unsigned long value)
++{
++	return getauxval(value);
++}
+-- 
+2.37.3
+
diff --git a/meta/recipes-core/musl/gcompat_git.bb b/meta/recipes-core/musl/gcompat_git.bb
index b051e43b6c..ffdb11a190 100644
--- a/meta/recipes-core/musl/gcompat_git.bb
+++ b/meta/recipes-core/musl/gcompat_git.bb
@@ -8,12 +8,13 @@  LICENSE = "NCSA"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=eb33ef4af05a9c7602843afb7adfe792"
 
 SRC_URI = "git://git.adelielinux.org/adelie/gcompat.git;protocol=https;branch=current \
-          "
+           file://0001-auxv-new-module.patch \
+           "
 SRC_URI:append:powerpc = "\
            file://0001-make-Static-PIE-does-not-work-on-musl-ppc.patch \
            "
 PV = "1.0.0+1.1+git${SRCPV}"
-SRCREV = "4d6a5156a6eb7f56b30d93853a872e36dadde81b"
+SRCREV = "c6921a1aa454bb87671f9bd1ecfe47d80d1620aa"
 
 S = "${WORKDIR}/git"
 
@@ -42,6 +43,7 @@  do_install () {
 		install -d ${D}${nonarch_base_libdir}${SITEINFO_BITS}
 		ln -rs ${D}${GLIBC_LDSO} ${D}${nonarch_base_libdir}${SITEINFO_BITS}/`basename ${GLIBC_LDSO}`
 	fi
+        ln -sf libgcompat.so.0 ${D}${libdir}/libgcompat.so
 }
 
 FILES:${PN} += "${nonarch_base_libdir}${SITEINFO_BITS}"