diff mbox series

[1/1] watchdog: Remove unneeded tirpc dependency

Message ID 20220912092122.2020942-1-ptsneves@gmail.com
State Accepted, archived
Commit 1080316fbb863809a75f8a0acd72c06221beedb1
Headers show
Series [1/1] watchdog: Remove unneeded tirpc dependency | expand

Commit Message

Paulo Neves Sept. 12, 2022, 9:21 a.m. UTC
watchdog code does not have any dependency on rpc code,
therefore the dependency and flags to try to use it are
removed.

Signed-off-by: Paulo Neves <ptsneves@gmail.com>
---
 meta/recipes-extended/watchdog/watchdog_5.16.bb | 4 ----
 1 file changed, 4 deletions(-)

Comments

Khem Raj Sept. 12, 2022, 3:06 p.m. UTC | #1
On Mon, Sep 12, 2022 at 2:21 AM Paulo Neves <ptsneves@gmail.com> wrote:
>
> watchdog code does not have any dependency on rpc code,
> therefore the dependency and flags to try to use it are
> removed.
>
> Signed-off-by: Paulo Neves <ptsneves@gmail.com>
> ---
>  meta/recipes-extended/watchdog/watchdog_5.16.bb | 4 ----
>  1 file changed, 4 deletions(-)
>
> diff --git a/meta/recipes-extended/watchdog/watchdog_5.16.bb b/meta/recipes-extended/watchdog/watchdog_5.16.bb
> index 26fcc10487..6031dcaa16 100644
> --- a/meta/recipes-extended/watchdog/watchdog_5.16.bb
> +++ b/meta/recipes-extended/watchdog/watchdog_5.16.bb
> @@ -28,10 +28,6 @@ UPSTREAM_CHECK_REGEX = "/watchdog/(?P<pver>(\d+[\.\-_]*)+)/"
>
>  inherit autotools update-rc.d systemd pkgconfig
>
> -DEPENDS += "libtirpc"
> -CFLAGS += "-I${STAGING_INCDIR}/tirpc"
> -LDFLAGS += "-ltirpc"
> -

does musl build works too ?

>  EXTRA_OECONF += " --disable-nfs "
>  CACHED_CONFIGUREVARS += "ac_cv_path_PATH_SENDMAIL=${sbindir}/sendmail"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170533): https://lists.openembedded.org/g/openembedded-core/message/170533
> Mute This Topic: https://lists.openembedded.org/mt/93628579/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Paulo Neves Sept. 12, 2022, 7:08 p.m. UTC | #2
it should as there is no rpc code in the project as far as i scanned. I 
built it with musl successfully.

Paulo Neves

On 9/12/22 17:06, Khem Raj wrote:
> On Mon, Sep 12, 2022 at 2:21 AM Paulo Neves <ptsneves@gmail.com> wrote:
>> watchdog code does not have any dependency on rpc code,
>> therefore the dependency and flags to try to use it are
>> removed.
>>
>> Signed-off-by: Paulo Neves <ptsneves@gmail.com>
>> ---
>>   meta/recipes-extended/watchdog/watchdog_5.16.bb | 4 ----
>>   1 file changed, 4 deletions(-)
>>
>> diff --git a/meta/recipes-extended/watchdog/watchdog_5.16.bb b/meta/recipes-extended/watchdog/watchdog_5.16.bb
>> index 26fcc10487..6031dcaa16 100644
>> --- a/meta/recipes-extended/watchdog/watchdog_5.16.bb
>> +++ b/meta/recipes-extended/watchdog/watchdog_5.16.bb
>> @@ -28,10 +28,6 @@ UPSTREAM_CHECK_REGEX = "/watchdog/(?P<pver>(\d+[\.\-_]*)+)/"
>>
>>   inherit autotools update-rc.d systemd pkgconfig
>>
>> -DEPENDS += "libtirpc"
>> -CFLAGS += "-I${STAGING_INCDIR}/tirpc"
>> -LDFLAGS += "-ltirpc"
>> -
> does musl build works too ?
>
>>   EXTRA_OECONF += " --disable-nfs "
>>   CACHED_CONFIGUREVARS += "ac_cv_path_PATH_SENDMAIL=${sbindir}/sendmail"
>>
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#170533): https://lists.openembedded.org/g/openembedded-core/message/170533
>> Mute This Topic: https://lists.openembedded.org/mt/93628579/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Sept. 12, 2022, 7:22 p.m. UTC | #3
On Mon, Sep 12, 2022 at 12:08 PM Paulo Neves <ptsneves@gmail.com> wrote:
>
> it should as there is no rpc code in the project as far as i scanned. I
> built it with musl successfully.

OK thanks for confirming.

>
> Paulo Neves
>
> On 9/12/22 17:06, Khem Raj wrote:
> > On Mon, Sep 12, 2022 at 2:21 AM Paulo Neves <ptsneves@gmail.com> wrote:
> >> watchdog code does not have any dependency on rpc code,
> >> therefore the dependency and flags to try to use it are
> >> removed.
> >>
> >> Signed-off-by: Paulo Neves <ptsneves@gmail.com>
> >> ---
> >>   meta/recipes-extended/watchdog/watchdog_5.16.bb | 4 ----
> >>   1 file changed, 4 deletions(-)
> >>
> >> diff --git a/meta/recipes-extended/watchdog/watchdog_5.16.bb b/meta/recipes-extended/watchdog/watchdog_5.16.bb
> >> index 26fcc10487..6031dcaa16 100644
> >> --- a/meta/recipes-extended/watchdog/watchdog_5.16.bb
> >> +++ b/meta/recipes-extended/watchdog/watchdog_5.16.bb
> >> @@ -28,10 +28,6 @@ UPSTREAM_CHECK_REGEX = "/watchdog/(?P<pver>(\d+[\.\-_]*)+)/"
> >>
> >>   inherit autotools update-rc.d systemd pkgconfig
> >>
> >> -DEPENDS += "libtirpc"
> >> -CFLAGS += "-I${STAGING_INCDIR}/tirpc"
> >> -LDFLAGS += "-ltirpc"
> >> -
> > does musl build works too ?
> >
> >>   EXTRA_OECONF += " --disable-nfs "
> >>   CACHED_CONFIGUREVARS += "ac_cv_path_PATH_SENDMAIL=${sbindir}/sendmail"
> >>
> >> --
> >> 2.25.1
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#170533): https://lists.openembedded.org/g/openembedded-core/message/170533
> >> Mute This Topic: https://lists.openembedded.org/mt/93628579/1997914
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/watchdog/watchdog_5.16.bb b/meta/recipes-extended/watchdog/watchdog_5.16.bb
index 26fcc10487..6031dcaa16 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.16.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.16.bb
@@ -28,10 +28,6 @@  UPSTREAM_CHECK_REGEX = "/watchdog/(?P<pver>(\d+[\.\-_]*)+)/"
 
 inherit autotools update-rc.d systemd pkgconfig
 
-DEPENDS += "libtirpc"
-CFLAGS += "-I${STAGING_INCDIR}/tirpc"
-LDFLAGS += "-ltirpc"
-
 EXTRA_OECONF += " --disable-nfs "
 CACHED_CONFIGUREVARS += "ac_cv_path_PATH_SENDMAIL=${sbindir}/sendmail"