diff mbox series

linux-yocto: Enable mdio for qemu

Message ID 20220907220535.3017588-1-raj.khem@gmail.com
State Accepted, archived
Commit 096c2588860d8f2c56a97cff72f70dd59276f9c7
Headers show
Series linux-yocto: Enable mdio for qemu | expand

Commit Message

Khem Raj Sept. 7, 2022, 10:05 p.m. UTC
There are package like mdio-netlink in meta-oe which need this feature
to be available, it has started to fail with 5.19

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto_5.19.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bruce Ashfield Sept. 8, 2022, 12:10 a.m. UTC | #1
On Wed, Sep 7, 2022 at 6:05 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> There are package like mdio-netlink in meta-oe which need this feature
> to be available, it has started to fail with 5.19

Fine with me!

Bruce

>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/linux/linux-yocto_5.19.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> index 0ff28aa952..e96395d1bb 100644
> --- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> @@ -56,7 +56,7 @@ COMPATIBLE_MACHINE = "^(qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemuppc64|qe
>  # Functionality flags
>  KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
>  KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
> -KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
> +KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc cfg/net/mdio.scc"
>  KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> --
> 2.37.3
>
Alexandre Belloni Sept. 8, 2022, 1:48 p.m. UTC | #2
Hi,

This caused many failures like this one:
https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5847/steps/11/logs/stdio

On 07/09/2022 15:05:35-0700, Khem Raj wrote:
> There are package like mdio-netlink in meta-oe which need this feature
> to be available, it has started to fail with 5.19
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/linux/linux-yocto_5.19.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> index 0ff28aa952..e96395d1bb 100644
> --- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> @@ -56,7 +56,7 @@ COMPATIBLE_MACHINE = "^(qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemuppc64|qe
>  # Functionality flags
>  KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
>  KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
> -KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
> +KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc cfg/net/mdio.scc"
>  KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> -- 
> 2.37.3
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170431): https://lists.openembedded.org/g/openembedded-core/message/170431
> Mute This Topic: https://lists.openembedded.org/mt/93535950/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Bruce Ashfield Sept. 8, 2022, 2:08 p.m. UTC | #3
On Thu, Sep 8, 2022 at 9:48 AM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hi,
>
> This caused many failures like this one:
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5847/steps/11/logs/stdio
>

Technically not an error, only an error in the eyes of the stricter testing.

Khem: Let me queue the patch here, and I'll add a mask for that
warning, since in this case =y is as good as =m

Bruce

> On 07/09/2022 15:05:35-0700, Khem Raj wrote:
> > There are package like mdio-netlink in meta-oe which need this feature
> > to be available, it has started to fail with 5.19
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> > ---
> >  meta/recipes-kernel/linux/linux-yocto_5.19.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > index 0ff28aa952..e96395d1bb 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > @@ -56,7 +56,7 @@ COMPATIBLE_MACHINE = "^(qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemuppc64|qe
> >  # Functionality flags
> >  KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
> >  KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
> > -KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
> > +KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc cfg/net/mdio.scc"
> >  KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
> >  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
> >  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> > --
> > 2.37.3
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#170431): https://lists.openembedded.org/g/openembedded-core/message/170431
> > Mute This Topic: https://lists.openembedded.org/mt/93535950/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Khem Raj Sept. 8, 2022, 6:43 p.m. UTC | #4
Cool, thanks!

On Thu, Sep 8, 2022 at 7:09 AM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
>
> On Thu, Sep 8, 2022 at 9:48 AM Alexandre Belloni
> <alexandre.belloni@bootlin.com> wrote:
> >
> > Hi,
> >
> > This caused many failures like this one:
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5847/steps/11/logs/stdio
> >
>
> Technically not an error, only an error in the eyes of the stricter testing.
>
> Khem: Let me queue the patch here, and I'll add a mask for that
> warning, since in this case =y is as good as =m
>
> Bruce
>
> > On 07/09/2022 15:05:35-0700, Khem Raj wrote:
> > > There are package like mdio-netlink in meta-oe which need this feature
> > > to be available, it has started to fail with 5.19
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> > > ---
> > >  meta/recipes-kernel/linux/linux-yocto_5.19.bb | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > > index 0ff28aa952..e96395d1bb 100644
> > > --- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > > +++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
> > > @@ -56,7 +56,7 @@ COMPATIBLE_MACHINE = "^(qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemuppc64|qe
> > >  # Functionality flags
> > >  KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
> > >  KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
> > > -KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
> > > +KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc cfg/net/mdio.scc"
> > >  KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
> > >  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
> > >  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
> > > --
> > > 2.37.3
> > >
> >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#170431): https://lists.openembedded.org/g/openembedded-core/message/170431
> > > Mute This Topic: https://lists.openembedded.org/mt/93535950/3617179
> > > Group Owner: openembedded-core+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
> >
> >
> > --
> > Alexandre Belloni, co-owner and COO, Bootlin
> > Embedded Linux and Kernel engineering
> > https://bootlin.com
>
>
>
> --
> - Thou shalt not follow the NULL pointer, for chaos and madness await
> thee at its end
> - "Use the force Harry" - Gandalf, Star Trek II
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
index 0ff28aa952..e96395d1bb 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
@@ -56,7 +56,7 @@  COMPATIBLE_MACHINE = "^(qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemuppc64|qe
 # Functionality flags
 KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
 KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
-KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
+KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc cfg/net/mdio.scc"
 KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
 KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"