diff mbox series

python3-lxml: Add recipe

Message ID 20220903174558.66575-1-raj.khem@gmail.com
State Accepted, archived
Commit 19e87e03234245c522d63f14365885ab5369a54c
Headers show
Series python3-lxml: Add recipe | expand

Commit Message

Khem Raj Sept. 3, 2022, 5:45 p.m. UTC
Import this recipe from meta-python, as it is needed by many recipes
from different layers e.g. wireplumber from meta-multimedia,
opengl-es-cts and vulkan-cts in meta-oe, yelp-tools in meta-gnome to
name a few, the real issue is that newer vulkan-cts has added this
dependency which is in meta-oe, and meta-oe can not depend on
meta-python

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/conf/distro/include/maintainers.inc      |  1 +
 .../python/python3-lxml_4.9.1.bb              | 42 +++++++++++++++++++
 2 files changed, 43 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-lxml_4.9.1.bb

Comments

Alexander Kanavin Sept. 4, 2022, 4:44 a.m. UTC | #1
But why move the recipe to core? Why not meta-oe?

Alex

On Sat 3. Sep 2022 at 19.46, Khem Raj <raj.khem@gmail.com> wrote:

> Import this recipe from meta-python, as it is needed by many recipes
> from different layers e.g. wireplumber from meta-multimedia,
> opengl-es-cts and vulkan-cts in meta-oe, yelp-tools in meta-gnome to
> name a few, the real issue is that newer vulkan-cts has added this
> dependency which is in meta-oe, and meta-oe can not depend on
> meta-python
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/conf/distro/include/maintainers.inc      |  1 +
>  .../python/python3-lxml_4.9.1.bb              | 42 +++++++++++++++++++
>  2 files changed, 43 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-lxml_4.9.1.bb
>
> diff --git a/meta/conf/distro/include/maintainers.inc
> b/meta/conf/distro/include/maintainers.inc
> index 3c80a3a617..fee4e52b10 100644
> --- a/meta/conf/distro/include/maintainers.inc
> +++ b/meta/conf/distro/include/maintainers.inc
> @@ -626,6 +626,7 @@ RECIPE_MAINTAINER:pn-python3-jinja2 = "Richard Purdie
> <richard.purdie@linuxfound
>  RECIPE_MAINTAINER:pn-python3-jsonpointer = "Bruce Ashfield <
> bruce.ashfield@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-jsonschema = "Bruce Ashfield <
> bruce.ashfield@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-libarchive-c = "Joshua Watt <
> JPEWhacker@gmail.com>"
> +RECIPE_MAINTAINER:pn-python3-lxml = "Khem Raj <raj.khem@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-magic = "Joshua Watt <JPEWhacker@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-mako = "Oleksandr Kravchuk <
> open.source@oleksandr-kravchuk.com>"
>  RECIPE_MAINTAINER:pn-python3-markdown = "Alexander Kanavin <
> alex.kanavin@gmail.com>"
> diff --git a/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> new file mode 100644
> index 0000000000..92a30f7907
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> @@ -0,0 +1,42 @@
> +SUMMARY = "Powerful and Pythonic XML processing library combining
> libxml2/libxslt with the ElementTree API."
> +DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
> +libxslt libraries. It provides safe and convenient access to these \
> +libraries using the ElementTree API. It extends the ElementTree API \
> +significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
> +C14N and much more."
> +HOMEPAGE = "https://lxml.de/"
> +SECTION = "devel/python"
> +LICENSE = "BSD-3-Clause & GPL-2.0-only & MIT & PSF-2.0"
> +LIC_FILES_CHKSUM =
> "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
> +
> file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
> +
> file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
> +
> file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
> +
> file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10
> \
> +
> file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b
> \
> +
> file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53
> \
> +                    "
> +
> +DEPENDS += "libxml2 libxslt"
> +
> +SRC_URI[sha256sum] =
> "fe749b052bb7233fe5d072fcb549221a8cb1a16725c47c37e42b0b9cb3ff2c3f"
> +
> +SRC_URI += "${PYPI_SRC_URI}"
> +inherit pkgconfig pypi setuptools3
> +
> +# {standard input}: Assembler messages:
> +# {standard input}:1488805: Error: branch out of range
> +DEBUG_OPTIMIZATION:remove:mips = " -Og"
> +DEBUG_OPTIMIZATION:append:mips = " -O"
> +BUILD_OPTIMIZATION:remove:mips = " -Og"
> +BUILD_OPTIMIZATION:append:mips = " -O"
> +
> +DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
> +DEBUG_OPTIMIZATION:append:mipsel = " -O"
> +BUILD_OPTIMIZATION:remove:mipsel = " -Og"
> +BUILD_OPTIMIZATION:append:mipsel = " -O"
> +
> +BBCLASSEXTEND = "native nativesdk"
> +
> +RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
> +
> +CLEANBROKEN = "1"
> --
> 2.37.3
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170270):
> https://lists.openembedded.org/g/openembedded-core/message/170270
> Mute This Topic: https://lists.openembedded.org/mt/93444245/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Sept. 4, 2022, 6:57 a.m. UTC | #2
On Sat, Sep 3, 2022 at 9:44 PM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> But why move the recipe to core? Why not meta-oe?

We could do that as well, don't see a big difference. I briefly looked
at vulkan related recipes
in core, but they don't yet use lxml like cts ones in meta-oe,
secondly systemd could use it
but it's optional as of now. So perhaps keeping it in meta-oe is fine for now.

>
> Alex
>
> On Sat 3. Sep 2022 at 19.46, Khem Raj <raj.khem@gmail.com> wrote:
>>
>> Import this recipe from meta-python, as it is needed by many recipes
>> from different layers e.g. wireplumber from meta-multimedia,
>> opengl-es-cts and vulkan-cts in meta-oe, yelp-tools in meta-gnome to
>> name a few, the real issue is that newer vulkan-cts has added this
>> dependency which is in meta-oe, and meta-oe can not depend on
>> meta-python
>>
>> Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ---
>>  meta/conf/distro/include/maintainers.inc      |  1 +
>>  .../python/python3-lxml_4.9.1.bb              | 42 +++++++++++++++++++
>>  2 files changed, 43 insertions(+)
>>  create mode 100644 meta/recipes-devtools/python/python3-lxml_4.9.1.bb
>>
>> diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
>> index 3c80a3a617..fee4e52b10 100644
>> --- a/meta/conf/distro/include/maintainers.inc
>> +++ b/meta/conf/distro/include/maintainers.inc
>> @@ -626,6 +626,7 @@ RECIPE_MAINTAINER:pn-python3-jinja2 = "Richard Purdie <richard.purdie@linuxfound
>>  RECIPE_MAINTAINER:pn-python3-jsonpointer = "Bruce Ashfield <bruce.ashfield@gmail.com>"
>>  RECIPE_MAINTAINER:pn-python3-jsonschema = "Bruce Ashfield <bruce.ashfield@gmail.com>"
>>  RECIPE_MAINTAINER:pn-python3-libarchive-c = "Joshua Watt <JPEWhacker@gmail.com>"
>> +RECIPE_MAINTAINER:pn-python3-lxml = "Khem Raj <raj.khem@gmail.com>"
>>  RECIPE_MAINTAINER:pn-python3-magic = "Joshua Watt <JPEWhacker@gmail.com>"
>>  RECIPE_MAINTAINER:pn-python3-mako = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
>>  RECIPE_MAINTAINER:pn-python3-markdown = "Alexander Kanavin <alex.kanavin@gmail.com>"
>> diff --git a/meta/recipes-devtools/python/python3-lxml_4.9.1.bb b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
>> new file mode 100644
>> index 0000000000..92a30f7907
>> --- /dev/null
>> +++ b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
>> @@ -0,0 +1,42 @@
>> +SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
>> +DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
>> +libxslt libraries. It provides safe and convenient access to these \
>> +libraries using the ElementTree API. It extends the ElementTree API \
>> +significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
>> +C14N and much more."
>> +HOMEPAGE = "https://lxml.de/"
>> +SECTION = "devel/python"
>> +LICENSE = "BSD-3-Clause & GPL-2.0-only & MIT & PSF-2.0"
>> +LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
>> +                    file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
>> +                    file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
>> +                    file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
>> +                    file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
>> +                    file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
>> +                    file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
>> +                    "
>> +
>> +DEPENDS += "libxml2 libxslt"
>> +
>> +SRC_URI[sha256sum] = "fe749b052bb7233fe5d072fcb549221a8cb1a16725c47c37e42b0b9cb3ff2c3f"
>> +
>> +SRC_URI += "${PYPI_SRC_URI}"
>> +inherit pkgconfig pypi setuptools3
>> +
>> +# {standard input}: Assembler messages:
>> +# {standard input}:1488805: Error: branch out of range
>> +DEBUG_OPTIMIZATION:remove:mips = " -Og"
>> +DEBUG_OPTIMIZATION:append:mips = " -O"
>> +BUILD_OPTIMIZATION:remove:mips = " -Og"
>> +BUILD_OPTIMIZATION:append:mips = " -O"
>> +
>> +DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
>> +DEBUG_OPTIMIZATION:append:mipsel = " -O"
>> +BUILD_OPTIMIZATION:remove:mipsel = " -Og"
>> +BUILD_OPTIMIZATION:append:mipsel = " -O"
>> +
>> +BBCLASSEXTEND = "native nativesdk"
>> +
>> +RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
>> +
>> +CLEANBROKEN = "1"
>> --
>> 2.37.3
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#170270): https://lists.openembedded.org/g/openembedded-core/message/170270
>> Mute This Topic: https://lists.openembedded.org/mt/93444245/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Sept. 4, 2022, 7:04 a.m. UTC | #3
On Sat, Sep 3, 2022 at 11:57 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Sat, Sep 3, 2022 at 9:44 PM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> >
> > But why move the recipe to core? Why not meta-oe?
>
> We could do that as well, don't see a big difference. I briefly looked
> at vulkan related recipes
> in core, but they don't yet use lxml like cts ones in meta-oe,
> secondly systemd could use it
> but it's optional as of now. So perhaps keeping it in meta-oe is fine for now.
>

Well, there is another compelling reason, that I forgot to mention,
meta-python does not depend on meta-oe as of now
if we move this recipe to meta-oe then meta-python will have to start
depending on
meta-oe and there are a bunch of python recipes in meta-python which depend on
this recipe. I think its a good setup to keep these layers independent
as they have been

> >
> > Alex
> >
> > On Sat 3. Sep 2022 at 19.46, Khem Raj <raj.khem@gmail.com> wrote:
> >>
> >> Import this recipe from meta-python, as it is needed by many recipes
> >> from different layers e.g. wireplumber from meta-multimedia,
> >> opengl-es-cts and vulkan-cts in meta-oe, yelp-tools in meta-gnome to
> >> name a few, the real issue is that newer vulkan-cts has added this
> >> dependency which is in meta-oe, and meta-oe can not depend on
> >> meta-python
> >>
> >> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> >> ---
> >>  meta/conf/distro/include/maintainers.inc      |  1 +
> >>  .../python/python3-lxml_4.9.1.bb              | 42 +++++++++++++++++++
> >>  2 files changed, 43 insertions(+)
> >>  create mode 100644 meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> >>
> >> diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
> >> index 3c80a3a617..fee4e52b10 100644
> >> --- a/meta/conf/distro/include/maintainers.inc
> >> +++ b/meta/conf/distro/include/maintainers.inc
> >> @@ -626,6 +626,7 @@ RECIPE_MAINTAINER:pn-python3-jinja2 = "Richard Purdie <richard.purdie@linuxfound
> >>  RECIPE_MAINTAINER:pn-python3-jsonpointer = "Bruce Ashfield <bruce.ashfield@gmail.com>"
> >>  RECIPE_MAINTAINER:pn-python3-jsonschema = "Bruce Ashfield <bruce.ashfield@gmail.com>"
> >>  RECIPE_MAINTAINER:pn-python3-libarchive-c = "Joshua Watt <JPEWhacker@gmail.com>"
> >> +RECIPE_MAINTAINER:pn-python3-lxml = "Khem Raj <raj.khem@gmail.com>"
> >>  RECIPE_MAINTAINER:pn-python3-magic = "Joshua Watt <JPEWhacker@gmail.com>"
> >>  RECIPE_MAINTAINER:pn-python3-mako = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
> >>  RECIPE_MAINTAINER:pn-python3-markdown = "Alexander Kanavin <alex.kanavin@gmail.com>"
> >> diff --git a/meta/recipes-devtools/python/python3-lxml_4.9.1.bb b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> >> new file mode 100644
> >> index 0000000000..92a30f7907
> >> --- /dev/null
> >> +++ b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
> >> @@ -0,0 +1,42 @@
> >> +SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
> >> +DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
> >> +libxslt libraries. It provides safe and convenient access to these \
> >> +libraries using the ElementTree API. It extends the ElementTree API \
> >> +significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
> >> +C14N and much more."
> >> +HOMEPAGE = "https://lxml.de/"
> >> +SECTION = "devel/python"
> >> +LICENSE = "BSD-3-Clause & GPL-2.0-only & MIT & PSF-2.0"
> >> +LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
> >> +                    file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
> >> +                    file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
> >> +                    file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
> >> +                    file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
> >> +                    file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
> >> +                    file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
> >> +                    "
> >> +
> >> +DEPENDS += "libxml2 libxslt"
> >> +
> >> +SRC_URI[sha256sum] = "fe749b052bb7233fe5d072fcb549221a8cb1a16725c47c37e42b0b9cb3ff2c3f"
> >> +
> >> +SRC_URI += "${PYPI_SRC_URI}"
> >> +inherit pkgconfig pypi setuptools3
> >> +
> >> +# {standard input}: Assembler messages:
> >> +# {standard input}:1488805: Error: branch out of range
> >> +DEBUG_OPTIMIZATION:remove:mips = " -Og"
> >> +DEBUG_OPTIMIZATION:append:mips = " -O"
> >> +BUILD_OPTIMIZATION:remove:mips = " -Og"
> >> +BUILD_OPTIMIZATION:append:mips = " -O"
> >> +
> >> +DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
> >> +DEBUG_OPTIMIZATION:append:mipsel = " -O"
> >> +BUILD_OPTIMIZATION:remove:mipsel = " -Og"
> >> +BUILD_OPTIMIZATION:append:mipsel = " -O"
> >> +
> >> +BBCLASSEXTEND = "native nativesdk"
> >> +
> >> +RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
> >> +
> >> +CLEANBROKEN = "1"
> >> --
> >> 2.37.3
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#170270): https://lists.openembedded.org/g/openembedded-core/message/170270
> >> Mute This Topic: https://lists.openembedded.org/mt/93444245/1686489
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
diff mbox series

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 3c80a3a617..fee4e52b10 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -626,6 +626,7 @@  RECIPE_MAINTAINER:pn-python3-jinja2 = "Richard Purdie <richard.purdie@linuxfound
 RECIPE_MAINTAINER:pn-python3-jsonpointer = "Bruce Ashfield <bruce.ashfield@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-jsonschema = "Bruce Ashfield <bruce.ashfield@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-libarchive-c = "Joshua Watt <JPEWhacker@gmail.com>"
+RECIPE_MAINTAINER:pn-python3-lxml = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-magic = "Joshua Watt <JPEWhacker@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-mako = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
 RECIPE_MAINTAINER:pn-python3-markdown = "Alexander Kanavin <alex.kanavin@gmail.com>"
diff --git a/meta/recipes-devtools/python/python3-lxml_4.9.1.bb b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
new file mode 100644
index 0000000000..92a30f7907
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-lxml_4.9.1.bb
@@ -0,0 +1,42 @@ 
+SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
+DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
+libxslt libraries. It provides safe and convenient access to these \
+libraries using the ElementTree API. It extends the ElementTree API \
+significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
+C14N and much more."
+HOMEPAGE = "https://lxml.de/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause & GPL-2.0-only & MIT & PSF-2.0"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
+                    file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
+                    file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
+                    file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
+                    file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
+                    file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
+                    "
+
+DEPENDS += "libxml2 libxslt"
+
+SRC_URI[sha256sum] = "fe749b052bb7233fe5d072fcb549221a8cb1a16725c47c37e42b0b9cb3ff2c3f"
+
+SRC_URI += "${PYPI_SRC_URI}"
+inherit pkgconfig pypi setuptools3
+
+# {standard input}: Assembler messages:
+# {standard input}:1488805: Error: branch out of range
+DEBUG_OPTIMIZATION:remove:mips = " -Og"
+DEBUG_OPTIMIZATION:append:mips = " -O"
+BUILD_OPTIMIZATION:remove:mips = " -Og"
+BUILD_OPTIMIZATION:append:mips = " -O"
+
+DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
+DEBUG_OPTIMIZATION:append:mipsel = " -O"
+BUILD_OPTIMIZATION:remove:mipsel = " -Og"
+BUILD_OPTIMIZATION:append:mipsel = " -O"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
+
+CLEANBROKEN = "1"