diff mbox series

gcc: Upgrade to 12.2.0

Message ID 20220820163903.3462152-1-raj.khem@gmail.com
State Accepted, archived
Commit b73f5c0a7b94d9d04dd69fe5a5b871eab05714a3
Headers show
Series gcc: Upgrade to 12.2.0 | expand

Commit Message

Khem Raj Aug. 20, 2022, 4:39 p.m. UTC
GCC 12.2 is the first bug-fix release from the GCC 12 branch containing
important fixes for regressions and serious bugs in GCC 12.1 with more
than 71 bugs fixed since the previous release comprising of  a number
of libstdc++ and C++ and fortran fixes [1]

Remove backported patch to fix libsanitizers with glibc 2.36, its
already present in 12.2

[1] https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.2

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/conf/distro/include/maintainers.inc      |  2 +-
 .../gcc/{gcc-12.1.inc => gcc-12.2.inc}        |  7 ++-
 ...ian_12.1.bb => gcc-cross-canadian_12.2.bb} |  0
 .../{gcc-cross_12.1.bb => gcc-cross_12.2.bb}  |  0
 ...-crosssdk_12.1.bb => gcc-crosssdk_12.2.bb} |  0
 ...cc-runtime_12.1.bb => gcc-runtime_12.2.bb} |  0
 ...itizers_12.1.bb => gcc-sanitizers_12.2.bb} |  0
 ...{gcc-source_12.1.bb => gcc-source_12.2.bb} |  0
 ...rry-pick-9cf13067cb5088626ba7-from-u.patch | 45 -------------------
 .../gcc/{gcc_12.1.bb => gcc_12.2.bb}          |  0
 ...initial_12.1.bb => libgcc-initial_12.2.bb} |  0
 .../gcc/{libgcc_12.1.bb => libgcc_12.2.bb}    |  0
 ...ibgfortran_12.1.bb => libgfortran_12.2.bb} |  0
 13 files changed, 4 insertions(+), 50 deletions(-)
 rename meta/recipes-devtools/gcc/{gcc-12.1.inc => gcc-12.2.inc} (95%)
 rename meta/recipes-devtools/gcc/{gcc-cross-canadian_12.1.bb => gcc-cross-canadian_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-cross_12.1.bb => gcc-cross_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-crosssdk_12.1.bb => gcc-crosssdk_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-runtime_12.1.bb => gcc-runtime_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-sanitizers_12.1.bb => gcc-sanitizers_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{gcc-source_12.1.bb => gcc-source_12.2.bb} (100%)
 delete mode 100644 meta/recipes-devtools/gcc/gcc/0001-libsanitizer-cherry-pick-9cf13067cb5088626ba7-from-u.patch
 rename meta/recipes-devtools/gcc/{gcc_12.1.bb => gcc_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgcc-initial_12.1.bb => libgcc-initial_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgcc_12.1.bb => libgcc_12.2.bb} (100%)
 rename meta/recipes-devtools/gcc/{libgfortran_12.1.bb => libgfortran_12.2.bb} (100%)

Comments

Luca Ceresoli Aug. 23, 2022, 2:49 p.m. UTC | #1
Hi Khem,

On Sat, 20 Aug 2022 09:39:03 -0700
"Khem Raj" <raj.khem@gmail.com> wrote:

> GCC 12.2 is the first bug-fix release from the GCC 12 branch containing
> important fixes for regressions and serious bugs in GCC 12.1 with more
> than 71 bugs fixed since the previous release comprising of  a number
> of libstdc++ and C++ and fortran fixes [1]
> 
> Remove backported patch to fix libsanitizers with glibc 2.36, its
> already present in 12.2
> 
> [1] https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.2
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>

Building with this patch I had a ccache compile failure on musl builds:

  error: 'time_t' has not been declared
  error: no declaration matches 'std::string core::Statistics::format_human_readable(const Config&, time_t, uint8_t, bool) const'

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5735/steps/11/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5752/steps/11/logs/stdio

They disappeared after removing this patch and rebuilding.
Khem Raj Aug. 23, 2022, 5:16 p.m. UTC | #2
thanks Luca

I will take a look today

On Tue, Aug 23, 2022 at 7:49 AM Luca Ceresoli <luca.ceresoli@bootlin.com> wrote:
>
> Hi Khem,
>
> On Sat, 20 Aug 2022 09:39:03 -0700
> "Khem Raj" <raj.khem@gmail.com> wrote:
>
> > GCC 12.2 is the first bug-fix release from the GCC 12 branch containing
> > important fixes for regressions and serious bugs in GCC 12.1 with more
> > than 71 bugs fixed since the previous release comprising of  a number
> > of libstdc++ and C++ and fortran fixes [1]
> >
> > Remove backported patch to fix libsanitizers with glibc 2.36, its
> > already present in 12.2
> >
> > [1] https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&resolution=FIXED&target_milestone=12.2
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
>
> Building with this patch I had a ccache compile failure on musl builds:
>
>   error: 'time_t' has not been declared
>   error: no declaration matches 'std::string core::Statistics::format_human_readable(const Config&, time_t, uint8_t, bool) const'
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5735/steps/11/logs/stdio
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/5752/steps/11/logs/stdio
>
> They disappeared after removing this patch and rebuilding.
>
> --
> Luca Ceresoli, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index c0c38dfc16..47b3e8148e 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -188,7 +188,7 @@  RECIPE_MAINTAINER:pn-gcc-cross-canadian-${TRANSLATED_TARGET_ARCH} = "Khem Raj <r
 RECIPE_MAINTAINER:pn-gcc-crosssdk-${SDK_SYS} = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-gcc-runtime = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-gcc-sanitizers = "Khem Raj <raj.khem@gmail.com>"
-RECIPE_MAINTAINER:pn-gcc-source-12.1.0 = "Khem Raj <raj.khem@gmail.com>"
+RECIPE_MAINTAINER:pn-gcc-source-12.2.0 = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-gconf = "Ross Burton <ross.burton@arm.com>"
 RECIPE_MAINTAINER:pn-gcr = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER:pn-gdb = "Khem Raj <raj.khem@gmail.com>"
diff --git a/meta/recipes-devtools/gcc/gcc-12.1.inc b/meta/recipes-devtools/gcc/gcc-12.2.inc
similarity index 95%
rename from meta/recipes-devtools/gcc/gcc-12.1.inc
rename to meta/recipes-devtools/gcc/gcc-12.2.inc
index 488e0c95b1..572fd8b669 100644
--- a/meta/recipes-devtools/gcc/gcc-12.1.inc
+++ b/meta/recipes-devtools/gcc/gcc-12.2.inc
@@ -2,11 +2,11 @@  require gcc-common.inc
 
 # Third digit in PV should be incremented after a minor release
 
-PV = "12.1.0"
+PV = "12.2.0"
 
 # BINV should be incremented to a revision after a minor gcc release
 
-BINV = "12.1.0"
+BINV = "12.2.0"
 
 FILESEXTRAPATHS =. "${FILE_DIRNAME}/gcc:${FILE_DIRNAME}/gcc/backport:"
 
@@ -64,11 +64,10 @@  SRC_URI = "${BASEURI} \
            file://0024-Fix-install-path-of-linux64.h.patch \
            file://0025-Move-sched.h-include-ahead-of-user-headers.patch \
            file://0026-rust-recursion-limit.patch \
-           file://0001-libsanitizer-cherry-pick-9cf13067cb5088626ba7-from-u.patch \
            file://prefix-map-realpath.patch \
            file://hardcoded-paths.patch \
 "
-SRC_URI[sha256sum] = "62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b"
+SRC_URI[sha256sum] = "e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff"
 
 S = "${TMPDIR}/work-shared/gcc-${PV}-${PR}/${SOURCEDIR}"
 B = "${WORKDIR}/gcc-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_12.1.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-cross-canadian_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-cross-canadian_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc-cross_12.1.bb b/meta/recipes-devtools/gcc/gcc-cross_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-cross_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-cross_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk_12.1.bb b/meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-crosssdk_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-crosssdk_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_12.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-runtime_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-runtime_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc-sanitizers_12.1.bb b/meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-sanitizers_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-sanitizers_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc-source_12.1.bb b/meta/recipes-devtools/gcc/gcc-source_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc-source_12.1.bb
rename to meta/recipes-devtools/gcc/gcc-source_12.2.bb
diff --git a/meta/recipes-devtools/gcc/gcc/0001-libsanitizer-cherry-pick-9cf13067cb5088626ba7-from-u.patch b/meta/recipes-devtools/gcc/gcc/0001-libsanitizer-cherry-pick-9cf13067cb5088626ba7-from-u.patch
deleted file mode 100644
index 6bbc95aa00..0000000000
--- a/meta/recipes-devtools/gcc/gcc/0001-libsanitizer-cherry-pick-9cf13067cb5088626ba7-from-u.patch
+++ /dev/null
@@ -1,45 +0,0 @@ 
-From 2701442d0cf6292f6624443c15813d6d1a3562fe Mon Sep 17 00:00:00 2001
-From: Martin Liska <mliska@suse.cz>
-Date: Mon, 11 Jul 2022 22:03:14 +0200
-Subject: [PATCH] libsanitizer: cherry-pick 9cf13067cb5088626ba7 from upstream
-
-9cf13067cb5088626ba7ee1ec4c42ec59c7995a0 [sanitizer] Remove #include <linux/fs.h> to resolve fsconfig_command/mount_attr conflict with glibc 2.36
-
-Upstream-Status: Backport [https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=2701442d0cf6292f6624443c15813d6d1a3562fe]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- .../sanitizer_platform_limits_posix.cpp                | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
-index 8ed3e92d270..97fd07acf9d 100644
---- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
-+++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp
-@@ -73,7 +73,9 @@
- #include <sys/vt.h>
- #include <linux/cdrom.h>
- #include <linux/fd.h>
-+#if SANITIZER_ANDROID
- #include <linux/fs.h>
-+#endif
- #include <linux/hdreg.h>
- #include <linux/input.h>
- #include <linux/ioctl.h>
-@@ -869,10 +871,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
-   unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
-   unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
- #endif
--  unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
--  unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
--  unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
--  unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
-+  unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
-+  unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
-+  unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
-+  unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
-   unsigned IOCTL_GIO_CMAP = GIO_CMAP;
-   unsigned IOCTL_GIO_FONT = GIO_FONT;
-   unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;
--- 
-2.37.1
-
diff --git a/meta/recipes-devtools/gcc/gcc_12.1.bb b/meta/recipes-devtools/gcc/gcc_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/gcc_12.1.bb
rename to meta/recipes-devtools/gcc/gcc_12.2.bb
diff --git a/meta/recipes-devtools/gcc/libgcc-initial_12.1.bb b/meta/recipes-devtools/gcc/libgcc-initial_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgcc-initial_12.1.bb
rename to meta/recipes-devtools/gcc/libgcc-initial_12.2.bb
diff --git a/meta/recipes-devtools/gcc/libgcc_12.1.bb b/meta/recipes-devtools/gcc/libgcc_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgcc_12.1.bb
rename to meta/recipes-devtools/gcc/libgcc_12.2.bb
diff --git a/meta/recipes-devtools/gcc/libgfortran_12.1.bb b/meta/recipes-devtools/gcc/libgfortran_12.2.bb
similarity index 100%
rename from meta/recipes-devtools/gcc/libgfortran_12.1.bb
rename to meta/recipes-devtools/gcc/libgfortran_12.2.bb