diff mbox series

[5/7] patchelf: update 0.14.5 -> 0.15.0

Message ID 20220811195806.1571221-5-alex@linutronix.de
State Accepted, archived
Commit 0b2f8da3ff9cbbb6fc2ab75fbe09ad1fe745c53b
Headers show
Series [1/7] dropbear: merge .inc into .bb | expand

Commit Message

Alexander Kanavin Aug. 11, 2022, 7:58 p.m. UTC
Rebase handle-read-only-files.patch

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../patchelf/handle-read-only-files.patch     | 30 +++++++++----------
 ...{patchelf_0.14.5.bb => patchelf_0.15.0.bb} |  2 +-
 2 files changed, 15 insertions(+), 17 deletions(-)
 rename meta/recipes-devtools/patchelf/{patchelf_0.14.5.bb => patchelf_0.15.0.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch b/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
index b755a263a4..76ad8d9d4d 100644
--- a/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
+++ b/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
@@ -1,4 +1,4 @@ 
-From 682fb48c137b687477008b68863c2a0b73ed47d1 Mon Sep 17 00:00:00 2001
+From 38b3d65f4a79d39ad9cdf841f2b3b29fd0c961ca Mon Sep 17 00:00:00 2001
 From: Fabio Berton <fabio.berton@ossystems.com.br>
 Date: Fri, 9 Sep 2016 16:00:42 -0300
 Subject: [PATCH] handle read-only files
@@ -9,37 +9,32 @@  https://github.com/darealshinji/patchelf/commit/40e66392bc4b96e9b4eda496827d2634
 Upstream-Status: Denied [https://github.com/NixOS/patchelf/pull/89]
 
 Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
-
 ---
- src/patchelf.cc | 16 +++++++++++++++-
- 1 file changed, 15 insertions(+), 1 deletion(-)
+ src/patchelf.cc | 18 +++++++++++++-----
+ 1 file changed, 13 insertions(+), 5 deletions(-)
 
-Index: git/src/patchelf.cc
-===================================================================
---- git.orig/src/patchelf.cc
-+++ git/src/patchelf.cc
-@@ -534,9 +534,19 @@ void ElfFile<ElfFileParamNames>::sortShd
+diff --git a/src/patchelf.cc b/src/patchelf.cc
+index 49accae..fb6c7ed 100644
+--- a/src/patchelf.cc
++++ b/src/patchelf.cc
+@@ -378,8 +378,16 @@ void ElfFile<ElfFileParamNames>::sortShdrs()
  
  static void writeFile(const std::string & fileName, const FileContents & contents)
  {
 +    struct stat st;
-+    int fd;
 +
      debug("writing %s\n", fileName.c_str());
  
--    int fd = open(fileName.c_str(), O_CREAT | O_TRUNC | O_WRONLY, 0777);
 +    if (stat(fileName.c_str(), &st) != 0)
 +        error("stat");
 +
 +    if (chmod(fileName.c_str(), 0600) != 0)
 +        error("chmod");
 +
-+    fd = open(fileName.c_str(), O_CREAT | O_TRUNC | O_WRONLY, 0777);
-+
+     int fd = open(fileName.c_str(), O_CREAT | O_TRUNC | O_WRONLY | O_BINARY, 0777);
      if (fd == -1)
          error("open");
- 
-@@ -551,8 +561,6 @@ static void writeFile(const std::string
+@@ -395,8 +403,6 @@ static void writeFile(const std::string & fileName, const FileContents & content
          bytesWritten += portion;
      }
  
@@ -48,7 +43,7 @@  Index: git/src/patchelf.cc
      /*
       * Just ignore EINTR; a retry loop is the wrong thing to do.
       *
-@@ -561,9 +569,11 @@ static void writeFile(const std::string
+@@ -405,9 +411,11 @@ static void writeFile(const std::string & fileName, const FileContents & content
       * http://utcc.utoronto.ca/~cks/space/blog/unix/CloseEINTR
       * https://sites.google.com/site/michaelsafyan/software-engineering/checkforeintrwheninvokingclosethinkagain
       */
@@ -63,3 +58,6 @@  Index: git/src/patchelf.cc
  }
  
  
+-- 
+2.30.2
+
diff --git a/meta/recipes-devtools/patchelf/patchelf_0.14.5.bb b/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
similarity index 91%
rename from meta/recipes-devtools/patchelf/patchelf_0.14.5.bb
rename to meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
index 0fa2c00f1d..389a0a9f40 100644
--- a/meta/recipes-devtools/patchelf/patchelf_0.14.5.bb
+++ b/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
@@ -7,7 +7,7 @@  LICENSE = "GPL-3.0-only"
 SRC_URI = "git://github.com/NixOS/patchelf;protocol=https;branch=master \
            file://handle-read-only-files.patch \
            "
-SRCREV = "a35054504293f9ff64539850d1ed0bfd2f5399f2"
+SRCREV = "49008002562355b0e35075cbc1c42c645ff04e28"
 
 S = "${WORKDIR}/git"