diff mbox series

lttng-modules: Fix build failure for kernel v5.15.58

Message ID 20220801085136.38110-1-zhe.he@windriver.com
State Accepted, archived
Commit c6f49f42bb6ffe53c56ef1710e3ea90d8a18fe9d
Headers show
Series lttng-modules: Fix build failure for kernel v5.15.58 | expand

Commit Message

He Zhe Aug. 1, 2022, 8:51 a.m. UTC
Backport from upstream d8254360c7f2ff9b3f945e9668d89c0b56b9bd91
("fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)")

tmp-glibc/work/qemuarm-wrs-linux-gnueabi/lttng-modules/2.13.3-r0/
lttng-modules-2.13.3/src/probes/../../include/lttng/
tracepoint-event-impl.h:133:6:
error: conflicting types for 'trace_kfree_skb'; have 'void(struct sk_buff *, void *)'
  133 | void trace_##_name(_proto);
      |      ^~~~~~

Signed-off-by: He Zhe <zhe.he@windriver.com>
---
 ...oduce-kfree_skb_reason-v5.15.58.v5.1.patch | 51 +++++++++++++++++++
 .../lttng/lttng-modules_2.13.4.bb             |  1 +
 2 files changed, 52 insertions(+)
 create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch

Comments

Luca Ceresoli Aug. 1, 2022, 1:04 p.m. UTC | #1
Hello He,

On Mon,  1 Aug 2022 16:51:36 +0800
"He Zhe" <zhe.he@windriver.com> wrote:

> Backport from upstream d8254360c7f2ff9b3f945e9668d89c0b56b9bd91
> ("fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)")
> 
> tmp-glibc/work/qemuarm-wrs-linux-gnueabi/lttng-modules/2.13.3-r0/
> lttng-modules-2.13.3/src/probes/../../include/lttng/
> tracepoint-event-impl.h:133:6:
> error: conflicting types for 'trace_kfree_skb'; have 'void(struct sk_buff *, void *)'
>   133 | void trace_##_name(_proto);
>       |      ^~~~~~
> 
> Signed-off-by: He Zhe <zhe.he@windriver.com>
> ---
>  ...oduce-kfree_skb_reason-v5.15.58.v5.1.patch | 51 +++++++++++++++++++
>  .../lttng/lttng-modules_2.13.4.bb             |  1 +
>  2 files changed, 52 insertions(+)
>  create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
> 
> diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
> new file mode 100644
> index 0000000000..0140c4b989
> --- /dev/null
> +++ b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
> @@ -0,0 +1,51 @@
> +From d8254360c7f2ff9b3f945e9668d89c0b56b9bd91 Mon Sep 17 00:00:00 2001
> +From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
> +Date: Fri, 29 Jul 2022 15:37:43 -0400
> +Subject: [PATCH] fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)
> +
> +See upstream commit :
> +
> +  commit c504e5c2f9648a1e5c2be01e8c3f59d394192bd3
> +  Author: Menglong Dong <imagedong@tencent.com>
> +  Date:   Sun Jan 9 14:36:26 2022 +0800
> +
> +    net: skb: introduce kfree_skb_reason()
> +
> +    Introduce the interface kfree_skb_reason(), which is able to pass
> +    the reason why the skb is dropped to 'kfree_skb' tracepoint.
> +
> +    Add the 'reason' field to 'trace_kfree_skb', therefor user can get
> +    more detail information about abnormal skb with 'drop_monitor' or
> +    eBPF.
> +
> +    All drop reasons are defined in the enum 'skb_drop_reason', and
> +    they will be print as string in 'kfree_skb' tracepoint in format
> +    of 'reason: XXX'.
> +
> +    ( Maybe the reasons should be defined in a uapi header file, so that
> +    user space can use them? )
> +
> +Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
> +Change-Id: Ib3c039207739dad10f097cf76474e0822e351273

Missing Upstream-status tag here.
He Zhe Aug. 2, 2022, 2:02 a.m. UTC | #2
On 8/1/22 21:04, Luca Ceresoli wrote:
> Hello He,
>
> On Mon,  1 Aug 2022 16:51:36 +0800
> "He Zhe" <zhe.he@windriver.com> wrote:
>
>> Backport from upstream d8254360c7f2ff9b3f945e9668d89c0b56b9bd91
>> ("fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)")
>>
>> tmp-glibc/work/qemuarm-wrs-linux-gnueabi/lttng-modules/2.13.3-r0/
>> lttng-modules-2.13.3/src/probes/../../include/lttng/
>> tracepoint-event-impl.h:133:6:
>> error: conflicting types for 'trace_kfree_skb'; have 'void(struct sk_buff *, void *)'
>>   133 | void trace_##_name(_proto);
>>       |      ^~~~~~
>>
>> Signed-off-by: He Zhe <zhe.he@windriver.com>
>> ---
>>  ...oduce-kfree_skb_reason-v5.15.58.v5.1.patch | 51 +++++++++++++++++++
>>  .../lttng/lttng-modules_2.13.4.bb             |  1 +
>>  2 files changed, 52 insertions(+)
>>  create mode 100644 meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
>>
>> diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
>> new file mode 100644
>> index 0000000000..0140c4b989
>> --- /dev/null
>> +++ b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
>> @@ -0,0 +1,51 @@
>> +From d8254360c7f2ff9b3f945e9668d89c0b56b9bd91 Mon Sep 17 00:00:00 2001
>> +From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
>> +Date: Fri, 29 Jul 2022 15:37:43 -0400
>> +Subject: [PATCH] fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)
>> +
>> +See upstream commit :
>> +
>> +  commit c504e5c2f9648a1e5c2be01e8c3f59d394192bd3
>> +  Author: Menglong Dong <imagedong@tencent.com>
>> +  Date:   Sun Jan 9 14:36:26 2022 +0800
>> +
>> +    net: skb: introduce kfree_skb_reason()
>> +
>> +    Introduce the interface kfree_skb_reason(), which is able to pass
>> +    the reason why the skb is dropped to 'kfree_skb' tracepoint.
>> +
>> +    Add the 'reason' field to 'trace_kfree_skb', therefor user can get
>> +    more detail information about abnormal skb with 'drop_monitor' or
>> +    eBPF.
>> +
>> +    All drop reasons are defined in the enum 'skb_drop_reason', and
>> +    they will be print as string in 'kfree_skb' tracepoint in format
>> +    of 'reason: XXX'.
>> +
>> +    ( Maybe the reasons should be defined in a uapi header file, so that
>> +    user space can use them? )
>> +
>> +Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
>> +Change-Id: Ib3c039207739dad10f097cf76474e0822e351273
> Missing Upstream-status tag here.

Thanks. resent.

Zhe

>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
new file mode 100644
index 0000000000..0140c4b989
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules/0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch
@@ -0,0 +1,51 @@ 
+From d8254360c7f2ff9b3f945e9668d89c0b56b9bd91 Mon Sep 17 00:00:00 2001
+From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+Date: Fri, 29 Jul 2022 15:37:43 -0400
+Subject: [PATCH] fix: net: skb: introduce kfree_skb_reason() (v5.15.58..v5.16)
+
+See upstream commit :
+
+  commit c504e5c2f9648a1e5c2be01e8c3f59d394192bd3
+  Author: Menglong Dong <imagedong@tencent.com>
+  Date:   Sun Jan 9 14:36:26 2022 +0800
+
+    net: skb: introduce kfree_skb_reason()
+
+    Introduce the interface kfree_skb_reason(), which is able to pass
+    the reason why the skb is dropped to 'kfree_skb' tracepoint.
+
+    Add the 'reason' field to 'trace_kfree_skb', therefor user can get
+    more detail information about abnormal skb with 'drop_monitor' or
+    eBPF.
+
+    All drop reasons are defined in the enum 'skb_drop_reason', and
+    they will be print as string in 'kfree_skb' tracepoint in format
+    of 'reason: XXX'.
+
+    ( Maybe the reasons should be defined in a uapi header file, so that
+    user space can use them? )
+
+Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+Change-Id: Ib3c039207739dad10f097cf76474e0822e351273
+---
+ include/instrumentation/events/skb.h | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/include/instrumentation/events/skb.h b/include/instrumentation/events/skb.h
+index 237e54ad..186732ea 100644
+--- a/include/instrumentation/events/skb.h
++++ b/include/instrumentation/events/skb.h
+@@ -13,7 +13,9 @@
+ /*
+  * Tracepoint for free an sk_buff:
+  */
+-#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,17,0))
++#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,17,0) \
++	|| LTTNG_KERNEL_RANGE(5,15,58, 5,16,0))
++
+ LTTNG_TRACEPOINT_ENUM(skb_drop_reason,
+ 	TP_ENUM_VALUES(
+ 		ctf_enum_value("NOT_SPECIFIED",	SKB_DROP_REASON_NOT_SPECIFIED)
+-- 
+2.17.1
+
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.4.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.4.bb
index ea2ec3c380..fea0e383c9 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.4.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.4.bb
@@ -14,6 +14,7 @@  SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
            file://0001-fix-mm-page_alloc-fix-tracepoint-mm_page_alloc_zone_.patch \
            file://0002-fix-fs-Remove-flags-parameter-from-aops-write_begin-.patch \
            file://0003-fix-workqueue-Fix-type-of-cpu-in-trace-event-v5.19.patch \
+           file://0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch \
            "
 
 # Use :append here so that the patch is applied also when using devupstream