diff mbox series

python3-jsonschema: 4.7.1 -> 4.7.2 + fixed the rdepends

Message ID 20220717082953.2651021-1-jan.vermaete@gmail.com
State New
Headers show
Series python3-jsonschema: 4.7.1 -> 4.7.2 + fixed the rdepends | expand

Commit Message

Jan Vermaete July 17, 2022, 8:29 a.m. UTC
And spitted the files for the tests into a -test package

buildhistory:
  images/raspberrypi4_64/glibc/core-image-base: IMAGESIZE changed from 208024 to 183660 (-12%)
  Changes to images/raspberrypi4_64/glibc/core-image-base (installed-package-names.txt):
    python3-pyparsing was removed
    python3-pip was removed
    python3-setuptools-scm was removed
    python3-packaging was removed
    python3-typing-extensions was removed
    python3-pkg-resources was removed
    python3-tomli was removed
    python3-setuptools was removed

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 ...onschema_4.7.1.bb => python3-jsonschema_4.7.2.bb} | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
 rename meta/recipes-devtools/python/{python3-jsonschema_4.7.1.bb => python3-jsonschema_4.7.2.bb} (83%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-jsonschema_4.7.1.bb b/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
similarity index 83%
rename from meta/recipes-devtools/python/python3-jsonschema_4.7.1.bb
rename to meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
index f17f28a57f..af728ab2d6 100644
--- a/meta/recipes-devtools/python/python3-jsonschema_4.7.1.bb
+++ b/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
@@ -4,10 +4,13 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
                     file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
 
-SRC_URI[sha256sum] = "25203dbebd62a1179f810f14339f7a638baaf279b5cc3b738a58c3744af56d65"
+SRC_URI[sha256sum] = "73764f461d61eb97a057c929368610a134d1d1fffd858acfe88864ee94f1f1d3"
 
 inherit pypi python_hatchling
 
+PACKAGES =+ "${PN}-tests"
+FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests"
+
 DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
 
 PACKAGECONFIG ??= "format"
@@ -35,14 +38,11 @@  RDEPENDS:${PN} += " \
     ${PYTHON_PN}-json \
     ${PYTHON_PN}-netclient \
     ${PYTHON_PN}-numbers \
-    ${PYTHON_PN}-pkgutil \
     ${PYTHON_PN}-pprint \
     ${PYTHON_PN}-pyrsistent \
-    ${PYTHON_PN}-shell \
-    ${PYTHON_PN}-six \
-    ${PYTHON_PN}-unittest \
-    ${PYTHON_PN}-setuptools-scm \
     ${PYTHON_PN}-zipp \
 "
 
+RDEPENDS:${PN}-tests = "${PN}"
+
 BBCLASSEXTEND = "native nativesdk"