glibc-tests: not clear BBCLASSEXTEND

Message ID 20220628152228.16791-1-kai.kang@windriver.com
State Accepted, archived
Commit d15975441471c9367b6d8cfa094f093e80f910d4
Headers show
Series glibc-tests: not clear BBCLASSEXTEND | expand

Commit Message

Kai June 28, 2022, 3:22 p.m. UTC
From: Kai Kang <kai.kang@windriver.com>

It clears BBCLASSEXTEND in glibc-tests recipe to remove 'nativesdk'
which is set in glibc recipe. The side effect is that it removes
"${MULTILIBS}" at same time if multilib enabled. Then there will no
multilib version glibc-tests. So only remove 'nativesdk' from
BBCLASSEXTEND rather than clear it.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta/recipes-core/glibc/glibc-tests_2.35.bb | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Richard Purdie June 28, 2022, 4:03 p.m. UTC | #1
On Tue, 2022-06-28 at 23:22 +0800, kai wrote:
> From: Kai Kang <kai.kang@windriver.com>
> 
> It clears BBCLASSEXTEND in glibc-tests recipe to remove 'nativesdk'
> which is set in glibc recipe. The side effect is that it removes
> "${MULTILIBS}" at same time if multilib enabled. Then there will no
> multilib version glibc-tests. So only remove 'nativesdk' from
> BBCLASSEXTEND rather than clear it.
> 
> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>  meta/recipes-core/glibc/glibc-tests_2.35.bb | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-core/glibc/glibc-tests_2.35.bb b/meta/recipes-core/glibc/glibc-tests_2.35.bb
> index 414f8660de..028e83e865 100644
> --- a/meta/recipes-core/glibc/glibc-tests_2.35.bb
> +++ b/meta/recipes-core/glibc/glibc-tests_2.35.bb
> @@ -18,7 +18,8 @@ python __anonymous() {
>         d.setVar("PROVIDES", "${PN} ${PN}-ptest")
>         d.setVar("RPROVIDES", "${PN} ${PN}-ptest")
>  
> -       d.setVar("BBCLASSEXTEND", "")
> +       bbclassextend = d.getVar("BBCLASSEXTEND").replace("nativesdk", "").strip()
> +       d.setVar("BBCLASSEXTEND", bbclassextend)
>         d.setVar("RRECOMMENDS", "")
>         d.setVar("SYSTEMD_SERVICE:nscd", "")
>         d.setVar("SYSTEMD_PACKAGES", "")
> @@ -95,7 +96,7 @@ python populate_packages:prepend () {
>          d.setVar('DEBIAN_NAMES', '')
>  }
>  
> -FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/glibc-tests/*"
> +FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/${PN}/*"
>  
>  EXCLUDE_FROM_SHLIBS = "1"
> 

Have you tested the multilib glibc-tests and been able to use it
successfully?

Cheers,

Richard
Randy MacLeod June 28, 2022, 10:23 p.m. UTC | #2
On 2022-06-28 12:03, Richard Purdie wrote:
> On Tue, 2022-06-28 at 23:22 +0800, kai wrote:
>> From: Kai Kang <kai.kang@windriver.com>
>>
>> It clears BBCLASSEXTEND in glibc-tests recipe to remove 'nativesdk'
>> which is set in glibc recipe. The side effect is that it removes
>> "${MULTILIBS}" at same time if multilib enabled. Then there will no
>> multilib version glibc-tests. So only remove 'nativesdk' from
>> BBCLASSEXTEND rather than clear it.
>>
>> Signed-off-by: Kai Kang <kai.kang@windriver.com>
>> ---
>>   meta/recipes-core/glibc/glibc-tests_2.35.bb | 5 +++--
>>   1 file changed, 3 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta/recipes-core/glibc/glibc-tests_2.35.bb b/meta/recipes-core/glibc/glibc-tests_2.35.bb
>> index 414f8660de..028e83e865 100644
>> --- a/meta/recipes-core/glibc/glibc-tests_2.35.bb
>> +++ b/meta/recipes-core/glibc/glibc-tests_2.35.bb
>> @@ -18,7 +18,8 @@ python __anonymous() {
>>          d.setVar("PROVIDES", "${PN} ${PN}-ptest")
>>          d.setVar("RPROVIDES", "${PN} ${PN}-ptest")
>>   
>> -       d.setVar("BBCLASSEXTEND", "")
>> +       bbclassextend = d.getVar("BBCLASSEXTEND").replace("nativesdk", "").strip()
>> +       d.setVar("BBCLASSEXTEND", bbclassextend)
>>          d.setVar("RRECOMMENDS", "")
>>          d.setVar("SYSTEMD_SERVICE:nscd", "")
>>          d.setVar("SYSTEMD_PACKAGES", "")
>> @@ -95,7 +96,7 @@ python populate_packages:prepend () {
>>           d.setVar('DEBIAN_NAMES', '')
>>   }
>>   
>> -FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/glibc-tests/*"
>> +FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/${PN}/*"
>>   
>>   EXCLUDE_FROM_SHLIBS = "1"
>>
> Have you tested the multilib glibc-tests and been able to use it
> successfully?


If Kai hasn't Naveen will.

../Randy

>
> Cheers,
>
> Richard
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#167350): https://lists.openembedded.org/g/openembedded-core/message/167350
> Mute This Topic: https://lists.openembedded.org/mt/92046086/3616765
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [randy.macleod@windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Kai June 30, 2022, 9:09 a.m. UTC | #3
On 6/29/22 6:23 AM, Randy MacLeod wrote:
> On 2022-06-28 12:03, Richard Purdie wrote:
>> On Tue, 2022-06-28 at 23:22 +0800, kai wrote:
>>> From: Kai Kang <kai.kang@windriver.com>
>>>
>>> It clears BBCLASSEXTEND in glibc-tests recipe to remove 'nativesdk'
>>> which is set in glibc recipe. The side effect is that it removes
>>> "${MULTILIBS}" at same time if multilib enabled. Then there will no
>>> multilib version glibc-tests. So only remove 'nativesdk' from
>>> BBCLASSEXTEND rather than clear it.
>>>
>>> Signed-off-by: Kai Kang <kai.kang@windriver.com>
>>> ---
>>>   meta/recipes-core/glibc/glibc-tests_2.35.bb | 5 +++--
>>>   1 file changed, 3 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/meta/recipes-core/glibc/glibc-tests_2.35.bb 
>>> b/meta/recipes-core/glibc/glibc-tests_2.35.bb
>>> index 414f8660de..028e83e865 100644
>>> --- a/meta/recipes-core/glibc/glibc-tests_2.35.bb
>>> +++ b/meta/recipes-core/glibc/glibc-tests_2.35.bb
>>> @@ -18,7 +18,8 @@ python __anonymous() {
>>>          d.setVar("PROVIDES", "${PN} ${PN}-ptest")
>>>          d.setVar("RPROVIDES", "${PN} ${PN}-ptest")
>>>   -       d.setVar("BBCLASSEXTEND", "")
>>> +       bbclassextend = 
>>> d.getVar("BBCLASSEXTEND").replace("nativesdk", "").strip()
>>> +       d.setVar("BBCLASSEXTEND", bbclassextend)
>>>          d.setVar("RRECOMMENDS", "")
>>>          d.setVar("SYSTEMD_SERVICE:nscd", "")
>>>          d.setVar("SYSTEMD_PACKAGES", "")
>>> @@ -95,7 +96,7 @@ python populate_packages:prepend () {
>>>           d.setVar('DEBIAN_NAMES', '')
>>>   }
>>>   -FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/glibc-tests/*"
>>> +FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/${PN}/*"
>>>     EXCLUDE_FROM_SHLIBS = "1"
>>>
>> Have you tested the multilib glibc-tests and been able to use it
>> successfully?
>
>
> If Kai hasn't Naveen will.

Thanks. I test it on core-image-minimal with multilib enabled.

And 132 test cases of lib32-glibc-tests run, 121 PASS, 10 FAIL and 1 SKIP.

Regards,
Kai

>
> ../Randy
>
>>
>> Cheers,
>>
>> Richard
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#167350): 
>> https://lists.openembedded.org/g/openembedded-core/message/167350
>> Mute This Topic: https://lists.openembedded.org/mt/92046086/3616765
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
>> [randy.macleod@windriver.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>

Patch

diff --git a/meta/recipes-core/glibc/glibc-tests_2.35.bb b/meta/recipes-core/glibc/glibc-tests_2.35.bb
index 414f8660de..028e83e865 100644
--- a/meta/recipes-core/glibc/glibc-tests_2.35.bb
+++ b/meta/recipes-core/glibc/glibc-tests_2.35.bb
@@ -18,7 +18,8 @@  python __anonymous() {
        d.setVar("PROVIDES", "${PN} ${PN}-ptest")
        d.setVar("RPROVIDES", "${PN} ${PN}-ptest")
 
-       d.setVar("BBCLASSEXTEND", "")
+       bbclassextend = d.getVar("BBCLASSEXTEND").replace("nativesdk", "").strip()
+       d.setVar("BBCLASSEXTEND", bbclassextend)
        d.setVar("RRECOMMENDS", "")
        d.setVar("SYSTEMD_SERVICE:nscd", "")
        d.setVar("SYSTEMD_PACKAGES", "")
@@ -95,7 +96,7 @@  python populate_packages:prepend () {
         d.setVar('DEBIAN_NAMES', '')
 }
 
-FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/glibc-tests/*"
+FILES:${PN} = "${PTEST_PATH}/* /usr/src/debug/${PN}/*"
 
 EXCLUDE_FROM_SHLIBS = "1"