elfutils/flex: Disable parallel make ptest compile

Message ID 20220625201335.317473-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 12755e3e771eb2f1628e2b3dd7138c8766973d82
Headers show
Series elfutils/flex: Disable parallel make ptest compile | expand

Commit Message

Richard Purdie June 25, 2022, 8:13 p.m. UTC
The recent change enabling parallel make for ptest compile/install caused
autobuilder failures in these two recipes. Disable parallel make here
for now until someone can debug the race and get it fixed (preferably
upstream).

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/elfutils/elfutils_0.187.bb | 1 +
 meta/recipes-devtools/flex/flex_2.6.4.bb         | 1 +
 2 files changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-devtools/elfutils/elfutils_0.187.bb b/meta/recipes-devtools/elfutils/elfutils_0.187.bb
index 31983dfd6ba..d03da613539 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.187.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.187.bb
@@ -56,6 +56,7 @@  do_compile_ptest() {
 	cd ${B}/tests
 	oe_runmake buildtest-TESTS oecheck
 }
+PTEST_PARALLEL_MAKE = ""
 
 do_install_ptest() {
 	if [ ${PTEST_ENABLED} = "1" ]; then
diff --git a/meta/recipes-devtools/flex/flex_2.6.4.bb b/meta/recipes-devtools/flex/flex_2.6.4.bb
index c7cd9653470..8736b3585e0 100644
--- a/meta/recipes-devtools/flex/flex_2.6.4.bb
+++ b/meta/recipes-devtools/flex/flex_2.6.4.bb
@@ -60,6 +60,7 @@  RDEPENDS:${PN}-ptest += "bash gawk make"
 do_compile_ptest() {
 	oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
 }
+PTEST_PARALLEL_MAKE = ""
 
 do_install_ptest() {
 	mkdir -p ${D}${PTEST_PATH}/build-aux/