[v2] packagegroup-core-ssh-dropbear: Add openssh-sftp-server recommendation

Message ID 20220624135817.259030-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit a98188e83b2c027d99cc38e3367e1ec2a98efbb0
Headers show
Series [v2] packagegroup-core-ssh-dropbear: Add openssh-sftp-server recommendation | expand

Commit Message

Richard Purdie June 24, 2022, 1:58 p.m. UTC
Seems sad to have to do this but openssh is moving to use sftp instead
of scp to move files. This means scp from Fedora 36 will no longer be
able to move files to/from a dropbear based image. This breaks a number
of our key QA tests and I suspect will cause users pain too.

The sftp server from openssh is small (200kb uncompressed) and standalone
so adding it to the packagegroup seems to be the best way to preserve user
sanity. If people really don't want it, they can just use dropbear instead
of the packageground.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb | 1 +
 1 file changed, 1 insertion(+)

v2: Make a reccomentation, tweak commit message

Comments

Luca Ceresoli June 24, 2022, 2:34 p.m. UTC | #1
Hi Richard,

On Fri, 24 Jun 2022 14:58:17 +0100
"Richard Purdie" <richard.purdie@linuxfoundation.org> wrote:

> Seems sad to have to do this but openssh is moving to use sftp instead
> of scp to move files. This means scp from Fedora 36 will no longer be
> able to move files to/from a dropbear based image. This breaks a number
> of our key QA tests and I suspect will cause users pain too.
> 
> The sftp server from openssh is small (200kb uncompressed) and standalone
> so adding it to the packagegroup seems to be the best way to preserve user
> sanity. If people really don't want it, they can just use dropbear instead
> of the packageground.
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  .../recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> v2: Make a reccomentation, tweak commit message
> 
> 
> diff --git a/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb b/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
> index 4f844ad9255..d06c6a56095 100644
> --- a/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
> +++ b/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
> @@ -4,3 +4,4 @@ PR = "r1"
>  inherit packagegroup
>  
>  RDEPENDS:${PN} = "dropbear"
> +RRECOMMENDS:${PN} = "openssh-sftp-server"

This fixes some failures but triggers some new ones:

Error: 
 Problem: package dropbear-dev-2022.82-r0.mips64 requires dropbear = 2022.82-r0, but none of the providers can be installed
  - package dropbear-2022.82-r0.mips64 conflicts with openssh provided by openssh-9.0p1-r0.mips64
  - package openssh-9.0p1-r0.mips64 conflicts with dropbear provided by dropbear-2022.82-r0.mips64
  - package openssh-dev-9.0p1-r0.mips64 requires openssh = 9.0p1-r0, but none of the providers can be installed
  - conflicting requests

https://autobuilder.yoctoproject.org/typhoon/#/builders/37/builds/5414/steps/11/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/62/builds/5414/steps/11/logs/stdio

Patch

diff --git a/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb b/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
index 4f844ad9255..d06c6a56095 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-ssh-dropbear.bb
@@ -4,3 +4,4 @@  PR = "r1"
 inherit packagegroup
 
 RDEPENDS:${PN} = "dropbear"
+RRECOMMENDS:${PN} = "openssh-sftp-server"