e2fsprogs: add alternatives handling of lsattr as well

Message ID 20220608131205.2218528-1-rasmus.villemoes@prevas.dk
State Accepted, archived
Commit 96703961eeb3460e9da26503d7942cc965d1e573
Headers show
Series e2fsprogs: add alternatives handling of lsattr as well | expand

Commit Message

Rasmus Villemoes June 8, 2022, 1:12 p.m. UTC
Building busybox with CONFIG_LSATTR=y and installing that in the same
filesystem as e2fsprogs breaks:

  ERROR: ... do_rootfs: Postinstall scriptlets of ['busybox'] have failed. If the intention is to defer them to first boot,
  then please place them into pkg_postinst_ontarget:${PN} ().
  Deferring to first boot via 'exit 1' is no longer supported.

Fix that by also alternatifying lsattr just as chattr already is.

Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
---
 meta/recipes-devtools/e2fsprogs/e2fsprogs_1.46.5.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Paulo Neves June 8, 2022, 8:09 p.m. UTC | #1
Looks good to me.
Luca Ceresoli June 9, 2022, 7:20 a.m. UTC | #2
Hi Rasmus,

On Wed,  8 Jun 2022 15:12:05 +0200
"Rasmus Villemoes via lists.openembedded.org"
<rasmus.villemoes=prevas.dk@lists.openembedded.org> wrote:
                 ^^^^^^^^^^^

As you can see above, your sender address is getting mangled. This is
not your fault, but it makes applying your patches annoying.

Can you please try to work around that by setting the sendemail.from
parameter in your git config?

You can read the details in this discussion:
https://lists.openembedded.org/g/openembedded-core/message/166515?p=%2C%2C%2C20%2C0%2C0%2C0%3A%3Acreated%2C0%2Crootfs.py%3A+find+.ko.zst+kernel+modules%2C20%2C2%2C0%2C91453338

Thanks you very much!
Rasmus Villemoes June 9, 2022, 10:06 a.m. UTC | #3
On 09/06/2022 09.20, Luca Ceresoli wrote:
> Hi Rasmus,
> 
> On Wed,  8 Jun 2022 15:12:05 +0200
> "Rasmus Villemoes via lists.openembedded.org"
> <rasmus.villemoes=prevas.dk@lists.openembedded.org> wrote:
>                  ^^^^^^^^^^^
> 
> As you can see above, your sender address is getting mangled. This is
> not your fault, but it makes applying your patches annoying.
> 
> Can you please try to work around that by setting the sendemail.from
> parameter in your git config?

Sorry about that, didn't know it.

It's not completely clear if I should put just the email address or the
full "Name <email>" in that configuration item, i.e. whether it's

[sendemail]
        from = rasmus.villemoes@prevas.dk

or

[sendemail]
        from = Rasmus Villemoes <rasmus.villemoes@prevas.dk>

For now I've gone with the latter, please let me know if that's correct.
In any case we'll see if it works the next time I submit a patch.

Rasmus

Patch

diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.46.5.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.46.5.bb
index ec48f419c7a..5b2d1921f08 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.46.5.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.46.5.bb
@@ -51,6 +51,7 @@  do_install () {
 	oe_multilib_header ext2fs/ext2_types.h
 	install -d ${D}${base_bindir}
 	mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
+	mv ${D}${bindir}/lsattr ${D}${base_bindir}/lsattr.e2fsprogs
 
 	install -v -m 755 ${S}/contrib/populate-extfs.sh ${D}${base_sbindir}/
 
@@ -99,10 +100,12 @@  FILES:libe2p = "${base_libdir}/libe2p.so.*"
 FILES:libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
 FILES:${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so ${bindir}/compile_et ${bindir}/mk_cmds"
 
-ALTERNATIVE:${PN} = "chattr"
+ALTERNATIVE:${PN} = "chattr lsattr"
 ALTERNATIVE_PRIORITY = "100"
 ALTERNATIVE_LINK_NAME[chattr] = "${base_bindir}/chattr"
 ALTERNATIVE_TARGET[chattr] = "${base_bindir}/chattr.e2fsprogs"
+ALTERNATIVE_LINK_NAME[lsattr] = "${base_bindir}/lsattr"
+ALTERNATIVE_TARGET[lsattr] = "${base_bindir}/lsattr.e2fsprogs"
 
 ALTERNATIVE:${PN}-doc = "fsck.8"
 ALTERNATIVE_LINK_NAME[fsck.8] = "${mandir}/man8/fsck.8"