[2/4] perl: Add dependency on make-native to avoid race issues

Message ID 20220605122558.270399-2-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 692b7c518637c77804caf7b3cfc60a83afa2e4f4
Headers show
Series [1/4] sanity: Switch to make 4.0 as a minimum version | expand

Commit Message

Richard Purdie June 5, 2022, 12:25 p.m. UTC
Make 4.1 has race issues with double colon usage in makefiles which are common
in MakeMaker generated code in perl. Add a dependency on make-native to avoid
this as it is relaitvely low overhead.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/perl/perl_5.34.1.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.34.1.bb b/meta/recipes-devtools/perl/perl_5.34.1.bb
index 4b9d2e2c501..42bcb8b1bc6 100644
--- a/meta/recipes-devtools/perl/perl_5.34.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.1.bb
@@ -33,6 +33,8 @@  S = "${WORKDIR}/perl-${PV}"
 inherit upstream-version-is-even update-alternatives
 
 DEPENDS += "perlcross-native zlib virtual/crypt"
+# make 4.1 has race issues with the double-colon usage of MakeMaker, see #14096
+DEPENDS += "make-native"
 
 PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"