[1/2] python3-setuptools: upgrade to 62.2.0

Message ID 20220516171045.3049978-1-ross.burton@arm.com
State New
Headers show
Series [1/2] python3-setuptools: upgrade to 62.2.0 | expand

Commit Message

Ross Burton May 16, 2022, 5:10 p.m. UTC
Drop 0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch as
the in-tree copy of sysconfig now simply calls the one in Python, so this
is not needed anymore.

Drop 0001-change-shebang-to-python3.patch as it is patching a file which
never gets executed directly, so is pointless.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 ...nfig-append-STAGING_LIBDIR-python-sy.patch | 35 -------------------
 .../0001-change-shebang-to-python3.patch      | 25 -------------
 ...59.5.0.bb => python3-setuptools_62.2.0.bb} |  7 +---
 3 files changed, 1 insertion(+), 66 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
 delete mode 100644 meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
 rename meta/recipes-devtools/python/{python3-setuptools_59.5.0.bb => python3-setuptools_62.2.0.bb} (87%)

Comments

Alexander Kanavin May 16, 2022, 5:21 p.m. UTC | #1
I'm afraid a bit more fixing is necessary (specifically the
side-porting of the (in)famous 'mikey special'):
https://git.yoctoproject.org/poky-contrib/commit/?h=akanavin/package-version-updates&id=847bfe3baf5a6117ca9e7053502335d0edc68ed6

Alex


On Mon, 16 May 2022 at 19:10, Ross Burton <ross.burton@arm.com> wrote:
>
> Drop 0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch as
> the in-tree copy of sysconfig now simply calls the one in Python, so this
> is not needed anymore.
>
> Drop 0001-change-shebang-to-python3.patch as it is patching a file which
> never gets executed directly, so is pointless.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  ...nfig-append-STAGING_LIBDIR-python-sy.patch | 35 -------------------
>  .../0001-change-shebang-to-python3.patch      | 25 -------------
>  ...59.5.0.bb => python3-setuptools_62.2.0.bb} |  7 +---
>  3 files changed, 1 insertion(+), 66 deletions(-)
>  delete mode 100644 meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
>  delete mode 100644 meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
>  rename meta/recipes-devtools/python/{python3-setuptools_59.5.0.bb => python3-setuptools_62.2.0.bb} (87%)
>
> diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch b/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
> deleted file mode 100644
> index 3150187951d..00000000000
> --- a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
> +++ /dev/null
> @@ -1,35 +0,0 @@
> -From 1ff575308248b183639c8cb14afee7c8572bd2b8 Mon Sep 17 00:00:00 2001
> -From: Tim Orling <timothy.t.orling@intel.com>
> -Date: Wed, 20 Oct 2021 17:38:10 +0000
> -Subject: [PATCH] _distutils/sysconfig: append
> - STAGING_LIBDIR/python-sysconfigdata to sys.path
> -
> -When python modules set SETUPTOOLS_USE_DISTULS='local', this uses the
> -vendored _distutils in setuptools rather than distutils in the Standard
> -Library. This is needed so that target configuration can be used with
> -python3-setuptools-native.
> -
> -Based on python3/0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch
> -from Alex Kanavin <alex.kanavin@gmail.com>
> -
> -Upstream-Status: Inappropriate [oe-specific]
> -
> -Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
> -
> ----
> - setuptools/_distutils/sysconfig.py | 2 ++
> - 1 file changed, 2 insertions(+)
> -
> -diff --git a/setuptools/_distutils/sysconfig.py b/setuptools/_distutils/sysconfig.py
> -index d36d94f..616eb91 100644
> ---- a/setuptools/_distutils/sysconfig.py
> -+++ b/setuptools/_distutils/sysconfig.py
> -@@ -484,6 +484,8 @@ def _init_posix():
> -             multiarch=getattr(sys.implementation, '_multiarch', ''),
> -         ),
> -     )
> -+    if 'STAGING_LIBDIR' in os.environ:
> -+        sys.path.append(os.environ['STAGING_LIBDIR']+'/python-sysconfigdata')
> -     try:
> -         _temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
> -     except ImportError:
> diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch b/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
> deleted file mode 100644
> index 6dcf52771b2..00000000000
> --- a/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
> +++ /dev/null
> @@ -1,25 +0,0 @@
> -From c39d0896930e25c224cc897660fc8511ccae30c8 Mon Sep 17 00:00:00 2001
> -From: Changqing Li <changqing.li@windriver.com>
> -Date: Thu, 23 Apr 2020 10:01:12 +0000
> -Subject: [PATCH] change shebang to python3
> -
> -Upstream-Status: Pending
> -
> -Signed-off-by: Changqing Li <changqing.li@windriver.com>
> ----
> - pkg_resources/_vendor/appdirs.py   | 2 +-
> - 1 files changed, 1 insertions(+), 1 deletions(-)
> -
> -diff --git a/pkg_resources/_vendor/appdirs.py b/pkg_resources/_vendor/appdirs.py
> -index ae67001..933e398 100644
> ---- a/pkg_resources/_vendor/appdirs.py
> -+++ b/pkg_resources/_vendor/appdirs.py
> -@@ -1,4 +1,4 @@
> --#!/usr/bin/env python
> -+#!/usr/bin/env python3
> - # -*- coding: utf-8 -*-
> - # Copyright (c) 2005-2010 ActiveState Software Inc.
> - # Copyright (c) 2013 Eddy Petrișor
> ---
> -2.24.1
> -
> diff --git a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
> similarity index 87%
> rename from meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
> rename to meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
> index f2810e18d31..452ccf73251 100644
> --- a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
> +++ b/meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
> @@ -8,12 +8,7 @@ inherit pypi python_setuptools_build_meta
>
>  SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
>
> -SRC_URI += "\
> -    file://0001-change-shebang-to-python3.patch \
> -    file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \
> -"
> -
> -SRC_URI[sha256sum] = "d144f85102f999444d06f9c0e8c737fd0194f10f2f7e5fdb77573f6e2fa4fad0"
> +SRC_URI[sha256sum] = "ca6ba73b7fd5f734ae70ece8c4c1f7062b07f3352f6428f6277e27c8f5c64237"
>
>  DEPENDS += "${PYTHON_PN}"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#165689): https://lists.openembedded.org/g/openembedded-core/message/165689
> Mute This Topic: https://lists.openembedded.org/mt/91144879/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch b/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
deleted file mode 100644
index 3150187951d..00000000000
--- a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
+++ /dev/null
@@ -1,35 +0,0 @@ 
-From 1ff575308248b183639c8cb14afee7c8572bd2b8 Mon Sep 17 00:00:00 2001
-From: Tim Orling <timothy.t.orling@intel.com>
-Date: Wed, 20 Oct 2021 17:38:10 +0000
-Subject: [PATCH] _distutils/sysconfig: append
- STAGING_LIBDIR/python-sysconfigdata to sys.path
-
-When python modules set SETUPTOOLS_USE_DISTULS='local', this uses the
-vendored _distutils in setuptools rather than distutils in the Standard
-Library. This is needed so that target configuration can be used with
-python3-setuptools-native.
-
-Based on python3/0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch
-from Alex Kanavin <alex.kanavin@gmail.com>
-
-Upstream-Status: Inappropriate [oe-specific]
-
-Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
-
----
- setuptools/_distutils/sysconfig.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/setuptools/_distutils/sysconfig.py b/setuptools/_distutils/sysconfig.py
-index d36d94f..616eb91 100644
---- a/setuptools/_distutils/sysconfig.py
-+++ b/setuptools/_distutils/sysconfig.py
-@@ -484,6 +484,8 @@ def _init_posix():
-             multiarch=getattr(sys.implementation, '_multiarch', ''),
-         ),
-     )
-+    if 'STAGING_LIBDIR' in os.environ:
-+        sys.path.append(os.environ['STAGING_LIBDIR']+'/python-sysconfigdata')
-     try:
-         _temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
-     except ImportError:
diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch b/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
deleted file mode 100644
index 6dcf52771b2..00000000000
--- a/meta/recipes-devtools/python/python3-setuptools/0001-change-shebang-to-python3.patch
+++ /dev/null
@@ -1,25 +0,0 @@ 
-From c39d0896930e25c224cc897660fc8511ccae30c8 Mon Sep 17 00:00:00 2001
-From: Changqing Li <changqing.li@windriver.com>
-Date: Thu, 23 Apr 2020 10:01:12 +0000
-Subject: [PATCH] change shebang to python3
-
-Upstream-Status: Pending
-
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
----
- pkg_resources/_vendor/appdirs.py   | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/pkg_resources/_vendor/appdirs.py b/pkg_resources/_vendor/appdirs.py
-index ae67001..933e398 100644
---- a/pkg_resources/_vendor/appdirs.py
-+++ b/pkg_resources/_vendor/appdirs.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- # -*- coding: utf-8 -*-
- # Copyright (c) 2005-2010 ActiveState Software Inc.
- # Copyright (c) 2013 Eddy Petrișor
--- 
-2.24.1
-
diff --git a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
similarity index 87%
rename from meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
rename to meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
index f2810e18d31..452ccf73251 100644
--- a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_62.2.0.bb
@@ -8,12 +8,7 @@  inherit pypi python_setuptools_build_meta
 
 SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
 
-SRC_URI += "\
-    file://0001-change-shebang-to-python3.patch \
-    file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \
-"
-
-SRC_URI[sha256sum] = "d144f85102f999444d06f9c0e8c737fd0194f10f2f7e5fdb77573f6e2fa4fad0"
+SRC_URI[sha256sum] = "ca6ba73b7fd5f734ae70ece8c4c1f7062b07f3352f6428f6277e27c8f5c64237"
 
 DEPENDS += "${PYTHON_PN}"