[3/3] stress-ng: disable apparmor from the correct spot

Message ID 20220506064155.2106140-3-alex@linutronix.de
State Accepted, archived
Commit 5ab122a79ec3c65c2704b2f47c59b357c425dad0
Headers show
Series [1/3] coreutils: update 9.0 -> 9.1 | expand

Commit Message

Alexander Kanavin May 6, 2022, 6:41 a.m. UTC
do_configure uses the base.bbclass version, which can
call 'make clean', negating the disabling.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb b/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
index ada35dbc4c..e7cc1d1846 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
@@ -20,7 +20,7 @@  RCONFLICTS:${PN} = "stress"
 
 inherit bash-completion
 
-do_configure:prepend() {
+do_compile:prepend() {
     mkdir -p configs
     touch configs/HAVE_APPARMOR
 }